none
Presence unknown for OCS 2007 R2 users on a Lync client RRS feed

  • Question

  • Hi,

      I am in the process of migrating from OCS 2007 R2 to Lync.  The two systems have been running flawlessly for several weeks, and there have been no issues with communication between users of the two systems.

     

      Yesterday, I changed the certificates on the Lync server, and now I have a situation where the Lync users can't see presence from the OCS users.  OCS users can still see Lync presence, and all functionality works between them.

     

      Any ideas how to address this one-way presence situation?

     

     Thanks!

    Tuesday, September 13, 2011 12:24 AM

All replies

  • Check if the new Lync certificate is trusted by OCS.

    Regards,


    Alex Ignatenko | MCITP:Lync 2010, Messaging, Server 2008 | MCTS:UC Voice, Virtualisation, SCCM, SCOM, OCS | MCSE: Security
    Tuesday, September 13, 2011 4:16 PM
  • They're both issued by the same CA.  The only thing I can think of is that maybe the OCS server keeps the equivalent of a "knownhosts" file, and even though the certificate is valid, it doesn't like the fact that it has changed.

    Tuesday, September 13, 2011 6:32 PM
  • Hi Tim,

    Please log onto the OCS 2007 R2 server and check if any errors in the event logs.

    And you could try to reissuing and reassigning Lync certificate.

    Moreover, provide anther post for reference. Hope helps.

    Wednesday, September 14, 2011 8:09 AM
    Moderator
  • If you run OCSlogger and choose to record SIP and S4, you should be able to see a quite detailed log of what is happening. If it is related to establishing the TLS session it should be easy to see there.
    Wednesday, September 14, 2011 4:54 PM
  • Tim mention IMs are flowing between the servers... So I do not think it is MTLS. But MLidholm is right Logger for SIP and S4 can be helpful.

    Regards,


    Alex Ignatenko | MCITP:Lync 2010, Messaging, Server 2008 | MCTS:UC Voice, Virtualisation, SCCM, SCOM, OCS | MCSE: Security
    Wednesday, September 14, 2011 4:59 PM
  • Might be obvious but did you try restarting both Front-End services after re-issuing the Lync certificate?
    Certified IT Professional Lync Server 2010 / Exchange 2007 - http://www.uwictpartner.be
    If you think my post is the answer to your question, please mark it as answer so future visitors can easily find it.
    Thursday, September 15, 2011 8:06 AM
  • Hey guys,

     Thanks for the responses.  I have rebooted both servers.  I'll use the OCSlogger to try and diagnose the problem.

     

      Will get back to you.

     

     -Tim


    • Edited by Tim Hanks Thursday, September 15, 2011 11:34 PM
    Thursday, September 15, 2011 11:03 PM
  • Hey guys,

      I took some traces, and I can't find anything obvious.  There are very few errors on ether Lync, or OCS.

     

      Any idea what messages I should be looking for that pertain to presence?  There seem to be messages inbound and outbound for all the OCS and Lync users in my organization.  No errors on those.  I assume those are presence exchanges.  The question is, why do our Lync clients say "Updating Presence..." for all the OCS users...

     

     Hmmmm...

     

     -Tim

    Friday, September 16, 2011 6:44 PM