none
Disable "Your search might be slow because indexing is not running" message RRS feed

  • Question

  • Hello,

    Is there any way to disable the "Your search might be slow because indexing is not running. Click to turn on the index" message?

    screenshot

    I have disabled windows search service for performance consideration, but this message bar appears every time I am searching for files, and even if I clicking the cross on the right of the bar, next time when I am doing another search it re-appears.

    How can I permanently disable it, by registry or other means?

     

    Bob

    Thursday, December 2, 2010 3:56 AM

Answers

  • Hi Bob,

     

    I would like to say that this notification will pop up if you disable the Windows Search Service. You can click the bar to turn on the Index and the notification will disappear.

     

    If you would like to not turn on the Index and still want to disable the Windows Search Service, I think we cannot remove this alert.

     

    Regards,

     

    Sabrina


    This posting is provided "AS IS" with no warranties or guarantees, and confers no rights. |Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Bob Sun Wednesday, December 8, 2010 1:28 PM
    Tuesday, December 7, 2010 7:54 AM
  • Search ( via the search service that you have disabled ) can be speed up by fine tuning the locations the service is indexing. By default it adds all Home Folders, all public folders, all shared folders, outlook 2007 inboxes, IE8 favorites and RSS stores..

     

    In my case I have a picture subfolder with flickr jpgs, over 16000. Excluding this specific folder plus the public ones makes a difference.

     

    You can also go to the setting for the startmenue and disable search for files and emails there. So that a search in the menu will really only show programs, not any personal stuff. ( Search for files is then only possible within the upper right search box inside the explorer windows ).

     

    Otherwise its true : the annoying message "search might be slow" .. cannot be turned off. It is to remind people to turn ON search. Indexed searches *are in fact* faster. That is so..

    With enough memory and on a dualcore it really does not impact performance that much as everybody says. For comparison : Windows Search 4.0 in Vista Sp2 is per se the same engine as in Windows7, and in Win7 it does index even more and agressively like in Vista. It just does it a bit different and has support for more porotocols. But it is really the same.

     

    If you want to tune Vistas performance I would start elsewhere. Turning off search is no good idea to achieve higher performance.

    • Marked as answer by Bob Sun Saturday, December 11, 2010 12:46 PM
    Friday, December 10, 2010 12:10 PM

All replies

  • Hi Bob,

     

    Let’s try the following suggestions to troubleshoot the issue:

     

    Suggestion 1: Rebuild the Index

    -------------------------------

    1.   Open the Control Panel.

    2.   In the Instant Search box, type Index.

    3.   Click on Indexing Options.

    4.   Click on Run as Administrator and allow the privileges.

    5.   Click on Advanced, then Rebuild.

     

    Suggestion 2: Enable the Windows Search service

    -----------------------------------------------

    1.   Click Start, type services.msc and press Enter.

    2.   Double click on Windows Search.

    3.   Set the Startup Type to Disabled and click OK.

    4.   Restart Windows.

     

    Suggestion 3: Test the issue in Clean Boot.

     

    Hope it helps.

     

    Regards,

     

    Sabrina

     


    This posting is provided "AS IS" with no warranties or guarantees, and confers no rights. |Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, December 3, 2010 8:36 AM
  • Dear Sabrina,

    But what I want is to disable search and also let this message bar never appear again. Is there a solution?

     

    Bob

    Friday, December 3, 2010 7:16 PM
  • Hi Bob,

     

    I would like to say that this notification will pop up if you disable the Windows Search Service. You can click the bar to turn on the Index and the notification will disappear.

     

    If you would like to not turn on the Index and still want to disable the Windows Search Service, I think we cannot remove this alert.

     

    Regards,

     

    Sabrina


    This posting is provided "AS IS" with no warranties or guarantees, and confers no rights. |Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Bob Sun Wednesday, December 8, 2010 1:28 PM
    Tuesday, December 7, 2010 7:54 AM
  • Dear Sabrina,

    Thanks for this confirmation.

     

    Bob

    Wednesday, December 8, 2010 1:28 PM
  • Search ( via the search service that you have disabled ) can be speed up by fine tuning the locations the service is indexing. By default it adds all Home Folders, all public folders, all shared folders, outlook 2007 inboxes, IE8 favorites and RSS stores..

     

    In my case I have a picture subfolder with flickr jpgs, over 16000. Excluding this specific folder plus the public ones makes a difference.

     

    You can also go to the setting for the startmenue and disable search for files and emails there. So that a search in the menu will really only show programs, not any personal stuff. ( Search for files is then only possible within the upper right search box inside the explorer windows ).

     

    Otherwise its true : the annoying message "search might be slow" .. cannot be turned off. It is to remind people to turn ON search. Indexed searches *are in fact* faster. That is so..

    With enough memory and on a dualcore it really does not impact performance that much as everybody says. For comparison : Windows Search 4.0 in Vista Sp2 is per se the same engine as in Windows7, and in Win7 it does index even more and agressively like in Vista. It just does it a bit different and has support for more porotocols. But it is really the same.

     

    If you want to tune Vistas performance I would start elsewhere. Turning off search is no good idea to achieve higher performance.

    • Marked as answer by Bob Sun Saturday, December 11, 2010 12:46 PM
    Friday, December 10, 2010 12:10 PM
  • Dear Smartie77nrw,

    Thanks for the information.

     

    Bob

    Saturday, December 11, 2010 12:46 PM
  • I think I have fixed your problem:

     

    Go to your Folder Options (From any window directory menu) Tools=> Folder Options. (You may have to press the Alt key to view this menu.)

     

    In the folder options dialogue go to "Search"

     

    In "What to Search" Select "Always Search File Names..."

     

    In "How to search" highlight "Dont use the index when searching..."

     

    Peace

    • Proposed as answer by POPCORNS 1068 Monday, May 2, 2016 5:56 PM
    Thursday, January 13, 2011 9:55 AM
  • Hi. The answer is simple! right click on message and choice never show it again! That is all! Good luck any more PC questions Fill free moycraigslist@yahoo.com

    • Proposed as answer by EdrickV Monday, May 28, 2012 8:02 PM
    Monday, April 4, 2011 6:11 AM
  • Not in Vista.
    Friday, June 15, 2012 12:44 PM
  • Not in Vista.
    Friday, June 15, 2012 12:44 PM
  • Hi Bob,

    A bit late but nevertheless :-)

    It's a reistry setting:

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\InfoBarsDisabled]
    "ServerMSSNotInstalled"=dword:00000001

    --

    Louis Göhl

    @louisgohl

    Wednesday, May 29, 2013 8:56 AM
  • Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\InfoBarsDisabled]
    "ServerMSSNotInstalled"=dword:00000001

    --

    Louis Göhl

    Hello, this registry hack doesn't work on Windows 7 and Outlook 2016.

    So I decided to turn on indexing (although have OS on the SSD) and in index locations I'm keeping only Microsoft Outlook (which is self-inserted automatically).


    ----- Lukas -----

    Friday, September 9, 2016 8:10 AM
  • Many thanks. I've been looking for a solution for a long time and this has worked perfectly for me.
    Wednesday, February 28, 2018 5:32 PM