none
Microsoft Outlook PST file too big

    Question

  • I am working in outlook 2010 and my pst file is too large and I am trying to change the Max File Size. I went to the microsoft Knowledge Base KB#832925 but the referenced registry entries are not there.
    Thursday, March 22, 2012 2:57 PM

Answers

  • That is because they don't exist by default and you need to create them manually.

    That said, are you sure that you are using a Unicode pst-file? What is the size of your pst-file now?

    If you are still using an ANSI formatted pst-file, then the Registry keys won't help you and you need to convert to a Unicode pst-file. See; http://www.msoutlook.info/question/115

    If you are using a hard drive which formatted as FAT32 instead of NTFS, the maximum file size limit is 4GB.
    See; http://www.msoutlook.info/question/70

    If it is indeed a Unicode pst-file on an NTFS drive, you might want to reconsider if you really want to make the file even larger or simply start with an additional pst-file; Home-> New Items-> More Items-> Outlook Data File...



    Robert Sparnaaij [MVP-Outlook]
    Outlook guides and more: HowTo-Outlook.com
    Outlook Quick Tips: MSOutlook.info

    Thursday, March 22, 2012 3:30 PM

All replies

  • That is because they don't exist by default and you need to create them manually.

    That said, are you sure that you are using a Unicode pst-file? What is the size of your pst-file now?

    If you are still using an ANSI formatted pst-file, then the Registry keys won't help you and you need to convert to a Unicode pst-file. See; http://www.msoutlook.info/question/115

    If you are using a hard drive which formatted as FAT32 instead of NTFS, the maximum file size limit is 4GB.
    See; http://www.msoutlook.info/question/70

    If it is indeed a Unicode pst-file on an NTFS drive, you might want to reconsider if you really want to make the file even larger or simply start with an additional pst-file; Home-> New Items-> More Items-> Outlook Data File...



    Robert Sparnaaij [MVP-Outlook]
    Outlook guides and more: HowTo-Outlook.com
    Outlook Quick Tips: MSOutlook.info

    Thursday, March 22, 2012 3:30 PM
  • Hi,

    Just checking in to see if the information provided by Roady[MVP] was helpful. Please let us know if you would like further assistance.


    Max Meng

    TechNet Community Support

    Tuesday, March 27, 2012 2:11 PM
    Moderator
  • Hi, 

    I'm marking the reply as answer as there has been no update for a couple of days. Please let us know if you would like further assistance.


    Max Meng

    TechNet Community Support

    Tuesday, April 03, 2012 2:44 PM
    Moderator
  • I am understanding you are using Outlook 2010 and haveing problem in changing its Max File Size.For this problem just open the Registry Editor. and follow these steps

    open Run command (Win+R), enter "regedit" in the search box and hit the enter

    Step 1: On Registry  Editor click HKEY_CURRENT_USER(You need to navigate to the following registry path according to your Outlook version:)

    for single users

    • HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\PST for Outlook 2010

    for administrators

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Outlook\PST for Outlook 2010

    Step 2: Click PST in the options

    note: - If you can’t see the PST key under Outlook key, create it manually. To do that:

    • Right-click on the blank space, and select New > Key in the options. Give it a name.
    • Now double-click at PST key, and find these two values in the right pane:
      1. MaxLargeFileSize
      2. WarnLargeFileSize

    Step 3: Now double-click MaxLargeFileSize value in the list.

    Now define the value data (in MB) and its base.

    you’re using Outlook 2010 or later version, the default PST file size limit is 50 GB. Make sure you specify a size over 50 GB.

    Step 4: Then double-click WarnLargeFileSize value in the list.

    Now again define the value data (in MB) and its base.

    For more Information, you can read "N. Sem's Blog" on the Internet



    Tuesday, June 27, 2017 7:57 AM