none
My Site creation failure for new My Sites

    Question

  • I've previously had users creating My Sites just fine.  I had installed the August 2011 CU last Friday evening, so I'm not sure if it had anything to do with this, but now when any user who doesn't already have their My Site created tries to click on My Content and it starts provisioning, it kicks back with:

    There has been an error creating the personal site. Contact your site administrator for more information.

    Event log shows two errors:

    6141: The site /personal/dld could not be created. The following exception occurred: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)).

    5187: My Site creation failure for user '<domain>\dld' for site url 'http://my/personal/dld'. The exception was: Microsoft.Office.Server.UserProfiles.PersonalSiteCreateException: A failure was encountered while attempting to create the site. ---> System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

    at Microsoft.SharePoint.Library.SPRequest.ApplyWebTemplate(String bstrUrl, String bstrWebTemplateContent, Int32 fWebTemplateContentFromSubweb, Int32 fDeleteGlobalListsWithWebTemplateContent, String& bstrWebTemplate, Int32& plWebTemplateId)

    at Microsoft.SharePoint.SPWeb.ApplyWebTemplate(String strWebTemplate)

    at Microsoft.SharePoint.Administration.SPSiteCollection.Add(SPContentDatabase database, SPSiteSubscription siteSubscription, String siteUrl, String title, String description, UInt32 nLCID, String webTemplate, String ownerLogin, String ownerName, String ownerEmail, String secondaryContactLogin, String secondaryContactName, String secondaryContactEmail, String quotaTemplate, String sscRootWebUrl, Boolean useHostHeaderAsSiteName)

    at Microsoft.SharePoint.SPSite.SelfServiceCreateSite(String siteUrl, String title, String description, UInt32 nLCID, String webTemplate, String ownerLogin, String ownerName, String ownerEmail, String contactLogin, String contactName, String contactEmail, String quotaTemplate, SPSiteSubscription siteSubscription)

    at Microsoft.Office.Server.UserProfiles.UserProfile.<>c__DisplayClass2.<CreateSite>b__0()

    --- End of inner exception stack trace ---

    at Microsoft.Office.Server.UserProfiles.UserProfile.<>c__DisplayClass2.<CreateSite>b__0()

    at Microsoft.SharePoint.SPSecurity.<>c__DisplayClass4.<RunWithElevatedPrivileges>b__2()

    at Microsoft.SharePoint.Utilities.SecurityContext.RunAsProcess(CodeToRunElevated secureCode)

    at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(WaitCallback secureCode, Object param)

    at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(CodeToRunElevated secureCode)

    at Microsoft.Office.Server.UserProfiles.UserProfile.CreateSite(String strRequestUrl, Boolean bCollision, Int32 lcid).

     

    The ULS Viewer shows for the provisioning of the My Site:

    09/15/2011 11:13:32.74 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation General 75f8 Medium Feature Activation: Feature 'CTypes' (ID: '695b6570-a48b-4a8e-8ea5-26ea7fc1d162') was activated at URL http://my/personal/dld. 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:32.74 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation Monitoring b4ly High Leaving Monitored Scope (Feature Activation: Activating Feature 'CTypes' (ID: '695b6570-a48b-4a8e-8ea5-26ea7fc1d162') at URL http://my/personal/dld.). Execution Time=379.409394210717 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:32.75 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation Fields 88y1 Medium No document templates uploaded for list "$Resources:core,global_onet_solutiongallery_list;" -- none found for list template "100". 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:32.83 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation Fields 88y1 Medium No document templates uploaded for list "$Resources:core,MasterPageGallery;" -- none found for list template "100". 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:32.89 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation Fields 88y0 Medium Creating UserInfoList for web "/personal/dld". 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:32.94 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation Fields 88y4 Medium Creating UserInfoList for web "http://my/personal/dld".Open the list, copy users and groups to the list and set it to have unique scope. Trying to open the UserInfoList. 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:32.94 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation Fields 88y6 Medium Creating UserInfoList for web "http://my/personal/dld". Trying to copy users and groups to userInfoList. 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:32.98 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation Fields 88y8 Medium Creating UserInfoList for web "http://my/personal/dld". Trying to make the list to have unique security scope. 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:32.98 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation General bj8s Medium setSecurityScopeUnique: start 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:32.98 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation General bj8u Medium setSecurityScopeUnique: start sproc 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:32.99 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation General bj8v Medium setSecurityScopeUnique: succeeded 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:32.99 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation General bj8w Medium setSecurityScopeUnique: finished 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:32.99 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation Fields 88ya Medium Creating UserInfoList for web "http://my/personal/dld". Succeeded. 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:33.00 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation Fields 88y1 Medium No document templates uploaded for list "$Resources:core,webpartgalleryList;" -- none found for list template "100". 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:33.05 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation Fields 88y1 Medium No document templates uploaded for list "$Resources:core,listtemplategalleryList;" -- none found for list template "100". 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:33.08 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation Fields 88y1 Medium No document templates uploaded for list "$Resources:core,themegalleryList;" -- none found for list template "100". 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:33.13 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation Fields 88xz High Failed to find <ListTemplate> tag corresponding to ID "101", tried both onet.xml for site definition ID "0" language "1033" and global site definition.  Operation failed. 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:33.13 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation Fields 88yt High GetUserListSchema(): Failed to get the list schema XML for feature '(null)', template '101': hr=0x8102007B. 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:33.16 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation Fields 88y1 Medium No document templates uploaded for list "$Resources:core,stylelibraryList;" -- none found for list template "121". 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:33.18 w3wp.exe (0x1534) 0x0F24 SharePoint Foundation Topology e5mc Medium WcfSendRequest: RemoteAddress: 'http://sharepoint:32843/5279f92afec84a71a039062f9489a408/MetadataWebService.svc' Channel: 'Microsoft.SharePoint.Taxonomy.IMetadataWebServiceApplication' Action: 'http://schemas.microsoft.com/sharepoint/taxonomy/soap/IDataAccessReadOnly/GetChanges' MessageId: 'urn:uuid:a651795a-f1ba-46b2-87b4-a1e489047867' 
    09/15/2011 11:13:33.18 w3wp.exe (0x1FA4) 0x2624 SharePoint Foundation Topology e5mb Medium WcfReceiveRequest: LocalAddress: 'http://sharepoint.<domain>.local:32843/5279f92afec84a71a039062f9489a408/MetadataWebService.svc' Channel: 'System.ServiceModel.Channels.ServiceChannel' Action: 'http://schemas.microsoft.com/sharepoint/taxonomy/soap/IDataAccessReadOnly/GetChanges' MessageId: 'urn:uuid:a651795a-f1ba-46b2-87b4-a1e489047867' 9fcb8d97-f838-4251-93e6-8fc33cde4208
    09/15/2011 11:13:33.18 w3wp.exe (0x1FA4) 0x2624 SharePoint Foundation Monitoring nasq Medium Entering monitored scope (ExecuteWcfServerOperation) 9fcb8d97-f838-4251-93e6-8fc33cde4208
    09/15/2011 11:13:33.18 w3wp.exe (0x1FA4) 0x2624 SharePoint Server Taxonomy fuc5 Medium MetadataWebServiceApplication.GetChanges called on 'Managed Metadata Service Application' starting. 9fcb8d97-f838-4251-93e6-8fc33cde4208
    09/15/2011 11:13:33.19 w3wp.exe (0x1FA4) 0x2624 SharePoint Server Taxonomy fuc6 Medium MetadataWebServiceApplication.GetChanges called on 'Managed Metadata Service Application' completed. 9fcb8d97-f838-4251-93e6-8fc33cde4208
    09/15/2011 11:13:33.19 w3wp.exe (0x1FA4) 0x2624 SharePoint Foundation Monitoring b4ly Medium Leaving Monitored Scope (ExecuteWcfServerOperation). Execution Time=1.59070496389904 9fcb8d97-f838-4251-93e6-8fc33cde4208
    09/15/2011 11:13:33.39 OWSTIMER.EXE (0x1D04) 0x21B4 SharePoint Foundation Monitoring nasq Medium Entering monitored scope (Timer Job SchedulingUnpublish) 3336caed-970a-44de-856e-337d0262b79a
    09/15/2011 11:13:33.39 OWSTIMER.EXE (0x1D04) 0x21B4 SharePoint Foundation Monitoring b4ly Medium Leaving Monitored Scope (Timer Job SchedulingUnpublish). Execution Time=1.97958120375634 3336caed-970a-44de-856e-337d0262b79a
    09/15/2011 11:13:33.85 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation General 8kh7 High A user may not remove his or her own account from a site collection. 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:33.85 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation General 85m6 Medium Applying web template 'SPSPERS#0' on web url 'http://my/personal/dld' 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:33.85 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation General 85m7 Medium Actual web template to apply to Url 'http://my/personal/dld' is 'SPSPERS#0' 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:33.85 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation General 8e2s Medium Unknown SPRequest error occurred. More information: 0x80070005 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:33.85 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation Topology c977 Unexpected Exception attempting to ApplyWebTemplate to SPSite http://my/personal/dld: System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))     at Microsoft.SharePoint.Library.SPRequest.ApplyWebTemplate(String bstrUrl, String bstrWebTemplateContent, Int32 fWebTemplateContentFromSubweb, Int32 fDeleteGlobalListsWithWebTemplateContent, String& bstrWebTemplate, Int32& plWebTemplateId)     at Microsoft.SharePoint.SPWeb.ApplyWebTemplate(String strWebTemplate)     at Microsoft.SharePoint.Administration.SPSiteCollection.Add(SPContentDatabase database, SPSiteSubscription siteSubscription, String siteUrl, String title, String description, UInt32 nLCID, String webTemplate, String ownerLogin, String ownerName, String ownerEmail, String secondaryContactLogin, String secondaryContactName, String secondaryContactEmail, String quotaTemplate, String sscRootWebUrl, Boolean useHostHeaderAsSiteName) Attempting to delete the site collection. 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:33.85 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation General 8e11 High Deleting the site at http://my/personal/dld and not deleting AD accounts. 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:34.47 w3wp.exe (0x23A4) 0x143C SharePoint Foundation Topology e5mc Medium WcfSendRequest: RemoteAddress: 'http://sharepoint:32843/5279f92afec84a71a039062f9489a408/MetadataWebService.svc' Channel: 'Microsoft.SharePoint.Taxonomy.IMetadataWebServiceApplication' Action: 'http://schemas.microsoft.com/sharepoint/taxonomy/soap/IDataAccessReadOnly/GetChanges' MessageId: 'urn:uuid:8c5da5f0-0ebf-40b9-8f74-90cd0409c798' 
    09/15/2011 11:13:34.47 w3wp.exe (0x1FA4) 0x245C SharePoint Foundation Topology e5mb Medium WcfReceiveRequest: LocalAddress: 'http://sharepoint.<domain>.local:32843/5279f92afec84a71a039062f9489a408/MetadataWebService.svc' Channel: 'System.ServiceModel.Channels.ServiceChannel' Action: 'http://schemas.microsoft.com/sharepoint/taxonomy/soap/IDataAccessReadOnly/GetChanges' MessageId: 'urn:uuid:8c5da5f0-0ebf-40b9-8f74-90cd0409c798' 2b7c37ec-6b10-4562-b376-8725c1c155a2
    09/15/2011 11:13:34.47 w3wp.exe (0x1FA4) 0x245C SharePoint Foundation Monitoring nasq Medium Entering monitored scope (ExecuteWcfServerOperation) 2b7c37ec-6b10-4562-b376-8725c1c155a2
    09/15/2011 11:13:34.47 w3wp.exe (0x1FA4) 0x245C SharePoint Server Taxonomy fuc5 Medium MetadataWebServiceApplication.GetChanges called on 'Managed Metadata Service Application' starting. 2b7c37ec-6b10-4562-b376-8725c1c155a2
    09/15/2011 11:13:34.47 w3wp.exe (0x1FA4) 0x245C SharePoint Server Taxonomy fuc6 Medium MetadataWebServiceApplication.GetChanges called on 'Managed Metadata Service Application' completed. 2b7c37ec-6b10-4562-b376-8725c1c155a2
    09/15/2011 11:13:34.47 w3wp.exe (0x1FA4) 0x245C SharePoint Foundation Monitoring b4ly Medium Leaving Monitored Scope (ExecuteWcfServerOperation). Execution Time=1.00152393670145 2b7c37ec-6b10-4562-b376-8725c1c155a2
    09/15/2011 11:13:34.93 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation Topology 6141 Critical The site /personal/dld could not be created.  The following exception occurred: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)). 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:34.93 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation Monitoring b4ly High Leaving Monitored Scope (Creating Site David Dukes). Execution Time=3076.75137482557 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:34.93 w3wp.exe (0x1534) 0x1CB0 SharePoint Portal Server User Profiles ogvf High Failed to create personal site (<domain>\dld, http://my/personal/dld): System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))     at Microsoft.SharePoint.Library.SPRequest.ApplyWebTemplate(String bstrUrl, String bstrWebTemplateContent, Int32 fWebTemplateContentFromSubweb, Int32 fDeleteGlobalListsWithWebTemplateContent, String& bstrWebTemplate, Int32& plWebTemplateId)     at Microsoft.SharePoint.SPWeb.ApplyWebTemplate(String strWebTemplate)     at Microsoft.SharePoint.Administration.SPSiteCollection.Add(SPContentDatabase database, SPSiteSubscription siteSubscription, String siteUrl, String title, String description, UInt32 nLCID, String webTemplate, String ownerLogin, String ownerName, String ownerEmail, String secondaryContactLogin, String secondaryContactName, String secondaryContactEmail, String quotaTemplate, String sscRootWebUrl, Boolean useHostHeaderAsSiteName)     at Microsoft.SharePoint.SPSite.SelfServiceCreateSite(String siteUrl, String title, String description, UInt32 nLCID, String webTemplate, String ownerLogin, String ownerName, String ownerEmail, String contactLogin, String contactName, String contactEmail, String quotaTemplate, SPSiteSubscription siteSubscription)     at Microsoft.Office.Server.UserProfiles.UserProfile.<>c__DisplayClass2.<CreateSite>b__0(). 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:34.93 w3wp.exe (0x1480) 0x0D28 SharePoint Foundation Topology e5mc Medium WcfSendRequest: RemoteAddress: 'http://sharepoint:32843/5279f92afec84a71a039062f9489a408/MetadataWebService.svc' Channel: 'Microsoft.SharePoint.Taxonomy.IMetadataWebServiceApplication' Action: 'http://schemas.microsoft.com/sharepoint/taxonomy/soap/IDataAccessReadOnly/GetChanges' MessageId: 'urn:uuid:f6f85fa5-1259-42e4-bc0f-d0fbfd8e47c3' 
    09/15/2011 11:13:34.93 w3wp.exe (0x1534) 0x1CB0 SharePoint Portal Server Administration 5187 Critical My Site creation failure for user '<domain>\dld' for site url 'http://my/personal/dld'. The exception was: Microsoft.Office.Server.UserProfiles.PersonalSiteCreateException: A failure was encountered while attempting to create the site. ---> System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))     at Microsoft.SharePoint.Library.SPRequest.ApplyWebTemplate(String bstrUrl, String bstrWebTemplateContent, Int32 fWebTemplateContentFromSubweb, Int32 fDeleteGlobalListsWithWebTemplateContent, String& bstrWebTemplate, Int32& plWebTemplateId)     at Microsoft.SharePoint.SPWeb.ApplyWebTemplate(String strWebTemplate)     at Microsoft.SharePoint.Administration.SPSiteCollection.Add(SPContentDatabase database, SPSiteSubscription siteSubscription, String siteUrl, String title, String description, UInt32 nLCID, String webTemplate, String ownerLogin, String ownerName, String ownerEmail, String secondaryContactLogin, String secondaryContactName, String secondaryContactEmail, String quotaTemplate, String sscRootWebUrl, Boolean useHostHeaderAsSiteName)     at Microsoft.SharePoint.SPSite.SelfServiceCreateSite(String siteUrl, String title, String description, UInt32 nLCID, String webTemplate, String ownerLogin, String ownerName, String ownerEmail, String contactLogin, String contactName, String contactEmail, String quotaTemplate, SPSiteSubscription siteSubscription)     at Microsoft.Office.Server.UserProfiles.UserProfile.<>c__DisplayClass2.<CreateSite>b__0()     --- End of inner exception stack trace ---     at Microsoft.Office.Server.UserProfiles.UserProfile.<>c__DisplayClass2.<CreateSite>b__0()     at Microsoft.SharePoint.SPSecurity.<>c__DisplayClass4.<RunWithElevatedPrivileges>b__2()     at Microsoft.SharePoint.Utilities.SecurityContext.RunAsProcess(CodeToRunElevated secureCode)     at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(WaitCallback secureCode, Object param)     at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(CodeToRunElevated secureCode)     at Microsoft.Office.Server.UserProfiles.UserProfile.CreateSite(String strRequestUrl, Boolean bCollision, Int32 lcid). 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:34.93 w3wp.exe (0x1534) 0x1CB0 SharePoint Foundation Monitoring b4ly High Leaving Monitored Scope (UserProfile.CreatePersonalSite() for '<domain>\dld'). Execution Time=3083.66482332252 0eafe286-3643-4115-8ba2-c09244609542
    09/15/2011 11:13:34.93 w3wp.exe (0x1534) 0x1CB0 SharePoint Portal Server User Profiles ogsj High Exception while creating personal site for '<domain>\dld': Microsoft.Office.Server.UserProfiles.PersonalSiteCreateException: A failure was encountered while attempting to create the site. ---> System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))     at Microsoft.SharePoint.Library.SPRequest.ApplyWebTemplate(String bstrUrl, String bstrWebTemplateContent, Int32 fWebTemplateContentFromSubweb, Int32 fDeleteGlobalListsWithWebTemplateContent, String& bstrWebTemplate, Int32& plWebTemplateId)     at Microsoft.SharePoint.SPWeb.ApplyWebTemplate(String strWebTemplate)     at Microsoft.SharePoint.Administration.SPSiteCollection.Add(SPContentDatabase database, SPSiteSubscription siteSubscription, String siteUrl, String title, String description, UInt32 nLCID, String webTemplate, String ownerLogin, String ownerName, String ownerEmail, String secondaryContactLogin, String secondaryContactName, String secondaryContactEmail, String quotaTemplate, String sscRootWebUrl, Boolean useHostHeaderAsSiteName)     at Microsoft.SharePoint.SPSite.SelfServiceCreateSite(String siteUrl, String title, String description, UInt32 nLCID, String webTemplate, String ownerLogin, String ownerName, String ownerEmail, String contactLogin, String contactName, String contactEmail, String quotaTemplate, SPSiteSubscription siteSubscription)     at Microsoft.Office.Server.UserProfiles.UserProfile.<>c__DisplayClass2.<CreateSite>b__0()     --- End of inner exception stack trace ---     at Microsoft.Office.Server.UserProfiles.UserProfile.<>c__DisplayClass2.<CreateSite>b__0()     at Microsoft.SharePoint.SPSecurity.<>c__DisplayClass4.<RunWithElevatedPrivileges>b__2()     at Microsoft.SharePoint.Utilities.SecurityContext.RunAsProcess(CodeToRunElevated secureCode)     at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(WaitCallback secureCode, Object param)     at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(CodeToRunElevated secureCode)     at Microsoft.Office.Server.UserProfiles.UserProfile.CreateSite(String strRequestUrl, Boolean bCollision, Int32 lcid)     at Microsoft.Office.Server.UserProfiles.UserProfile.CreatePersonalSite(Int32 lcid). 0eafe286-3643-4115-8ba2-c09244609542

    I've checked the My Site permissions, reset IIS, rebooted the server, I started thinking that it had something to do with C2WTS because in the ULS I was also seeing some Event ID's g220 "No Windows Identity for" and some EventID bz7l "Could not retrieve a valid Windows Identity for" events, but they aren't corresponding with these My Site Creation failures, yet I went through all C2WTS permissions and settings nonetheless (I don't believe I should be seeing those events as it is), and it all looked fine.

    I'd like to think it's something simple I'm overlooking, but I've spent a couple of days now researching and troubleshooting to no avail.

    Current users can still get to, and use, their My Site Content.  I'm able to create new Site Collections in testing.  It only seems to be a problem with a user provisioning a My Site for the first time now.

    Thursday, September 15, 2011 5:09 PM

Answers

  • I finally got it to work.  Here is what I did to fix this, if anyone encounters "Access Denied" when creating new My Sites, maybe this will help:

    • Go to Central Administration -> Application Management -> Manage Web Applications
    • Selected the My Site Web Application, then clicked "User Permissions" in the Ribbon
    • Scrolled down to the Site Permissions section and UNCHECKED "Use Self-Service Site Creation" then clicked Save at bottom
    • Make sure the My Site Web Application is still selected and go back into "User Permissions"
    • RE-SELECT "Use Self-Service Site Creation" and Save

    Once I did this, I was then able to create new My Sites.  I'm not sure why it was giving Access Denied when all permissions appeared to be set correctly.

     

    Thursday, September 15, 2011 8:24 PM

All replies

  • As I read through the ULS log and analyzed the feature loading and missing template lines, I tried opening up Feature Admin to see if I could find a faulty feature.  When clicking the "Find Faulty Feature in Farm" button, I got a "Unhandled exception has occurred in your application...Access Denied 0x80070005" message.

    I believe I even limited it down to only getting the "Access Denied" message in Feature Admin when choosing the My Site Web Application on the left side and then selecting any My Site site collection below that.  Choosing site collections in the Intranet Web Application is fine.

    I'm running Feature Admin as the Farm Administrator.  Any ideas where the permissions are wrong on the My Site Web Application, and what could have changed? 


    Edit:  I wasn't running Feature Admin as Farm Admin...I was running it as spAdmin (install account).  When running it as Farm Admin, it goes through and doesn't find any faulty features in the farm. 

    Edit 2: I semi-take that back.  spAdmin IS in the Farm Administrators group...yet Feature Admin doesn't let it scan all Site Collections even if it isn't the Site Collection Administrator...yet it did with the Farm Admin Account.

    • Edited by TheMind Thursday, September 15, 2011 8:10 PM
    Thursday, September 15, 2011 7:42 PM
  • I finally got it to work.  Here is what I did to fix this, if anyone encounters "Access Denied" when creating new My Sites, maybe this will help:

    • Go to Central Administration -> Application Management -> Manage Web Applications
    • Selected the My Site Web Application, then clicked "User Permissions" in the Ribbon
    • Scrolled down to the Site Permissions section and UNCHECKED "Use Self-Service Site Creation" then clicked Save at bottom
    • Make sure the My Site Web Application is still selected and go back into "User Permissions"
    • RE-SELECT "Use Self-Service Site Creation" and Save

    Once I did this, I was then able to create new My Sites.  I'm not sure why it was giving Access Denied when all permissions appeared to be set correctly.

     

    Thursday, September 15, 2011 8:24 PM
  • above issue might be resulted successful to few users, but not in my case...

    so I have work out almost 2 days on this issue.. I have check my other VMs, it working fine ...

    after applied many resolutions ( including above one) I haven't got success...

    deleted & created web application for My site, UPS application.

    I don't know how it came in to my mind & I follow the process used by configuration wizard uses to create service applications,

    if you have created service application using SharePoint Configuration Wizard, than at the end it will prompt you to create sitecollection for "http://servername" or "http://servername/sites"..

    create sitecollection at root level "/", it could be any thing e.g. test using team site.

    Do IIS reset and it got worked for me..

    Thursday, July 23, 2015 9:52 AM