none
Printers offline in windows 2008 R2

    Question

  • Hi

    When I look into Print Management, I have some printers offline. I can print direct to the IP-address, and can acces the web-console of the printer. When I reboot the spooler it's ready and goes immediately offline again.

    any suggestions 

     

     

    Wednesday, November 10, 2010 9:17 AM

Answers

  • Something is interfering with the SNMP response from the printer.  On the ports tab of the affected printers, Configure the port and uncheck SNMP until you figure out what the issue is.  Setup a TEST printer using a port with SNMP enabled so you can work on the issue and still have an working queue for others to use.

    I'd also verify that the firmware on the network cards of the printers are the same version.


    Alan Morris Windows Printing Team

    Thursday, November 11, 2010 2:42 PM
    Answerer
  • This can also occur if the port configuration is not correct for SNMP Community name.  If you change this to a value other than PUBLIC on the device, then you will also need to update the information in port configuration.


    Alan Morris Windows Printing Team

    Hi all,

    After having some issues with offline printers, the conclusion was very simple. Just be sure that you have the exact same SNMP configuration on the printer device, matching what you have on the port used on the print server. If you don't have the option "Use Printer Offline" active, or if the printer isn't REALLY offline, this should clear out any problems.

    Hope it helps!


    Tiago Viana, MCITP:SA

    • Proposed as answer by jonjon14all Friday, July 20, 2012 10:44 PM
    • Unproposed as answer by jonjon14all Thursday, August 2, 2012 8:05 PM
    • Proposed as answer by sullijwiii Thursday, November 22, 2012 4:23 PM
    • Marked as answer by Alan MorrisEditor Thursday, November 22, 2012 8:31 PM
    Wednesday, July 18, 2012 2:27 PM
  • This can also occur if the port configuration is not correct for SNMP Community name.  If you change this to a value other than PUBLIC on the device, then you will also need to update the information in port configuration.


    Alan Morris Windows Printing Team
    Monday, August 8, 2011 10:05 PM
    Answerer

All replies

  • Sounds like it could be a driver problem. Try checking the OEM web site for the latest drivers.

    --------

    Regards,
    Hank Arnold
    Microsoft MVP
    Windows Server - Directory Services
    http://it.toolbox.com/blogs/personal-pc-assistant/

    On 11/10/2010 4:17 AM, Patrick Verbakel wrote:

    Hi

    When I look into Print Management, I have some printers offline. I can print direct to the IP-address, and can acces the web-console of the printer. When I reboot the spooler it's ready and goes immediately offline again.

    any suggestions




    Regards, Hank Arnold (MVP - DS)
    Wednesday, November 10, 2010 9:28 AM
  • Hi

    I have downloaded the latest driver and have this issue for serveral printers. Some printers are "ready" other "offline", for same brand/type and same driver  

     

    Wednesday, November 10, 2010 10:04 AM
  • Hi,

    Thanks for the post.

    You said that some printers are "ready" other "offline", for same brand/type and same driver. Now I am wondering if there is any registry difference between the good one and the bad one. You could check it from the following path in registry:

    Key:   HKEY_CURRENT_CONFIG\System\CurrentControlSet\Control\Print\Printers\<print queue name>

    In addition, are these printers (good ones and bad ones) locally attached to the same machine?

    Please also right-click the problematic print queue in Printers, and then clear the Use Printer Offline setting. This resets the registry key to the correct value.

    Hope this helps.

    Miles

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, November 11, 2010 2:57 AM
    Moderator
  • Hi

    registry looks the same

    all printers connect to one printerserver

    Use printer offline was not marked

     

    regards,

     

    • Proposed as answer by eschencedq Monday, July 23, 2012 1:48 PM
    Thursday, November 11, 2010 8:28 AM
  • Something is interfering with the SNMP response from the printer.  On the ports tab of the affected printers, Configure the port and uncheck SNMP until you figure out what the issue is.  Setup a TEST printer using a port with SNMP enabled so you can work on the issue and still have an working queue for others to use.

    I'd also verify that the firmware on the network cards of the printers are the same version.


    Alan Morris Windows Printing Team

    Thursday, November 11, 2010 2:42 PM
    Answerer
  • I disabled snmp on the port and status changed to "ready"

    will look into firmware

    Thursday, November 11, 2010 2:51 PM
  • Hi there,

     

    I have this exact symptom on a Windows 2008 Standard Server. This solution\workaround worked like a charm.

    But I'm still trying to identify the cause of the problem. Has anyone reached a conclusion?

     

    Best Regards,

    Tiago Viana

     

     

     

    Wednesday, March 9, 2011 9:54 AM
  • Greetings,

    Has anyone found a resolution for this issue. I am having the same issue as well.

     

    Please advise.

     

    Thanks,

     

    wm

    Thursday, May 26, 2011 10:07 PM
  • I don't know much about SNMP but I think it's a security configuration mismatch between the printer and the driver. The SNMP client in the driver has community name set to "public" which is a default read-only name or something. When I logged in to my printer's firmware through the web interface, I looked at the SNMP config page and SNMP was setup to read-write access with a blank community name. I set the printer community name to public and since then I haven't had the offline status problems but I can't prove this is what fixed it.

    The printer I was having problems with is a HP LaserJet 9050n, latest firmware and universal print driver on a 2008 R2 server.

    Thursday, July 28, 2011 12:49 PM
  • Thank you Alan Morris.  Turning off SNMP on the printer did the trick.
    Thursday, August 4, 2011 6:46 PM
  • Although not for 2008, the same workaround is mentioned here :

    http://support.microsoft.com/kb/946198


    Please remember to click “Mark as Answer” on the post that helps you.
    Sunday, August 7, 2011 1:09 AM
  • This can also occur if the port configuration is not correct for SNMP Community name.  If you change this to a value other than PUBLIC on the device, then you will also need to update the information in port configuration.


    Alan Morris Windows Printing Team
    Monday, August 8, 2011 10:05 PM
    Answerer
  • Although not for 2008, the same workaround is mentioned here :

    http://support.microsoft.com/kb/946198


    Please remember to click “Mark as Answer” on the post that helps you.


    The issue above looks to be a defect/bug in the tcpmib.dll.  It is the 2007 version that was affected and resolved by the hotfix delivered by KB946198. 

    There was a registry/GPO component to enable the hotfix in 2003: DWORD: SNMPLegacy at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print with a value set to 1.  This is documented in the KB.  It was also suggested to me that since this hotfix was delivered for Server 2003 that it should have been ported to Server 2008 R2 and simply adding the very same component (SNMPLegacy) to the 2008 box should alleviate the behaviour.  Tried that.  Same issue.

    So it's either not a bug in the tcpmib.dll or the hotfix was NOT ported to Server 2008.  I'll tend to lean to the latter.

    Friday, October 14, 2011 8:14 PM
  • Hi Dustin,

    in fact it is not a bug in tcpmib.dll . It's a design change. Customers with large print server farms and thousands of print queues complained that they don't know if printers are attached behind the old print queues in his environment because all print queues were online.

    As a result a design change has been done. If the printer does not respond or does not respond in a spesific period of time it will be set to offline by the spooler service.

    The admins will then know if the print queues are still used or if a printer is attached behind that. The problem was that a lot of printers were not snmp compliant and also does not repond within the required time to the print server.

    The spooler set it to offline and clients were not able to print. Therefore MS introduced SNMPLegacy (Old behaviour). Even if the printer does not respond to the snmp command it will remain online.

    Regards,

    Cengiz Kuskaya




    Friday, October 14, 2011 10:28 PM
  • The SNMPLegacy registry key was never implemented in any OS other than 2003 SP2.
    Alan Morris Windows Printing Team
    Saturday, October 15, 2011 7:23 AM
    Answerer
  • Yes.  I believe that was confirmed.  Thanks Cengiz for your feedback.

    For the purposes of workaround the key for the SNMP Status is located at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\Standard TCP/IP Port\Ports\<IP Address/Port Name>\SNMP Enabled.  Set it to 0.

    GPO Ready?

    D.

    Wednesday, October 19, 2011 8:41 PM
  • Hello Alan,

    no, thats not correct. There is something wrong with the SNMP response interpretation  in Windows Server 2008 R2. Windows Server 2003 reads the SNMP value correct as "Error", Windows Server 2008 R2 thinks, it is "Offline". So observed at several printer models (but not all).

    regards,

    Herbert Abels
    Germany

    Wednesday, July 18, 2012 7:45 AM
  • Hello Hank,

    sorry, but this is not possible.

    We are talking about SNMP, not about the driver. Either the message will be sent out incorrectly or is misinterpreted by the operating system.

    regards,

    Herbert Abels
    Germany

    Wednesday, July 18, 2012 7:50 AM
  • Hello Patrick,

    this works, but does not solve the problem. When disconnecting the warning lamp, it will not light precisely, of course.

    But theSNMP communicationis needed formanythings.For example,the devicesoptions are recognizedand reportedwith SNMP. And there are some warning messages that are very very important for central monitoring (like ther correct "Offline").

    Regards,

    Herbert Abels
    Germany

    Wednesday, July 18, 2012 7:59 AM
  • Hello Alan,

    what does that mean?

    The problem is that there may be many reasons for a printer not to respond to an SNMP command. For example, the warning "toner low" or "paper tray empty" with some printers. I think the reason lies in the order of SNMP queries and the positions in the MIB, perhaps relating with a timeout.

    Regards,

    Herbert.Abels
    Germany

    Wednesday, July 18, 2012 11:21 AM
  • This can also occur if the port configuration is not correct for SNMP Community name.  If you change this to a value other than PUBLIC on the device, then you will also need to update the information in port configuration.


    Alan Morris Windows Printing Team

    Hi all,

    After having some issues with offline printers, the conclusion was very simple. Just be sure that you have the exact same SNMP configuration on the printer device, matching what you have on the port used on the print server. If you don't have the option "Use Printer Offline" active, or if the printer isn't REALLY offline, this should clear out any problems.

    Hope it helps!


    Tiago Viana, MCITP:SA

    • Proposed as answer by jonjon14all Friday, July 20, 2012 10:44 PM
    • Unproposed as answer by jonjon14all Thursday, August 2, 2012 8:05 PM
    • Proposed as answer by sullijwiii Thursday, November 22, 2012 4:23 PM
    • Marked as answer by Alan MorrisEditor Thursday, November 22, 2012 8:31 PM
    Wednesday, July 18, 2012 2:27 PM
  • Alan and Tiago, your answers proved true in my case - HP 2320 and 400 printers offline in Server 2008. I found the SNMP did not match in both the browser view and the port setting in Printer and Device Win7. They are working great now. All I have to do is change the settings on about 25 printers. Thank you very much :)
    Thursday, November 22, 2012 4:29 PM
  • Yes its the wrong SNMP settings that caused the printer to go offline. Thanks for this post!

    Thursday, October 8, 2015 9:08 AM
  • Great tip!!!
    Thursday, November 16, 2017 6:45 PM
  • Thanks Alan. Still useful today.
    Thursday, March 22, 2018 5:59 AM