SharePoint Server Search 15 Service Not Starting


  • I installed SharePoint 2013 a few weeks ago.  I installed the update and the 4 patches.  Everything worked fine for about a week. 

    Now I am having a couple of problems with the installation that prevents anything from working correctly.  The services for SharePoint Search Host Controller and Sharepoing Server Search 15 will not start.  When I try to start these services, I get an err "Windows could not start the SharePoint Search Host Controller service on Local Computer.  Error 5:  Access is denied."  The other 3 services for SP (Administration, Timer, Tracing) start fine with the same account. 

    The other problem is that I cannot 'save' anything in my site.  On a list, for example, if I update any data and try to save the list item, I get an error "The server was unable to save the form at this time.  Please try again."

    List Save Err Screenprint

    What is wrong with my install that causes these problems. 

    Thursday, January 03, 2013 1:50 PM

All replies

  • Is your server able to get to the proper domain controller?  If it is, then you don't have a login propblem per-se. The host controller is responsible for starting several other services that have been assigned to the particular search service in the farm (admin, crawl, index, analysis, etc).  It must be able to check the local configuration files it has and it must be able to query the search application admin component for any changes that might have occured.  After it verfies what services need to be run, it will attempt to start new process worker threads using the noderunner.exe shell.  This will in turn start the WFE service hosts for each role.

    My guess is that your topology has been changed in some weird way.  How did you create the search service application?   How many servers in the farm running search and how did you assign the roles?

    Chris Givens CEO, Architecting Connected Systems Blog Twitter

    Saturday, January 26, 2013 9:03 PM
  • Hello Chris,

    I am also facing the same problem. I had 2 app server in my farm eg server1 and server2. Dec CU installation everything was working fine and

    Search was installed on server1 and app2 had other service applications and also central administartion service.

    After a week or so I tried to add another WFE server in the farm using AutoSPInstaller which dont know due to somereason switched off my server 1 after restart i see search is corrupt central admin oepning from server2.

    Host controller service is started but not able to start SharePoint Server Search 15.

    Pls suggest how to fix the above search issue?

    Thanks Ba$va

    Monday, January 27, 2014 8:43 PM
  • hi

    check accounts which are used for these services: are they still active in AD?

    Blog -
    Dynamic CAML queries via C# -

    Tuesday, January 28, 2014 3:09 PM
  • "The other 3 services for SP (Administration, Timer, Tracing) start fine with the same account.  "

    That in itself is an issue, I assume these accounts are all running as the farm account?  Have you tried reinstalling the .net 4.5.1 prereq? 

    MCITP-EA | "Never test how deep the water is with both feet"

    Sunday, February 09, 2014 2:38 AM
  • Hi All,

    SharePoint 101, Always Start / Stop SharePoint Services either through the UI or using PowerShell. When a service is disabled it usually means the service is not configured correctly or not at all. The easiest way for you to configure search is through the configuration wizard. Personally, I use PowerShell and the best PowerShell Installation / Configuration script is, it rocks...

    In the mean time check if the Search service is started with Central Administration, if not Start it, then Create a Search Service Application...

    Also, its cool to help folks... But, if you don't know the answer if you haven't done it beforedon't guess, or you may cause someone more issues than you resolve...

    BTW there is one exception on starting  /stopping SharePoint Services. From time to time you may have to stop the timer service but at least do so from the command line

    • Net stop SPtimerv4
    • Net start SPtimerv4



    Sunday, February 09, 2014 7:37 AM
  • I had this same problem, I added the search service account to the local admins group.... no more problem.

    Good luck,


    Gary Newman MCSE, MCT, CCNA, MCSD, MCPD, MCDBA, MCAD, MCSA, MCTS Developer and Administrator On SharePoint 2013 SharePoint Practice Manager for AmeriTeach Denver, CO.

    Thursday, November 13, 2014 10:55 PM
  • Once you activate your Enterprise Search it will automatically will start.  Make sure that you have right crediential for the account which is member of Admin group.

    You can fallow the instruction in this article and service will start.  SharePoint server 15 Service

    Tuesday, October 06, 2015 6:03 AM