none
Hyperlinks in Outlook 2010 emails do not open browser

    Question

  • I have 2 PCs with nearly identical software configurations except for the OS.
    One PC uses Windows 7 Ultimate x64, the other uses Windows 7 Home Premium x64.
    Both have Office Professional Plus 2010 and Norton Security Suite 4 installed.
    Both PCs have all available updates installed.

    My problem is with hyperlinks contained in emals received into Outlook 2010.

    On the Ultimate system, the hyperlinks work properly, that is, clicking a hyperlink opens a browser window, as expected.

    On the Home Premium system, the hyperlinks don't work at all correctly.
    The first time any hyperlink is clicked, a message box titled "Windows" pops up with the following content:
      Windows can't open this file.
      File: http://www.youtube.com/watch_popup?v=LO2eh6f5Go0
      To open this file, Windows needs to know what program you want to use to open it.
      Windows can go online to look it up automatically or you can manually select from a list of programs that are installed on your computer.
      What do you want to do?
      The first option button is labeled "Use the web service to find the correct program."
      The second option button is labeled "Select a program from a list of installed programs."
    If I select the first option, nothing appears to happen.
    If I select the second, I get a pop up with a list of apps.  I select Internet Explorer. check the box labeled "Always use the selected program to open this kind of file", click OK and the browser opens.
    However, if I go back to the same email and click the same hyperlink during the Outlook session, a window pops up asking me to confirm that I want to open the link using IE.
    If I click on any other hyperlink, in the same email or any other email, I get the first pop up "Windows needs to know what program..."

    I didn't see any Outlook settings that would affect this behavior.

    Any clues about what needs to be done to fix this very annoying behavior?

    Thursday, June 24, 2010 3:02 PM

Answers

  • Hi,

     

    First, please check if you can open other URL in the email, such as http://www.microsoft.com.

     

    Based on the current situation, the file should be played by Media Player. Now let’s try to set Internet Explorer and Windows Media Player as the default program:

    ===========

    1.       In a window of Internet Explorer, click Tools > Internet Options.

    2.       Click the Programs tab, under Internet programs, click the Set Programs button.

    3.       Click Set your default program.

    4.       Click on Internet Explorer, click Set this program as default, and click the OK button.

    5.       Click on Windows Media Player, click Set this program as default, and click the OK button.

    6.       Reboot the computer and check the results again.

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Best Regards,

     

    Sally Tang

    • Marked as answer by Sally Tang Wednesday, June 30, 2010 2:47 AM
    • Edited by Sally Tang Wednesday, July 28, 2010 9:30 AM
    Friday, June 25, 2010 2:31 AM

All replies

  • Hi,

     

    First, please check if you can open other URL in the email, such as http://www.microsoft.com.

     

    Based on the current situation, the file should be played by Media Player. Now let’s try to set Internet Explorer and Windows Media Player as the default program:

    ===========

    1.       In a window of Internet Explorer, click Tools > Internet Options.

    2.       Click the Programs tab, under Internet programs, click the Set Programs button.

    3.       Click Set your default program.

    4.       Click on Internet Explorer, click Set this program as default, and click the OK button.

    5.       Click on Windows Media Player, click Set this program as default, and click the OK button.

    6.       Reboot the computer and check the results again.

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Best Regards,

     

    Sally Tang

    • Marked as answer by Sally Tang Wednesday, June 30, 2010 2:47 AM
    • Edited by Sally Tang Wednesday, July 28, 2010 9:30 AM
    Friday, June 25, 2010 2:31 AM
  • Hi,

     

    I am writing to see how everything is going with this issue. Is the problem resolved? If there is anything I can do for you, please feel free to let me know.

     

    Sally Tang

    • Edited by Sally Tang Wednesday, July 28, 2010 9:28 AM
    Monday, June 28, 2010 2:19 AM
  • Hi,

     

    As I have not heard from you for several days. I will go ahead and close this thread. If this issue is not resolved or you have any questions, please feel free to reply to us and this thread will be re-opened.

     

    • Edited by Sally Tang Wednesday, July 28, 2010 9:29 AM
    Wednesday, June 30, 2010 2:47 AM
  • Just installed Outlook 2010, when trying to open url, I get the msg " This operation has been cancelled due to restictions in effect in this computer"..

    Using Vista, no problem with Windows mail

    Tried the above to no avail. Any help appreciated.

    Friday, July 02, 2010 6:06 PM
  • Sally:

    Your answer worked for me.

    When I looked at the program associations, I noticed that many extensions were not associated with applications that were installed on that PC.

    No idea how the associations were lost or why they were not set, but after setting the extension-application associations, things started working.

     

    Thanks,

    Michael

    Friday, July 02, 2010 6:52 PM
  • Hi Michael,

     

    I am glad to hear that the problem is resolved. I appreciate all your time and effort on this issue.

     

    Sally Tang

    Monday, July 05, 2010 1:18 AM
  • Just installed Outlook 2010 via HUP (Microsoft Office 2010 pro).  Previously using Windows mail via Vista.  Tried the above fix,  didnt work. an open url with Windows Mail, but not in Outlook 2010. Nor will it receive e-mail offline from server ( 02 ), anything receiving while shutdown does not appear, yet Windows Mail does? 

    Tried 'repair', still same problems.

    Any suggestions.

    Rgds.

    Stuart Charter.

    Tuesday, July 06, 2010 8:41 PM
  • I have Office and Outlook 2010.  Loaded the IE 9 Beta and found hyperlinks in emails would not work - recieved error message "The operation has been cancelled due to restrictions in effect on this computer".

    I have checked all Sally Tang suggests on the 25 June [ensuring "set Programs" are correct] but still receive the error message.

    Any further ideas?

    MikeBamf


    MikeBamf
    Thursday, October 21, 2010 1:47 PM
  • I've tried the fixes given here and they don't work for me either.  I'm using Outlook 2010 and Windows 7 Starter - any other ideas about how to make hyperlinks work please?

     

    Tuesday, November 30, 2010 5:52 PM
  • I have this problem also.  Have been using IE8B for sometime and all of a sudden, hylperllinks on this computer only stopped working.  Get the mesage  "The operation has been cancelled due to restrictions in effect on this computer". 

    I have tried all the above efforts to no avail.

    This machine and my laptop have Win 7 Ultimate SP1 and IE9B installed.  Laptop works without any problems.  On this machine i get error  csc.exe wants to run......after three time of "OK" I get an error message and it goes away. 

    art


    Art
    Monday, January 24, 2011 2:49 PM
  • Have same problem as above and suggestions do not fix problem.

     

    Win 7 SP1 Ultimate, IE9B, Office Pro 2010.

    Additionally, I get csc.exe needs permission,  get this 3 time then dw20.exe 1 time then exception process ID=9xe8c (3724) thread ID=0x12dc (4828).

     

    Please advise.


    Art
    • Proposed as answer by XXXOS Thursday, February 10, 2011 11:28 PM
    Monday, January 24, 2011 2:56 PM
  • Go to the following link and click on FIX IT http://support.microsoft.com/kb/310049

    This will automaticly fix hyperlink probloms in officer 2010

    Thursday, February 10, 2011 11:29 PM
  • Hi Sally

    I followed your instructions on my Windows-7, Office 2010 Home Professional.  It has changed the symbols linking to websites on desktop, but didn't let me open any hyperlinks from Microsoft Outlook emails.  I have to copy and paste to access all links.  So the problem is not resolved, instead I have a new problem; the symbols that open my websites on my desktop.  For example, the link to Google Maps now has the symbol the ABC.  My bank has the symbol of a TV guide and eBay has some unknown symbol

    So how do I undo my new problem, that has resulted by following your instructions above? 

    Stephen

    Monday, May 23, 2011 5:38 AM
  • Sally,

     

    Thank you so much for the help!   I had the same problem as Michael, only it started when I had Outlook 2003.  Every time I clicked

    on a hyperlink it wanted to save a file.  Drove me nuts!  Never could find a solution to it.

     

    I upgraded to MS Office Professional 2010, and started getting the"windows cannot open" message, did the search, and presto!   Your

    answer came up and was an easy fix.  Even though I use Firefox most of the time, I'm glad I can click on an Outlook 2010 link and

    actually get somewhere!

     

    Thanks again.

    Santiago

    Wednesday, July 20, 2011 3:28 PM
  • I have a similar problem with a different twist.  When I hit hyperlinks in outlook 2010, I get a message to select program to open it with; I select IE, and it opens.  I select always use that program, but have same problem next time.  I have checkedd all default programs, with no change. 

    What seems to me to be the problem, is that every link that has an extension such as "xxx.com/xxxxxxx" is seen as a different file type requiring an unknown program to open it, not seeing it as a variation of ".com". 

    I have NO idea how to fix this, and actually it is my wife's laptop, so I hear no end to it!!!!!

    Thanks for any help you can suggest,

    Tom  (First time poster!)

    Thursday, June 07, 2012 4:35 PM
  • Hi TD & all,

    Sally, (the first answer) was correct.  I have the same problem as the first and this last post by tdschofield....too funny because its my wife's laptop as well! I wasn't hearing the end of it!!! lol  Anyhow, Sally didn't quite say the steps correctly so I think you might have not done it.  I followed her directions but understood what she meant.  I'll copy and paste her directions and make the necessary changes....I hope this helps.  I didn't even have to reboot, it worked immediately..

    1.      In a window of Internet Explorer, clickTools > Internet Options.

    2.      Click thePrograms tab, under Internet programs, click theSet Programs button.

    3.      ClickSet your default program.

    4.      Click onInternet Explorer, click Set this program as default, and click theOK button.

    At this point, you are done... below is if you are having problems opening music files....as far as opening links in outlook, after you click on "set this program as default, you'll see the computer think and make changes..after you click ok, you can go back to outlook and the links will work.

    5.      Click onWindows Media Player, click Set this program as default, and click theOK button.

    6.      Reboot the computer and check the results again.

    Monday, June 25, 2012 4:09 PM
  • XXXOS,

    I have Outlook 2010 and was getting the same email about "restrictions in effect on this computer."  I used the FixIt link and it corrected my problem immediately.  I didn't even have to reboot.  Thanks!

    I recommend this solution.

    http://support.microsoft.com/kb/310049

    Tuesday, October 02, 2012 1:32 AM
  • Sally- It worked for me. I re-opened Google Chrome after following your steps and it worked! Thank you!
    Tuesday, November 20, 2012 8:25 PM