locked
missing perfomance counter RRS feed

  • Question

  • I have an exchange 2013 on a windows 2012 R2

    I've notice now that exchange perfomance monitor are missing , from perfmon I can see only many other counter  like antigen and all other related to windows, IIS and other, but no one specific for exchange.

    Why? Is there a specific task to enable and register them under windows?


    alex

    Thursday, May 21, 2020 2:57 PM

All replies

  • I've notice now that exchange perfomance monitor are missing , from perfmon I can see only many other counter  like antigen and all other related to windows, IIS and other, but no one specific for exchange.

     Hi Alex,

    Do you mean the Exchange related counters are missing in the Performance Monitor?

    Is there any error message when you open PerfMon?
    Have you checked to see if there are any relevant events in Event Viewer?

    Considering that the counters might be disabled via registry settings, please check the registry locations below to confirm that the missing counters are not disabled:
    (Important: Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.)  

    • HKLM\System\CurrentControlSet\Services\%servicename%\Performance  
      (%servicename% represents any service with a performance counter. For example: MSExchange Active Manager, MSExchange AD Performance, etc.)

    If there are registry keys for "DisablePerformanceCounters" with a value other than0, then counter may be disabled and you would need to change the value to 0 to re-enable it. For more details, you may refer to: Disable Performance Counters.

    Once you have verified the counters are not disabled by registry settings, please try rebuilding all performance counters and see the result:
    1. Close Performance Monitor, and then stop any other monitoring services that might be trying to use the missing counters.
    2. Type the following commands at an Administrator command prompt. Press Enter after each line:

    cd c:\windows\system32
    lodctr /R
    cd c:\windows\sysWOW64
    lodctr /R
    WINMGMT.EXE /RESYNCPERF

    3. Restart the services below:
        • Performance Logs & Alerts (pla)
        • Windows Management Instrumentation(Winmgmt)
    4. Create a new Data Collector Set.
    Reference: https://support.microsoft.com/en-us/help/2554336

    Hope this can be helpful.

    Regards, 

    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Friday, May 22, 2020 7:05 AM
  • I've checked the registry, and there are no DisablePerformanceCounters Keys

    II've run then command as suggested:

    and I get an error:

    c:\Windows\System32>lodctr /R

    Error: Unable to rebuild performance counter setting from system backup store, e
    rror code is 2

    then  

    c:\Windows\System32>cd c:\windows\sysWOW64

    c:\Windows\SysWOW64>lodctr /R

    Info: Successfully rebuilt performance counter setting from system backup store
    c:\Windows\SysWOW64>WINMGMT.EXE /RESYNCPERF

    restart the 2 services

    Now I can see only this counter where the name start with MSExchange

    MSExchangeTransport_ExtensibilityAgents
    MSExchangeResourceLoad
    MSExchange Hygiene...(many..)


    alex

    Friday, May 22, 2020 12:09 PM
  • I've rerun the command that finished without error... but still only 2 items as MXEcahge...

    alex

    Saturday, May 23, 2020 8:38 AM
  • now many other counter has gone. For example web service disappears, I cannot found it on the perfomance monitor when I try to add.. but a Datto agent is still recording data from this counter

    alex

    Saturday, May 23, 2020 12:38 PM
  • Hi Alex,

    According to the KB article, a new Data Collector Set needs to be created after restarting the two services. If you haven’t done this in the previous attempts, please follow the step to create a new Data Collector Set (do not use an existing Data Collector Set) and see the result.

    Besides, as mentioned in the article, “Sometimes, running lodctr /R may not recover all counters. If you notice this happening, verify the file c:\windows\system32\PerfStringBackup.INI contains the proper information.” So if the issue persists, please navigate to c:\windows\system32\PerfStringBackup.INI, check if the file size has a drastic difference with the file on other machines. If the file on this machine is much smaller, please make a backup of it, and then try to copy this file from an identical machine for restoring the counters. 

    Regards,

    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Wednesday, May 27, 2020 6:39 AM
  • I've created a new data collector set, but the counters I can select are the same I can choose from the perfomance monitor and exchange counter are missing as the WEB SERVICE counter that was present before I run the indicated procedure

    I've opened \PerfStringBackup.INI and it has many items on exchange that I cannot see on perfomance monitor so the file seems to be ok.

    Here an example:

    [PERF_MSExchange Admin Audit Log]
    First Counter=15298
    First Help=15299
    Last Counter=15316
    Last Help=15317

    [PERF_MSExchange Anti-Malware Agent]
    First Counter=15232
    First Help=15233
    Last Counter=15296
    Last Help=15297

    [PERF_MSExchange Approval Assistant]
    First Counter=15216
    First Help=15217
    Last Counter=15230
    Last Help=15231

    [PERF_MSExchange Approval Framework]
    First Counter=15192
    First Help=15193
    Last Counter=15214
    Last Help=15215

    [PERF_MSExchange Assistants - Per Assistant]
    First Counter=15152
    First Help=15153
    Last Counter=15190
    Last Help=15191

    [PERF_MSExchange Assistants - Per Database]
    First Counter=15106
    First Help=15107
    Last Counter=15150
    Last Help=15151

    [PERF_MSExchange Attachment Filtering]
    First Counter=15100
    First Help=15101
    Last Counter=15104
    Last Help=15105


    alex

    Wednesday, May 27, 2020 2:58 PM
  • Hi Alex,

    >> I've created a new data collector set
    May I know how you created the new data collector set? If it was created from a template, please try again to create a new one manually and check the result:

     

    Regards,

    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, June 1, 2020 8:18 AM
  • look the sceenshot, I add a new couter manual, when I need to select the counter after MSexcange Hygiene there is only one item, MSExchange submission smtp sent, all other counter are missing

    alex

    Monday, June 1, 2020 9:51 AM
  • Hi Alex,

    Is there any difference if you manually select the computer:


    In addition, if you have another server which doesn’t have this issue, please try to replace the PerfStringBackup.INI file as mentioned in our previous discussion.

    By the way, in case the issue is related to any third party applications on the machine, it’s suggested to try temporarily disabling or removing the 3rd party software and see the result.

     

    Regards,

    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Thursday, June 4, 2020 9:07 AM
  • I confirm that there are NO differences if I select the computer name as \\computername

    I have PerfStringBackup.INI from an other server but the file has much more item (like imap that on mine is not enabled) and some items are mixed italian / english.

    I dont' know if the issue is related to a3rd part software, but I don't think because other than exchange there are Wsus and MSME (exchange antivirus from Mcafee). 


    alex

    Thursday, June 4, 2020 11:49 AM
  • I dont' know if the issue is related to a3rd part software, but I don't think because other than exchange there are Wsus and MSME (exchange antivirus from Mcafee). 

    Hi Alex,

    As based on my experience, 3rd party applications, especially antivirus software, are often found to be the culprit of a weird issue. So if possible, would you please have a test by temporarily turning off them and check the result? 

    Regards,

    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Tuesday, June 9, 2020 9:24 AM
  • Hi Alex,


    As based on my experience, 3rd party applications, especially antivirus software, are often found to be the culprit of a weird issue. So if possible, would you please have a test by temporarily turning off them and check the result? 

    Regards,

    Yuki Sun 

    I've disabled the Antivirus but nothing changes, Exchange item are still missing. As I wrote before after lodctr /R  procedure disappears also  "web service" counters  like \Web Service\Current Connections. This is missing from perfmon windows but is seems to be still working with other interfaces. I use the Datto agent to monitor the server and the counter \Web Service\Current Connections is still working even if  not visible in perfmon

    Alessandro


    alex

    Wednesday, June 10, 2020 6:21 AM
  • as "web service" counter are missing I've tryed to reload the counter as indicate in the previus article

    From C:\Windows\WinSxS\amd64_microsoft-windows-iis-w3svc_*

    I run lodctr w3ctrs.ini and I get as response

    "conunter for w3svc are already installed"

    but still not visible under preformance monitor and

    typeperf "\Web Service(_Total)\Current Connections"

    response is "no valid counter"


    alex

    Thursday, June 11, 2020 12:25 PM
  • Hi Alex,

    May I know if you have seen any relevant events in the Event Viewer?

    Besides, please try to re-run "WINMGMT /RESYNCPERF" and then reboot the server at nonworking hours and see if there would be any difference.

    Regards,

    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Friday, June 12, 2020 9:50 AM
  • Hi Alex,

    May I know if you have seen any relevant events in the Event Viewer?

    Besides, please try to re-run "WINMGMT /RESYNCPERF" and then reboot the server at nonworking hours and see if there would be any difference.


    Unofrtunatly there are nothing usefull on event viewer. I've reboot afrer WINMGMT /RESYNCPERF"  but nothing changes

    alex

    Wednesday, June 17, 2020 8:16 AM