none
migration error for site collection RRS feed

  • Question

  • one database has 15 site collections which we migrated from 2010 to 2016 using DB upgrade.
    all sites migrated sucessfully except one site collection. 

    for that one site when we checked "site collection upgrade status" below are the logs, what could be the wrong. Please assist. 

    Thursday, October 17, 2019 6:08 AM

Answers

  • Hi kumar,

    It seems there is an issue with content types. You may have to either deactivate/activate and then perform an IIS reset.

    Disable-SPFeature -identity "CTypes" -URL https://somesite
    
    Enable-SPFeature -identity "CTypes" -URL https://somesite

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Marked as answer by sns shyam Friday, October 18, 2019 9:18 AM
    Friday, October 18, 2019 6:54 AM
    Moderator

All replies

  • Hi

    I always understood that you should not upgrade from 2010 to 2016 but should upgrade from 2010 to 2013 then 2013 to 2016.

    Cheers Ross

    • Proposed as answer by ChetanKashid17 Thursday, October 17, 2019 1:12 PM
    Thursday, October 17, 2019 1:03 PM
  • As Moray said you can't migrate directly from SP 2010 to SP 2016. for your scenario the best solution would be move first 2013 and then move it 2016 or else use 3rd party tool migration like Sharegate, Metalogix, Ave Point, etc.,

    Thanks & Regards,


    sharath aluri

    Thursday, October 17, 2019 1:43 PM
  • Hi sns shyam.

    You cannot perform a direct migration from SharePoint 2010 to SharePoint 2016: you have to migrate first from SharePoint 2010 to SharePoint 2013 and then from SharePoint 2013 to SharePoint 2016. There is no other way to do a successful migration.

    Bye.


    Luigi Bruno
    MCP, MOS, MTA, MCTS, MCSA, MCSE

    Thursday, October 17, 2019 3:03 PM
  • Hi,

    Always we should go by the sequence of SharePoint version not skipping the middle version in SharePoint migration project - here you must migrate from SP2010 to 2013 then 2013 to 2016 while we take the approach of content db migration but if we go with third party tool like Metalogix or ShareGate - this rule is not true, there we can skip the middle layer of migration -  here SP2010 to SP2016 directly we can migrate.


    Thanks&Regards,

    Habibur Rahaman

    MCSA,MCP,MCTS

    My Certificates

    Note: If you feel the proposed answer is helpful, please mark as so or if this answered your question,please mark as answer.

    Thursday, October 17, 2019 5:30 PM
  • hi 

    Thank you all.

    Yes I have migrated from 2010 to 2013 and then to 2016

    but in 2013 and 2016, this particular site is having an issue, Please refer the error in screenshot in the first thread. Thank you


    kumar

    Friday, October 18, 2019 5:05 AM
  • Hi kumar,

    It seems there is an issue with content types. You may have to either deactivate/activate and then perform an IIS reset.

    Disable-SPFeature -identity "CTypes" -URL https://somesite
    
    Enable-SPFeature -identity "CTypes" -URL https://somesite

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Marked as answer by sns shyam Friday, October 18, 2019 9:18 AM
    Friday, October 18, 2019 6:54 AM
    Moderator
  • Hi Grace,

    After disabling the above feature it is upgraded. Thank you.


    kumar

    Friday, October 18, 2019 9:19 AM
  • Hi kumar,

    Thanks for marking my reply as answer. I’m pleased to know that the information is helpful to you. I hope you are delighted with the service we provided you.

    Here I will provide a brief summary of this post for your information.

    [migration error for site collection]

    Environment

    ====================

    SharePoint 2013 & SharePoint 2016

    Question

    ====================

    When migrate from SharePoint 2010 to SharePoint 2013, then SharePoint 2016, “site collection upgrade status” displays Upgrade Completed with Errors in the one of the site collection. In the upgrade log, there is error “Feature upgrade incomplete for Feature ‘CTYpes’ (Id: 15/xxx) in Site”.

     

    Solution

    ====================

    Confirmed by kumar, the solution is disable ‘CTypes’ feature using PowerShell command:

    Disable-SPFeature -identity "CTypes" -URL https://somesite

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Wednesday, October 23, 2019 7:53 AM
    Moderator