none
SharePoint 2010 Installation Failed - FIPS validated cryptographic algorithms

    Question

  • Hi All,
    We are trying to install SharePoint 2010 foundation on a Windows 2008 Standard-SP2 (NOT R2).
    After installing SharePoint when we run the config wizard for the first time we get the below mentioned error. We have another box which hosts MS SQL Server 2008 and we noticed that the config database is created but the wizard fails during the Create Config Database step.
    Local security policy for FIPS is disabled.

    Failed to create the configuration database.
    An exception of type System.InvalidOperationException was thrown.  Additional exception information: This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms.
    System.InvalidOperationException: This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms.
       at System.Security.Cryptography.SHA256Managed..ctor()
       at Microsoft.SharePoint.UserCode.SPSolutionValidatorCollection.ComputeHash()
       at Microsoft.SharePoint.Administration.SPUserCodeService.UpdateValidatorsHash()
       at Microsoft.SharePoint.Administration.SPPersistedChildCollection`1.Add(T newObj, Boolean ensure)
       at Microsoft.SharePoint.Administration.SPPersistedChildCollection`1.Add(T newObj)
       at Microsoft.SharePoint.UserCode.SPSolutionValidatorCollection.Insert(SPSolutionValidator validator, Int32 index)
       at Microsoft.SharePoint.UserCode.SPSolutionValidatorCollection.Add(SPSolutionValidator validator)
       at Microsoft.SharePoint.Administration.SPUserCodeService.Update()
       at Microsoft.SharePoint.Administration.SPPersistedChildCollection`1.Add(T newObj, Boolean ensure)
       at Microsoft.SharePoint.Administration.SPPersistedChildCollection`1.Ensure(T newObj)
       at Microsoft.SharePoint.Administration.SPUserCodeService.EnsureService(SPFarm farm, Boolean upgrading)
       at Microsoft.SharePoint.Administration.SPFarm.CreateBasicServices(SqlConnectionStringBuilder administrationContentDatabase, IdentityType identityType, String farmUser, SecureString farmPassword)
       at Microsoft.SharePoint.Administration.SPFarm.Create(SqlConnectionStringBuilder configurationDatabase, SqlConnectionStringBuilder administrationContentDatabase, IdentityType identityType, String farmUser, SecureString farmPassword, SecureString masterPassphrase)
       at Microsoft.SharePoint.Administration.SPFarm.Create(SqlConnectionStringBuilder configurationDatabase, SqlConnectionStringBuilder administrationContentDatabase, String farmUser, SecureString farmPassword, SecureString masterPassphrase)
       at Microsoft.SharePoint.PostSetupConfiguration.ConfigurationDatabaseTask.CreateOrConnectConfigDb()
       at Microsoft.SharePoint.PostSetupConfiguration.ConfigurationDatabaseTask.Run()
       at Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask()

    We noticed in the Servers Manger > Features we still see the framework version as 3.0 but in the installed programs list we do see .NET Framework 3.5 SP1 installed.

    Please help

    Monday, October 11, 2010 3:03 PM

Answers

  • Hi All,

    We resolved the issue.

    Even though the fips was disabled in the local security policy, in the registry there are two more places were the FIPS value was 1 i.e. enabled.

     There are FIPS related keys in three locations

    1.)HKLM\SYSTEM\ControlSet001\Control\LSA\FipsAlgorithm
    2.)HKLM\SYSTEM\ControlSet002\Control\LSA\FipsAlgorithm
    3.)HKLM\SYSTEM\CurrentControlSet\Control\LSA\FipsAlgorithm

    Only the 3rd key had the value as 0 i.e. disabled, but the other two had values as 1 i.e. enabled. I changed the values to 0 for the other two and then ran the PSCONFIG again. This time the installation was successfully completed. ISSUE RESOLVED.

    I have written the details here:

    http://collaborationsharepoint.blogspot.com/2010/10/this-implementation-is-not-part-of.html


    Regards, Mahesh
    • Marked as answer by Mahesh Srini Wednesday, October 13, 2010 9:05 PM
    Wednesday, October 13, 2010 9:05 PM

All replies

  • Can SharePoint 2010 be installed on Windows Server 2008 SP2? I wonder if I am getting this error because I am not using Win 2008 R2!
    Monday, October 11, 2010 6:51 PM
  • We got the Virtual machine rebuilt, we installed SP2010 Foundation, .NET Framework 3.5 , everything again, but still the same problem. Can anyone please help?
    Tuesday, October 12, 2010 3:52 PM
  • Hi All,

    We resolved the issue.

    Even though the fips was disabled in the local security policy, in the registry there are two more places were the FIPS value was 1 i.e. enabled.

     There are FIPS related keys in three locations

    1.)HKLM\SYSTEM\ControlSet001\Control\LSA\FipsAlgorithm
    2.)HKLM\SYSTEM\ControlSet002\Control\LSA\FipsAlgorithm
    3.)HKLM\SYSTEM\CurrentControlSet\Control\LSA\FipsAlgorithm

    Only the 3rd key had the value as 0 i.e. disabled, but the other two had values as 1 i.e. enabled. I changed the values to 0 for the other two and then ran the PSCONFIG again. This time the installation was successfully completed. ISSUE RESOLVED.

    I have written the details here:

    http://collaborationsharepoint.blogspot.com/2010/10/this-implementation-is-not-part-of.html


    Regards, Mahesh
    • Marked as answer by Mahesh Srini Wednesday, October 13, 2010 9:05 PM
    Wednesday, October 13, 2010 9:05 PM
  • I was having the same problem and the fix above did not appear to resolve the issue. Here is some additional information that fully resolved the issue for me.

    It appears the three FipsAlgorithm settings that need to be set to 0 (disabled) are in two places.

    The three areas listed above I understood to describe the 'FipsAlgorithm' folders that have 'Enabled' properties (note upper case letters)

    1.)HKLM\SYSTEM\ControlSet001\Control\LSA\FipsAlgorithmPolicy\Enabled
    2.)HKLM\SYSTEM\ControlSet002\Control\LSA\FipsAlgorithmPolicy\Enabled
    3.)HKLM\SYSTEM\CurrentControlSet\Control\LSA\FipsAlgorithmPolicy\Enabled

    ALSO there are 'fipsalgorithmpolicy' properties directly under 'LSA' with the same name (note lower case) that need to be set to 0.

    1.)HKLM\SYSTEM\ControlSet001\Control\LSA\fipsalgorithmpolicy
    2.)HKLM\SYSTEM\ControlSet002\Control\LSA\fipsalgorithmpolicy
    3.)HKLM\SYSTEM\CurrentControlSet\Control\LSA\fipsalgorithmpolicy

    Good luck!

    Wednesday, May 16, 2012 11:07 PM
  • I had same problem and solved by disable the following

    1.)HKLM\SYSTEM\ControlSet001\Control\LSA\FipsAlgorithm
    2.)HKLM\SYSTEM\ControlSet002\Control\LSA\FipsAlgorithm

    3.)HKLM\SYSTEM\CurrentControlSet\Control\LSA\FipsAlgorithm

    Many Thanks,

    Ayman Saleh


    Ayman Saleh

    Thursday, August 02, 2012 1:17 PM
  • I had the exact same issue as well. I had disabled the three registry keys for FIPS and had no results. I was completely unaware of the three ADDITONAL registry keys; all of which were set to 1. Your soultion solved my problem. This was two days worth of headache. Thank you!
    Thursday, November 29, 2012 5:43 PM