none
Outlook 2016 initial connection to Exchange is very slow on every client and every user. RRS feed

  • Question

  • I have been fighting this issue where when you launch Outlook 2016 it hangs at "trying to connect" for maybe a minute and at that time you can't do anything in outlook.  Global Address list lookups also seem slow to resolve names.  

    I tried diagnosing with wireshark to see what its doing but all I can see is a connection to the exchange server over and over again with the TLS 1.2 protocol.  I checked auto discovery and it appears to be configured correctly and working.  Email flow isn't affected.  It does hang for 4 or 5 seconds on the splash screen but I think thats probably normal.  After the window comes up it sits and trying to connect for about 55 - 70 seconds.  During that time you can not use Outlook.  

    I know there are tons of posts that are similar to this issue but it doesn't seem to fit my situation exactly.  Can one help me find a log or something that might help explain what this is doing when its hanging?


    Friday, August 17, 2018 4:46 PM

All replies

  • Hi trevoryour,

     

    It seems that this is a performance issue, please refer to the following article to see if it will give you some thoughts about this issue:

     

    How to troubleshoot performance issues in Outlook

    https://support.microsoft.com/en-us/help/2695805/how-to-troubleshoot-performance-issues-in-outlook

     

    You can also enable the Outlook logging or check if there is any error logged in the event log:

     

    What is the Enable logging (troubleshooting) option?

    https://support.office.com/en-us/article/what-is-the-enable-logging-troubleshooting-option-0fdc446d-d1d4-42c7-bd73-74ffd4034af5

     

    Regards,

    Gavin Gao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, August 20, 2018 9:09 AM
  • Thanks.  I'll take a look at the performance issues doc.  One more thing I want to mention is that with Cache mode turned off, it starts immediately.  Its only when starting in cached mode.  We have tried rebuilding the OST file but it did not resolve the issue.  If fact this issue is present on multiple workstations.  I loaded a brand new machine and logged in and the behavior was the same that makes me think its a server issue.
    Monday, August 20, 2018 1:20 PM
  • Hi,

     

    The performance issue doc also provide us some causes related with OST or PST file, for example, a large .pst file or .ost file. Meanwhile, you can uncheck the Download shared folders option and test again.

    Regards,

    Gavin Gao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Proposed as answer by Gavin-Gao Friday, September 14, 2018 2:15 AM
    Wednesday, August 22, 2018 7:38 AM
  • Not sure what's going on but it wouldn't let me reply with my original username. Anyway the shared folder button uncheck didn't help. I doubt its an OST file size issue. This seems to be happening for every user. My ost file size is 306MB.  I'm thinking its an Exchange issue but OWA comes up right away.
    Thursday, August 23, 2018 6:49 PM
  • I figured it out.  The issue was only happening when using RPC over HTTP.  We switched to MAPI over HTTP and Outlook started opening immediately.  This is a good solution because moving to MAPI is considered to be something that needs to be done anyway.
    • Proposed as answer by trevoryour_cp Friday, September 14, 2018 12:32 PM
    Friday, September 14, 2018 12:32 PM
  • Hi,

    RPC over http is still there but discouraged and now MAPI over http is future for exchange 2016 and 2019.

    https://docs.microsoft.com/en-us/exchange/clients/mapi-over-http/configure-mapi-over-http


    Please mark as an answer if this answers your question .

    PREM RANA

    MCSE Exchange 2013, MCSA 2012 Server MCTS Exchange 2007,

    2010, MCITP Exchange 2007, 2010 MCSE 2003 Server,

    MCSA Exchange 2003 ITIL V3 Foundation

    https://ranaprem.wordpress.com/

    This posting is provided AS IS with no warranties and confers no rights.

    Friday, September 14, 2018 1:24 PM