none
Restoring Exchange ( DAG ) Databases on Alternative Standalone Server RRS feed

  • Question

  • Hi All,

    Current Version Of Exchange is SP3 with RU 20.

    We have DAG with 2 Mailbox ( MB1 =5 Active DBs & 5 Passive DBs and MB2=5 Active DBs & 5 Passive DBs ) Servers, 2 CAS Servers and 2 Hub Transport Servers. Management asked me to setup the Exchange Setup at Isolated Network on a Single Alternative Standalone Server for Emergency purpose. Management does not need Site Resiliency or DR Site but they need to restore the all Databases on a Single Server. We've been taking MS Exchange Databases Backup through VERITAS and the Backup type is MS Exchange.

    I restored an Active Directory in isolated network on Server1 and another one server need to be setup for exchange. I have installed new Exchange Server with MB, CAS and HUB on Server2. I made a connectivity between isolated and production ( VERITAS Net Backup ) network to restore the databases. I was trying to restore the exchange databases from backup server to Server2 and it was not restoring getting some error. Then newly I took the production exchange DBs backup as MS-Windows backup type and restoring on Server2. Before restoring on Server2 I have created 10 Databases ( On the Database properties I have clicked “This database can be overwritten by a restore ”) and LOGs Volumes in similar fashion of Production.  And I stopped Information Store Service on Server2 and executing restoration from Backup Server to overwrite. The Databases are overwritten & restored but the catalog files are restoring separately.

    After the restoration I cannot mount the databases and noticed through ESEUTIL that those Databases status are Dirty Shutdown mode.

    Can we mount the databases by restoring .edb files as a MS-Windows Restore?

    Can we restore the databases from DAG Mailbox Servers to Single Standalone Server ?

    Appreciated, for your advises and help to setup our exchange environment in isolated network.

    Thank You in Advance.


    Regards,Ali

    Sunday, October 6, 2019 5:30 PM

All replies

  • Hi Admin-Exchange,

    You can restore the database to another server:

    Refering to the official document: 

    Move a Mailbox Database Using Database Portability

    For more detailed usage about ESEUTIL tool:

    How to use Exchange Extensible Storage Engine Utilities (ESEUTIL) tool?

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Regards,

    Joyce Shen


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, October 7, 2019 3:08 AM
  • Hi,

    Do suggestions above help? If you have any questions or needed further help on this issue, please feel free to post back. If the issue has been resolved, please mark the helpful replies as answers, this will make answer searching in the forum easier and be beneficial to other community members as well.

    Thanks for your understanding.

    Regards,

    Joyce Shen


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Thursday, October 10, 2019 1:30 AM
  • Hi Joyce Shen,

    We do not want to move the Mailbox Databases from one server to another. We just need a copy/similar of Exchange setup ( All User Mailboxes ) in isolated network.

    Can you please clarify my below doubts :

    Can we mount the databases by restoring .edb files as a MS-Windows Restore?

    Can we restore the databases from DAG Mailbox Servers to Single Standalone Server and mount ?

    ================================================================

    When I try to mount I'm getting following error.

    --------------------------------------------------------
    Microsoft Exchange Error
    --------------------------------------------------------
    Failed to mount database 'DB1'.
    DB1
    Failed
    Error:
    Couldn't mount the database that you specified. Specified database: DB1; Error code: An Active Manager operation failed. Error The database action failed. Error: Operation failed with message: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-550)
    . [Database: DB1, Server: EX-Backup.domain.com].
    An Active Manager operation failed. Error The database action failed. Error: Operation failed with message: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-550)
    . [Database: DB1, Server: EX-Backup.domain.com]
    An Active Manager operation failed. Error Operation failed with message: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-550)
    . [Server: EX-Backup.domain.com]

    MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-550)

    ============================================================

    Appreciated for your help and advise. Thank You.


    Regards,Ali

    Thursday, October 10, 2019 7:37 AM
  • Hi,

    >>Can we mount the databases by restoring .edb files as a MS-Windows Restore?

    Exchange mailbox database can be restored with windows server backup

    Detailed: https://practical365.com/exchange-server/exchange-2010-mailbox-database-backup-restore-windows-server-backup/

    If you want to use this way to restore the database to anouther server, it may not be supported.

    >>Can we restore the databases from DAG Mailbox Servers to Single Standalone Server and mount ?

    I'm afraid you can't.

    >>The similar issue about your error information provided above:

    Exchange Database does not mount

    Regards,

    Joyce Shen


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Monday, October 14, 2019 7:19 AM
  • Hi,

    Do you have any further issue on this topic?

    Meanwhile, if there is no issue, please remember to mark helpful reply as answer to close the thread. Your action would be helpful to other users who encounter the same issue and read this thread.

    Thanks for your understanding.

    Regards,

    Joyce Shen


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Friday, October 18, 2019 1:16 AM
  • Hi,

    Please give me couple of days since I'm checking it.


    Regards,Ali

    Friday, October 18, 2019 2:49 PM
  • Hi,

    Waiting for your feedback about this issue, share your updates here if you have any progress on it.

    Regards,

    Joyce Shen


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, October 21, 2019 8:34 AM