I can't copy and paste formatted text within the same or between Word and Excel documents


  • I run Microsoft Office Professional Plus 2010 (English) (Student Select)

    when I try to copy any formatted text or tables within the same or different Word documents I will always loose the formatting. This is also true if I try to copy formats or formatted tables within Excel or from Excel to Word, see example screenshot:

    When I have a look at my paste options via 'Alt', 'e', 's' or 'Paste special' it only lets me choose between "Unformatted Text" or "Unformatted Unicode Text", see screenshot:

    Here is what I tried already:

    - In the advance options menu all options are on "keep formatting"

    - I uninstalled and reinstalled the entire office suit but keep having the same problem!

    Any ideas?

    Thanks in advance,

    Tuesday, March 27, 2012 6:48 PM


  • I found the solution on another site,, so I can't claim the solution as my own, but it worked for me. Kent Ng says: 

    I face the similar issue with Excel 2003. If you have installed Skype-Click-to-Call, just removed it to resolve this issue.

    Friday, March 30, 2012 10:07 AM

All replies

  • I have the exact same problem and I've been going crazy since yesterday looking for a working solution.

    I checked the advanced options too to make sure all paste options are on "keep source formatting" and I unchecked the "Use Smart Cut and Paste" option too to be sure. But the problem is still there!

    I'd appreciate any help too. 

    I'm using Microsoft Office 2007 Professional. 

    • Edited by Lady.K Tuesday, March 27, 2012 11:59 PM
    Tuesday, March 27, 2012 11:58 PM
  • I do have the same problem. It recently appeared and is random. Under undetermined circumstances, the options reappear then disappear again, even without closing the file....

    Microsoft, please help !


    Wednesday, March 28, 2012 9:09 AM
  • I have the same problem as well. It came on suddenly over the past day or two. It seems to me to be a problem with the windows clipboard - it is converting everything to unformatted text. I use Clipcache clipboard manager and suddenly the clips being captures are all unformatted text. Until now, ClipCache took from the windows clipboard the original formatted text and then offered a choice of plain text or rtf. Clips from webpages were offered as HTML or text. Now everything I copy is offered as plain text only. I tried disabling Clipcache thinking that my be the cause of the problem, but no joy.

    I echo :  Microsoft - please help!

    Thursday, March 29, 2012 2:46 AM
  • I am having the exact same issue since yesterday.  It only allows me to paste (Keep Text Only), and my paste special has the exact same options (only Unformatted and Unformatted Unicode Text).

    I also experience this same problem trying to paste to PowerPoint.

    A solution would be fantastic.

    Thursday, March 29, 2012 8:34 AM
  • I see this when I have Internet Explorer open at the same time...  Close it and cut and paste starts working again properly.


    • Proposed as answer by JessGH Wednesday, January 2, 2013 1:24 PM
    Thursday, March 29, 2012 4:42 PM
  • I found the solution on another site,, so I can't claim the solution as my own, but it worked for me. Kent Ng says: 

    I face the similar issue with Excel 2003. If you have installed Skype-Click-to-Call, just removed it to resolve this issue.

    Friday, March 30, 2012 10:07 AM
  • @ Celala

    Spot on!! I'm running MS Office 2007 and removing skype click to call solved the problem instantly. Thanks so much for the post!

    • Edited by B Josephs Friday, March 30, 2012 1:50 PM
    Friday, March 30, 2012 1:50 PM
  • PERFECT!!!

    Solves the issue instantly!!

    thank you soooo much!!!

    Friday, March 30, 2012 4:25 PM
  • Worked for me!  That's the most frustrating bug I've run across in a long time.

    Friday, March 30, 2012 9:51 PM
  • I don't think I have 'click to call'.  Is this a seperate app for Skype?  I have removed the 'When I double-click on a contact start a call' under 'General settings'.  Is this the same thing?  The problem only happens intermittantly to me and I have not yet been able to track down exactly when it happens.  Sometimes (in Word or Excel 2010 paste) I get the text only option, and others I get more options such as 'same format', 'merge' etc.

    Regards, Mike

    Sunday, April 1, 2012 3:19 PM
  • Right on the spot! I unistalled Skype Click-To-Call and the copy format reappreared instantly in Excel 2010 without even restarting the computer!

    Thank you WRadigan &!

    Sunday, April 1, 2012 5:55 PM
  • One of our users has just encountered this annoying problem with Office 2007, after updating Skype recently (to 5.8).

    Given Microsoft now owns Skype, is this something that can resolved through internal channels, or would it be useful to notify Skype independently?

    Monday, April 2, 2012 2:05 AM
  • Further to my previous posting I realised my mistake and have uninstalled Skype Click-To-Call.  Looks like it installed itself during the last Skype update to ver 5.8.  I will re-post if the problem recurs.

    Thanks for the advice.

    Regards, Mike

    Monday, April 2, 2012 7:43 AM
  • Thank you SOOOOOOOOOOOOOOOO much for contributing this solution.  I read it fast the first time and thought "how can that possibly be related", but it worked like a charm, BUT  sure enough I uninstalled Skype click to call, restarted my pc, and TA DAH!!!!  all my paste special options are back.


    Wednesday, April 4, 2012 12:06 PM
  • I was very skeptical that Skype would affect my ability to cut and paste, but this worked like a charm! I have been dealing with this for a week and nothing except rebooting worked. Rebooting only worked for the first several attempts to cut and paste. thanks!
    Wednesday, April 4, 2012 5:55 PM
  • I wish to thank W Radigan and of course, Jaynet Zhang of Microsoft Contingent Staff for getting this answer out to us, the users. I had been pulling my hair out for 2 days over this problem because it had stopped my work on building a tutorial, and 95% of the answer regarding a problem such as this were not fixes but just 'try this'. And of course, most had no bearing at all. So, I thank you again! Removing the Skype Click-to-Call feature solved the Word problem AND an Excel problem.

    The Word problem was that I could not copy graphics with text from the web (browser did not matter - I tried 3 others besides IE), and I could not copy hyperlinks from the web either - they just came over into Word as simple text. I had to create the hyperlink manually under the Insert tab, and select Hyperlink. The Excel problem was that when I copied cells, it did not pick up the formulas, but only the resultant values, which made the copy almost useless.  Both of the Word problems (on both Word 2007 & 2010) were resolved with this fox, as well as my Excel issues too!

    Thank you again -

    Vincent LaVallee

    Vincent LaVallee

    Friday, April 6, 2012 5:00 PM
  • Well...this one did save me a lot of time !!!!

    A user just brought in his laptop... W7 32bit with Office 2007.

    Upgraded Skype a few days ago to 5.8. .....and the copy/paste problem started.

    Uninstalled Skype Click to Call ...and it's resolved.

    Some serious debugging needed if i didn't read this post !

    Wednesday, April 11, 2012 11:16 AM
  • Thank you very much!  This worked for me.  I was glad I googled the question and found there were others out there with the same problem that seemed to all start right around the end of March!
    Wednesday, April 11, 2012 9:13 PM
  • Here's an article on how to uninstall the Skype Click and Call Function -
    Thursday, April 12, 2012 7:43 PM
  • Fantastic. Thanks for sharing. Skype's on my shitlist for that one. : /
    Wednesday, April 18, 2012 5:40 PM
  • I found the solution on another site,, so I can't claim the solution as my own, but it worked for me. Kent Ng says: 

    I face the similar issue with Excel 2003. If you have installed Skype-Click-to-Call, just removed it to resolve this issue.

    Thanks - had the same problem with Word 2010 and all is good now!!
    Friday, April 20, 2012 9:58 AM
  • Thank you so much Dear Celala......

    I was really facing this terrible problem in MS Office 2007 and 2003, simultaneously. I tried many options to get solve it but couldn't successed. While I removed "Skype-Click-to-Call", I instantly got the solution.

    Once again thank so much for this sharing....

    Thursday, April 26, 2012 1:55 AM
  • Celala,

    solid answer - thanks for contribute.

    Big thanks to OP of solution as well, Jaynet Zhang.

    Friday, May 4, 2012 8:05 PM
  • many thans to this post. it works instantly. God bless u 
    Wednesday, May 30, 2012 4:19 AM
  • This solution  it's totally insane... wait... IT WORKS!!! :)

    Thank you very much!

    Wednesday, May 30, 2012 4:38 PM
  • Dude, thank you for finding that one, it's being driving me crazy.

    Kent Ng, how on earth did you work that one out!

    Thursday, May 31, 2012 1:14 PM
  • THANKS!!! :)

    now i'd LOVE to know... what was the relation between skype click-to-call and excel copy and paste??? 

    Friday, June 1, 2012 4:27 AM
  • Thanks !!!

    I removed the Skype-Click-to-Call (which I am not using anyway) and it fixed the problem!

    Monday, June 4, 2012 11:39 AM
  • Many thanks for discovering this bizzare connection of Skype with cut and paste issue. Have been really struggling for past 2 days and work has been affected because of this silly issue. Glad that I googled to find the solution. God bless you.
    Wednesday, June 6, 2012 4:35 AM
  • Unbelievable !!! skype and paste n cut relation , thanks , it help lot !
    Thursday, June 7, 2012 10:16 AM
  • So pleased to have solved this problem - had lost so much time with this problem!  Thanks everyone.

    Friday, June 8, 2012 10:31 AM
  • thank you so much, I had the same problem. It took me one day to pin the problem to the clipboard, but then thanks to your help it was finally solved....
    Friday, June 8, 2012 3:22 PM
  • Thank you... Crazy bug! 
    Friday, June 15, 2012 12:08 PM
  • Thank you! Thank you! Thank you! Thank you! Thank you! Thank you!
    Wednesday, July 4, 2012 6:17 PM
  • Thank you so much man... My boss had this problem... She was so happy to know the solution!!! I'll never install Skype click to call now!
    Friday, July 20, 2012 11:13 AM

    I didn't understand Skype had installed a separate module. But it works. I'm sooooooooooooooooooooo happy!!!

    Sunday, August 5, 2012 6:20 PM
  • Thank you. Uninstalling Skype-Click-to-Call worked.
    Tuesday, August 7, 2012 5:51 AM
  • For me disabling the Skype add-on in Internet Explorer solved this issue. Closing IE provided a temporary fix. Glad I found this thread!!!!!!!



    Friday, August 10, 2012 1:35 PM
  • It's great to hear that the uninstall of Skype Click-to-Call worked for so many folks.  However...

    I have the same issue on my (relatively new) machine and

    • do not have Skype installed
    • have never had Skype installed
    • have confirmed that there are no Skype add-ons in IE (8.0)

    So now what?

    Friday, August 17, 2012 1:20 PM
  • Dear spmallet3, While all my experience with the problem described (cannot copy & paste in MS Word from the Internet) was solved by removing the Skype Click-to-Call feature, I can only suggest some things, many of which you may have done already. First, are you an experienced and knowledgeable Windows user? I ask because if you are not, then perhaps the following suggestion may be of value and use to you: (1) how did you determine you do not have Skpe or Skype Click-to Call? Was it via Progeams & Features list or was it only via 'All Prgrams' from the Start button? Did you check in the Task Manager as well? (2) Next, what version of Windows are you running? I ask because you say you are running IE 8, but version 9 has been out for at least a year and is quite better and quite nice as well. My experience with this problem was on Vista 64 bit and Windows 7 64 bit as well. (3) Exactly what problem are you seeing? Also, is it only with MS Word or are there problems (that you got when the MS Word probelms started) with MS Excel as well? If so, exactly what problems are you having with Excel? (4) Lastly, I could try to assist you directly and I have the ability to get on your system remotely (via LogMeIn)y from my computer (requires you to install the LogMeIn software which I would email to you as an attachment). I have many other users I remotely support.


    Friday, August 17, 2012 5:23 PM
  • >>  are you an experienced and knowledgeable Windows user?

    I'll let you be the judge based on subsequent responses.

    >> (1) how did you determine...

    Programs & Features, Task Mgr (processes for all users), and a check of the services running (via MMC)

    >> (2) Next, what version of Windows are you running?

    Win7 Enterprise, 64-bit.

    >> but [IE] version 9 has been out for at least a year...

    Tell that to our crack IT group who set up this (new) machine in May :-)

    >> Exactly what problem are you seeing?

    Working strictly within Word - no browsers, no Excel - the "Paste Special..." dropdown often - but not always, and so far not predictably - shows only "Unformatted Text" and "Unformatted Unicode Text" as selection choices in the listbox.

    Fwiw, this is actually not problematical for me - I don't use "Paste Special".  I happened onto this thread in the process of trying to solve a problem that is very troublesome:  copying and pasting formatted text between Word documents (or between, say, the code editor in Visual Studio and Word) often works only on a second attempt.  The first attempt pastes unformatted text.  Re-copying and re-pasting usually works, though not always.

    Until recently, it appeared that this was web browser-related (Firefox).  However, I've now seen the problem occur with no browser processes running at all.  This one's really gnarly - intermittent, no obvious pattern, and really disruptive of normal work flow.

    >>  ...requires you to install the LogMeIn software...

    That self same IT group frowns on such measures  :-)  (I get it; it's a security issue.  Still, they don't have any better a handle on this than anyone else.)

    Friday, August 17, 2012 7:32 PM
  • Perfect Celala, been bugging me for months this problem.  Getting rid of Skype Click to Call has done the trick.  Thank you.
    Saturday, September 8, 2012 9:18 AM
  • spmallett3: Do you happen to have a VNC client installed? I was having this problem too and Googling brought me to this post but I don’t have Skype on my PC either. Then I remembered the VNC client does some weird things to my PC’s clipboard sometimes. Closing VNC resolved the problem right away. (I suspect any program that has access to your clipboard could cause similar problems.)
    Sunday, September 23, 2012 9:09 PM
  • wow~  u  r amazing, thank you for ur kind help ^_^
    Thursday, October 18, 2012 2:32 AM
  • This worked for me! Woah what a design flaw Microsoft! Thanks MBReyes this was driving me nuts!
    Wednesday, January 2, 2013 1:24 PM
  • Hi everyone, just want to say that i haven`t installed skype click and call and i had same stupid problem, and solved in by uninstalling skype and whoila - it worked again. 

    From this problem i will never look same to the skype program...
    and i installed again skype, and it was working like there was no this problem.
    • Edited by zezam krizu Saturday, January 5, 2013 9:27 PM
    Saturday, January 5, 2013 9:26 PM
  • Zezam - Are you sure you did not install the Skype Click to Call feature? The only way you could have been sure was to look at all installed programs via the Control Panel. If you did not do this, then keep in mind that the Click to Call feature comes as a Skype update and you are not even aware you installed it! If this all happened, then deinstalling Skype will remove Click to Call and then reinstalling it does not bring back the Click to Call feature.


    Vincent LaVallee

    Saturday, January 5, 2013 11:02 PM
  • OMG! YOU HELPED ME SO MUCH.  What a stupid bug.  I didn't have to even restart my computer, and now I'm so happy THANK YOU!
    Saturday, January 12, 2013 1:38 AM
  • Yes, I am pretty shure that i hadn't installed skype click to call, because i don't need that service for me, and i always carefuly install every program by reading and (un)checking boxes... :)
    Wednesday, April 17, 2013 4:38 PM
  • Thank you, the moment I closed IE the problem vanished.


    Thursday, June 20, 2013 10:56 AM
  • You are a f** genius. Indeed is IE open that causes it!
    • Edited by Oscar6666 Sunday, August 11, 2013 4:35 AM complete
    Sunday, August 11, 2013 4:34 AM
  • IE is the cause of all this, the moment I close IE I can use copy & paste again
    Monday, November 4, 2013 9:04 AM
  • I don't have any skype installed (checked the program and feature in Control panel) but have this same problem. Any idea what else could cause this problem? It started when my computer was upgraded to Windows 7 with excel 2010. I previously had Windows XP with excel 2010 with no problem.

    Thanks much in advance. This is such an annoying problem :S

    Friday, November 15, 2013 3:08 AM
  • Dear bearbe,

    I do not have a definitive answer for you because in my experience it was totally due to Skype to Call, and I have trained all my customers to never install that feature of Skype. Once I deleted that feature (thru the Control Panel/Programs & Features my problem went away, and I have nit had it since. I never did discover exactly what Skype's Click-to-Call did to cause this problem, so it is possible that whatever Click-to-Call does, that perhaps some other tool or software could be doing the same thing.

    My best suggestion to you is to sort your programs listed in Programs & Features by date and try to recall when this problem started. Of course, if this problem started immediately when you migrated from XP to Windows 7, then this approach may not be too worthwhile.

    Vincent (11-14-2-13)

    Friday, November 15, 2013 6:58 AM
  • For those (like myself) that had this issue but do not have Skype (nor Skype Click-to-call) installed, I would look for other applications that may be taking over the clipboard. As echoed by dsbldn, I did have a VNC client (TightVNC) running, and I could only paste as plain text from one local Word document to another (even though the VNC client was idle). After closing the VNC client, all of a sudden I could paste between Word documents with proper formatting.

    In testing right now, it seems like the problem is intermittent - I can re-launch the VNC client, and still have the ability to paste with formatting between documents, so it may be some combination of the VNC client being open, and the VNC client having used the clipboard at some point? Regardless, for those that have this issue, perhaps  examine any apps you have that may use the clipboard in unique ways - VNC pasting across operating system instances may be the culprit here (I think you can only paste plain text through a VNC window to a different OS), and the clipboard is getting improperly locked into this mode while VNC is running?

    I'd start closing open apps/processes one at a time until you can copy and then paste while preserving formatting. Good luck! 

    Sunday, March 30, 2014 3:12 PM