none
Outlook 2010 High CPU Usage

    Question

  • I've got a problem that has just started recently with Outlook 2010 where the CPU usage is higher than you would normally expect whilst the application isn't being used.  CPU usage hovers around 45-60%.  I've seen a few threads about this sort of things and tried the suggestions in them such as disabling all the add-ons, starting Outlook in Safe Mode.  Both of these things make no difference.

    Does anybody have any other suggestions about what might be casuing this and how to fix it?

    Cheers


    Adam.

    Monday, April 23, 2012 6:57 AM

Answers

  • Nope.  Never found the answer.  I'm using the Outlook 2013 Preview and it works fine in Online mode.

    Sorry!

    • Marked as answer by adamf83 Monday, April 1, 2013 7:13 PM
    Thursday, September 20, 2012 8:29 PM

All replies

  • Hi Adam,

    I've seen such kind of issue caused by corrupted profiles, for this cause:

    • If you have internet calendar account in use, remove it and check again
    • or simply create a new profile to check the issue

    Also:

    • make sure all the latest update & service packs have been installed
    • scan your system with updated anti-virus

     

    For your reference.

     

    How to create and configure an email profile in Outlook:
    http://support.microsoft.com/kb/829918

    Check Windows Update:
    http://www.windowsupdate.com

    Download Office 2010 Service Pack 1:
    http://support.microsoft.com/kb/2460049

    How to remove and avoid computer viruses:
    http://www.microsoft.com/security/pc-security/antivirus.aspx

     

    Sincerely,

    Max Meng
    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    Tuesday, April 24, 2012 6:09 AM
    Moderator
  • Max,

    I have tried deleting and creating a new profile.  That worked for a short time until I realised that Outlook was operating in Cached Mode.  When operating in Online mode the CPU usage jumps up.

    All available updates are installed, AV is up-to-date and using real-time protection.

    Any ideas?

    Cheers

    Adam.

    Wednesday, April 25, 2012 6:44 AM
  • Hi Adam,

    As we know using Online mode do will cause low performance issue. And Cached Mode is recommended in all circumstances, except those specifically indicated in the When to use Online Mode section in this article http://technet.microsoft.com/en-us/library/cc179067.aspx

    From the article http://support.microsoft.com/kb/940226, we can find some causes of the low performance and how to solve:

    Cause 1:

    If you install Windows Desktop Search on a Windows XP-based computer or install Outlook on a Windows Vista-based computer

    Windows Desktop Search (WDS) will index all data in .ost files and in .pst files. However, the indexing of Outlook data occurs only when Outlook is running. Therefore, you may have to leave Outlook running overnight to determine whether the performance issues were related to the building of your search indexes.

    Performance issues may increase when Outlook is running in online mode. Such performance issues occur because running Outlook in online mode increases the load on the Exchange Server. This performance issue is especially noticeable when Outlook is configured in a non-default state to index the items from the Exchange Server to the local client index, and more than one user indexes the Outlook data at the same time by using Windows Desktop Search.

    To determine the indexing status for Outlook data, follow these steps:  

    1. In Outlook, point to Instant Search on the Tools menu, and then click Indexing Status.
    2. In the Microsoft Office Outlook dialog box, view the number of items that remain to be indexed.

    The built-in back-off mechanisms in the indexing component of Windows Desktop Search pause the indexing of Outlook data when the system is under heavy use. The easiest way to let the indexing finish is to leave Outlook running overnight.

    Additionally, performance issues are reduced when you run Outlook in Cached Exchange Mode. In this mode, Windows Desktop Search searches the local copy of the mailbox instead of the mailbox content that is located on the server.

    Cause 2.

    If you are running Outlook with the To-Do Bar enabled when Outlook  is running in online mode against an Exchange server, the additional data that is displayed in the To-Do Bar is retrieved from the server. Therefore, additional data requests are performed. These additional data requests for the To-Do Bar cause additional network traffic that can affect the performance of some standard Outlook operations.

    To avoid additional network traffic and the resulting performance effect in Outlook, you can turn off the To-Do Bar and reduce the network traffic between Outlook and Exchange in online mode. This reduction in data retrieval requests affects the user experience most significantly if you have a network that has high latency or limited bandwidth. To turn off the To-Do Bar in Outlook, point to To-Do Bar on the View menu, and then click Off.


    Max Meng

    TechNet Community Support

    Friday, April 27, 2012 7:38 AM
    Moderator
  • Hi Adam,

    Just checking in to see if the information was helpful. Please let us know if you would like further assistance.


    Max Meng

    TechNet Community Support

    Monday, April 30, 2012 9:11 AM
    Moderator
  • Max,

    I'd already looked at the index status and I still have high CPU usage when there are 0 items remaining to be indexed.  I will double check the to-do bar, but I am pretty sure I don't use it.

    Cheers

    Adam.

    Tuesday, May 1, 2012 6:31 PM
  • Hi Adam,

    Just checking in to see how is everything going on. Please let us know if you would like further assistance.


    Max Meng

    TechNet Community Support

    Tuesday, May 8, 2012 7:10 AM
    Moderator
  • Max,

    I'd already looked at the index status and I still have high CPU usage when there are 0 items remaining to be indexed.  I did have the to-do bar on but even with the to-do bar off and Outlook in Online mode I am still getting CPU usage of 50% plus.

    Any other ideas?

    Cheers

    Adam.

    Tuesday, May 8, 2012 7:18 AM
  • Adam,

    Have you solved your problem? I have a problem that looks like yours.

    gr, Iwan

    Wednesday, September 19, 2012 8:02 AM
  • Nope.  Never found the answer.  I'm using the Outlook 2013 Preview and it works fine in Online mode.

    Sorry!

    • Marked as answer by adamf83 Monday, April 1, 2013 7:13 PM
    Thursday, September 20, 2012 8:29 PM