none
Sorry, apps are turned off. If you know who runs the server, tell them to enable apps.

    Question

  • I've follow this article http://www.sharepointalex.co.uk/index.php/2012/11/enabling-sharepoint-2013-apps/ step by step to enable apps of SharePoint 2013 public facing site and still keep getting

    Sorry, apps are turned off. If you know who runs the server, tell them to enable apps.

    I viewed the logs the only message that could the issue is

    App Management Shared Service Application Proxy is not installed.

    below snapshots of settings, what would I missing?

    the services

    App Management Service  / Microsoft SharePoint Foundation Subscription Settings Service  are started

    Wednesday, July 16, 2014 11:38 AM

Answers

  • Hi,

    According to your description, my understanding is that the apps cannot be enabled in the public facing site.

    Based on the ULS log error message, I recommend to check if the App Management Service application is associated with the web application where the public facing site exists.

    Please delete the existing App Management Service application and re-create it using SharePoint 2013 Management Shell to see if the issue still occurs.

    I also recommend to check if you can ping the app domain name. If not, please check if the domain name is configured correctly in DNS.

    Please refer to the Configure the domain names in DNS(all hosting options) part in the link below:

    http://technet.microsoft.com/en-us/library/fp161236(v=office.15).aspx

    Best regards.

    Thanks


    Victoria Xia
    TechNet Community Support

    • Marked as answer by SharpRan Thursday, July 17, 2014 7:34 AM
    Thursday, July 17, 2014 2:10 AM
    Moderator
  • I recreated the service as suggested and noticed that the service is associated with website custom group after adding it , it worked perfect

    • Marked as answer by SharpRan Thursday, July 17, 2014 7:34 AM
    Thursday, July 17, 2014 7:34 AM

All replies

  • Hi,

    According to your description, my understanding is that the apps cannot be enabled in the public facing site.

    Based on the ULS log error message, I recommend to check if the App Management Service application is associated with the web application where the public facing site exists.

    Please delete the existing App Management Service application and re-create it using SharePoint 2013 Management Shell to see if the issue still occurs.

    I also recommend to check if you can ping the app domain name. If not, please check if the domain name is configured correctly in DNS.

    Please refer to the Configure the domain names in DNS(all hosting options) part in the link below:

    http://technet.microsoft.com/en-us/library/fp161236(v=office.15).aspx

    Best regards.

    Thanks


    Victoria Xia
    TechNet Community Support

    • Marked as answer by SharpRan Thursday, July 17, 2014 7:34 AM
    Thursday, July 17, 2014 2:10 AM
    Moderator
  • I recreated the service as suggested and noticed that the service is associated with website custom group after adding it , it worked perfect

    • Marked as answer by SharpRan Thursday, July 17, 2014 7:34 AM
    Thursday, July 17, 2014 7:34 AM
  • Check the web application where you are trying to install the app.

    Make sure the app management proxy application is configred to use with it.

    I was also getting the same error and every thing was  configured.

    I went to web application management and  connected my web application to the app management proxy and it worked.

    Tuesday, January 06, 2015 5:59 PM
  • Thanks dude, it works!
    Wednesday, July 22, 2015 2:31 PM