none
Outlook 2010: Missing ribbons

    Question

  • Hi

    A new installation of Office 2010 x64 does not show not all ribbons only in Outlook
    as I write an email (3 ribbons are not present). All other Outlook-Windows like
    tasks and so on are ok.
    Neither adapting the ribbons nor resetting ribbons to defaults make them
    visible again.
    Unchecking and rechecking a invisible ribbon like the ribbon "options" does
    not help either.


    Thanks for your help.

    Patrick
    Monday, December 14, 2009 7:48 AM

All replies

  • I am having the same problem.  I had the ribbon when I first installed.  I minimized it at one point and Outlook crashed with it in the minimized position.  Now, even when I click the arrow to show the ribbon again, it will not come back.  I have tried to reset the ribbons and it still won't come back.  I have done plenty of searches on this issue and it seems we are not the only ones.  Hopefully someone will come up with an answer to this one.
    • Proposed as answer by skip duemeland Tuesday, January 05, 2010 4:10 PM
    Wednesday, December 16, 2009 2:17 PM
  • i have same problem.. looks like a bug.. but investigating
    • Proposed as answer by fourdogs111 Friday, October 26, 2012 5:15 PM
    • Unproposed as answer by fourdogs111 Friday, October 26, 2012 5:15 PM
    Tuesday, January 05, 2010 4:11 PM
  • Try renaming the olkexplorer file at C:\Users\username\AppData\Local\Microsoft\Office then restart outlook.

    Diane Poremsky [MVP - Outlook]
    Outlook Tips: http://www.outlook-tips.net/
    Outlook & Exchange Solutions Center: http://www.slipstick.com
    Wednesday, January 06, 2010 1:08 AM
  • Renaming the olkexporer.officeUI file didn't fix the problem for me.  It only happened today, and I can't see what I did that would have caused it.

    I've tried uninstalling and reinstalling, but that didn't help either...came back exactly the same.  I had a quick look at the officeUI file, and it just seems to be XML, and my file is only 1kb...so I'm guessing it only stores the changes made to the UI.  I also played with the Ribbon Settings and found one interesting piece of behaviour...everything was already checked in the Main tab/group except for the Developer toolbar...if I check this one item, my Ribbon reappears, but only with the Developer tab!!!  I tried unchecking everything, OK, then check everything OK, but still no love.

    Has anyone actually found a fix for this, or even why it happens?  I'm struggling with using keyboard shortcuts and right-click context menus.

    Friday, January 14, 2011 4:23 AM
  • Hi guys,

    Not sure if you have fixed this or not, and I won't claim credit for this, but just stumbled across another Microsoft forum (CRM 2011 Beta) that had the answer for me...and it sounds like it helps with other products also!

    Quick steps (all the usual warnings about Registry modifications apply...if you don't know what I mean, don't follow these steps):
    1.       Close Outlook
    2.       Go to Start-Run type in Regedit
    3.       Navigate to HKEY_CLASSES_ROOT\TypeLib\{2DF8D04C-5BFA-101B-BDE5-00AA0044DE52} 
    4.       Right click on the 2.4 regkey and choose Export.  Save this export to your desktop for now so we have a backup.
    5.       Now once that is backed up right click on the 2.4 regkey and choose delete.
    6.       Launch Outlook

    Full article is here:
    http://social.microsoft.com/Forums/en-US/crm2011beta/thread/40d444b3-82a3-4186-ae40-dcd9f02e0e8e

    Hope that fixes it for you all too!

    • Proposed as answer by tumolo Friday, February 18, 2011 12:27 AM
    Friday, January 14, 2011 4:36 AM
  • It did not work for me mate. Thanks for the help
    Monday, February 14, 2011 9:09 PM
  • Hi guys,

    Not sure if you have fixed this or not, and I won't claim credit for this, but just stumbled across another Microsoft forum (CRM 2011 Beta) that had the answer for me...and it sounds like it helps with other products also!

    Quick steps (all the usual warnings about Registry modifications apply...if you don't know what I mean, don't follow these steps):
    1.       Close Outlook
    2.       Go to Start-Run type in Regedit
    3.       Navigate to HKEY_CLASSES_ROOT\TypeLib\{2DF8D04C-5BFA-101B-BDE5-00AA0044DE52} 
    4.       Right click on the 2.4 regkey and choose Export.  Save this export to your desktop for now so we have a backup.
    5.       Now once that is backed up right click on the 2.4 regkey and choose delete.
    6.       Launch Outlook

    Full article is here:
    http://social.microsoft.com/Forums/en-US/crm2011beta/thread/40d444b3-82a3-4186-ae40-dcd9f02e0e8e

    Hope that fixes it for you all too!

    This worked for me.  Thanks so much!
    Friday, February 18, 2011 12:28 AM
  • Thanks!  That worked.  Weird bug for the Dynamics CRM 2011 plugin for Outlook 2010. I have Windows 7 x64...maybe thats the issue?  Anyhow, thanks!
    Thursday, April 21, 2011 6:09 PM
  • This worked for me also; also occurred after installing CRM 2011, but on this machine I am running XP with Outlook 2010.
    Thursday, February 23, 2012 3:23 PM
  • Hi, thanx for help.

    P.S. my ribbons disapeared after installing CRM outlook client 2011.

    Tuesday, March 27, 2012 8:50 AM
  • Hi guys,

    Not sure if you have fixed this or not, and I won't claim credit for this, but just stumbled across another Microsoft forum (CRM 2011 Beta) that had the answer for me...and it sounds like it helps with other products also!

    Quick steps (all the usual warnings about Registry modifications apply...if you don't know what I mean, don't follow these steps):
    1.      Close Outlook
    2.      Go to Start-Run type in Regedit
    3.      Navigate toHKEY_CLASSES_ROOT\TypeLib\{2DF8D04C-5BFA-101B-BDE5-00AA0044DE52}
    4.      Right click on the 2.4 regkey and choose Export.  Save this export to your desktop for now so we have a backup.
    5.      Now once that is backed up right click on the 2.4 regkey and choose delete.
    6.      Launch Outlook

    Full article is here:
    http://social.microsoft.com/Forums/en-US/crm2011beta/thread/40d444b3-82a3-4186-ae40-dcd9f02e0e8e

    Hope that fixes it for you all too!

    Thank this fixed my problem.

    • Proposed as answer by Mshak Monday, May 21, 2012 1:05 PM
    Thursday, April 19, 2012 10:20 PM
  • Thanks Rose That was great. It fixed the problem.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.Or please vote as helpful.

    Monday, May 21, 2012 1:06 PM
  • I had Office 2010 Pro Plus installed and installed the Office 15 Beta (side by side to 2010). I uninstalled the beta and my Outlook ribbon disappeared exactly as described. I also have CRM 2011 add-in installed in Outlook 2010.

    I did not find the 2.4 key (this must be Office 2007) but did find 2.5 (Office 2010) and 2.7 (Office 15). I exported both to be safe, deleted them and launched Outlook. Office went into configuration mode (like when you activate) and after 30 seconds Outlook 2010 has the ribbons back.

    Excellent fix!


    Grant Thompson

    • Proposed as answer by John McCrae Thursday, September 06, 2012 6:46 PM
    Wednesday, August 22, 2012 12:37 AM
  • Grant, thanks for the posting. I had your exact scenario and this got me sorted out!

    Cheers
    John

    Thursday, September 06, 2012 6:47 PM
  • Thanks for the solution.

    In my case I had a 32 bit Office 2010 and for various reasons I had to go to a 64 bit installation.  

    I had to delete the 2.4 as well as the 2.5 regkey.  When I restarted outlook, it went through the configuration process again, a voila....ribbon.

    *thumbs up*

    Wednesday, October 03, 2012 3:48 PM
  • Thanks Grant,

    I had the same issue as you, and have been able to rectify it.

    Thanks

    Tony

    Friday, October 12, 2012 4:43 AM
  • I right clicked on the gray area and then I was able to un-check "Minimize Ribbon". The ribbon then re-appeared.
    Friday, October 26, 2012 5:17 PM
  • Worked for me, although in my case I had a 2.3 and a 2.7, not 2.4 (different addons).
    Friday, December 07, 2012 4:20 PM
  • Andrew, I found your post and it worked like a charm. Thanks!
    Friday, January 04, 2013 8:24 PM
  • Great work Grant. Worked for me also! Cheers
    Tuesday, January 08, 2013 9:42 AM
  • Thank you much that worked

    and that is going to the top of the stupid list for Microsoft

    Tuesday, January 29, 2013 9:45 PM
  • Awesome thanks bud! this worked for me :)
    Wednesday, April 10, 2013 8:04 PM
  • Andrew McHutchison's solution worked for me, as well. I'm running Office 2013 and Microsoft Dynamics CRM 2011.

    Thanks for the help.


    • Edited by ninjaspaz Wednesday, June 05, 2013 3:49 PM
    Wednesday, June 05, 2013 3:47 PM
  • Andrew's fix worked for me. Ran into this issue on Windows 8. Installed Office 2010 and then CRM 2011 and the ribbons all went *poof*.

    Looks like this has been a known issue for over 2 years now, is there an official response from MS?

    Tuesday, July 02, 2013 1:02 PM
  • The registry solution didn't work for me, however, when I went into Outlook and just disabled the add-ins, the culprit was Microsoft CRM. Once disabled, my ribbon came back. I removed & reinstalled Microsoft CRM.
    Thursday, July 18, 2013 8:45 PM
  • This fix worked a treat for me, thanks for the info.
    Tuesday, November 19, 2013 4:53 PM