COM Surrogate has stopped working. RRS feed

  • Question

  • I keep getting the same message, "COM Surrogate has stopped working."


    I get it when I first login, and I get it a few times while I'm doing what I normally do, which is using a varying combination of the Internet, Yahoo! Music Engine, Access 2003, and  jGrasp, and both Yahoo! and Windows Live Messengers.


    I don't have Nero installed, so I can't figure out what to do about it.  I already removed the only set of codecs that I know of, some oggcodecs thing from illiminable.



    Thursday, March 29, 2007 9:59 PM

All replies

  • I just uninstalled URGE and rebooted.  I haven't gotten the error yet, and it's been a few minutes.  I'll let it go a couple of days to see if this solves it.
    • Proposed as answer by heaveen1 Wednesday, November 25, 2009 9:05 AM
    Thursday, March 29, 2007 10:15 PM
  • This was, in fact, the problem.  Apparantly, URGE, the online music store that Windows Media Player 11 sports, isn't compatible with Vista.  If anyone else is having the same problem, I found that removing URGE solved it.
    Wednesday, April 4, 2007 11:28 PM
  • Hey BOB, how do I un-install URGE???. I got the same problem but when a Folder with a video is visualized.


    Thx, I really appreciate your help...



    Sunday, April 8, 2007 12:00 AM
  • Go to your control panel, click Uninstall a Program, and then uninstall URGE.  If you're using a classic view, then click the Programs and Features icon.
    Thursday, April 12, 2007 2:36 AM
  • I got the exact same message after I installed URGE too. I'll have to see if I can uninstall it too.
    Tuesday, April 17, 2007 5:07 PM
  • Let us know if that works for you as well.  There's hope in numbers.
    Wednesday, April 18, 2007 8:50 PM
  • Hi All , I have the same problem as Maverick-an with a folder that has video files in!! I looked for URGE but don't find it, anybody else know what could be causing this problem
    Thursday, April 19, 2007 7:24 AM
  • Hi All! Figured it out! Uninstalled nero 7 and problem went away.
    Thursday, April 19, 2007 7:44 PM
  • I removed URGE from my Windows Media Player and that seems to have fixed the problem
    Friday, April 20, 2007 3:14 PM
  • Me too, Removed Nero 7 and problem went away. Thanks for the post.
    Tuesday, May 15, 2007 9:38 PM
  • This issue is getting to be a common one and has been found to be caused by a number of things, like as posted above Nero, Divx, and for me it was XVid that did it. Mostly a CODEC that's caused allot of folks problems it seems.
    There is also a workaround for it that allot of people are using, including myself, that works well. But I found a secondary issue with it that can also be fixed rather easily.
    The fix involves adding the dllhost.exe to the Data Execution Protection (DEP) Ignore list. Here's the method in Vista (all Flavors):
    Right click My Computer, select Properties - select Advanced System Settings from the left side pane - in the Performance box, click Settings - click Data Execution Prevention tab - Check the "Turn on DEP for all programs and services except those I select" option - click "Add".
    A navigation box opens, navigate to C:\WINDOWS\system32\dllhost.exe, click it to add and hit OK.
    This should now add this "Com Surrogate", with a checked box, into the list area, OK out, reboot and you're done. The Com Surrogate errors should disappear.
    But I also found that secondary problem, my Avant Browser also stopped working soon after I applied this fix. I tried all the usual troubleshooting and nothing was working. I remembered turning on DEP for All Programs with that other fix so I wondered if this was causing it.
    I went to the same settings box and this time I added the Avant Browser.exe to the same list I added the other, rebooted and now Avant worked again. I was able to reproduce this many times so it is a definate fixable issue.
    It may also cause other browsers or programs to Stop Working in Vista, so if this happens to you soon after you apply the above fix for COM Surrogate errors, and something stops working, simply add it's exe to the DEP list, reboot and it should be working again.
    This will NOT affect your system adversely BTW, DEP was turned off by default for everything but Windows Services and Programs, so adding anything to the Ignore list in the above manner simply returns it to the default state.
    Dave C. (Chappy)
    Admin - Tech Support Forums
    • Proposed as answer by Jhatcher55 Monday, May 25, 2009 10:22 PM
    Tuesday, May 22, 2007 4:48 AM
  • Hi,

    I am running Windows XP SP 2 and I had a similar error message with WMP 11.  I also removed URGE from the add/remove programs and that cleared up the problem.  I was so glad to find this thread.

    Friday, June 1, 2007 10:35 AM
  • Guys, sorry for being such a donkey, but I still dont find the way how to remove the freaking URGE program.... any additional help????? thx in advance...



    Wednesday, June 6, 2007 12:19 AM
  • Nothing bro. Thx for your helkp but nothing in my case. The problem continues. According to Windows Vista Problem Report, the problem seems to be associated with my Nero7 version. I tried to find the executable in the Nero folder for adding to the DEP< but didnt find any excutable that I consider suitable for adding as an exception....... DUNO what to do...... maybe updating Nero?????
    Wednesday, June 6, 2007 1:02 AM
  • Maverick
    If you're recieving the "COM Suurogate" error and it's reported that Nero is the cause of it, it's not Nero you have to add to the DEP Ignore list, it's "dllhost.exe" that is added.
    If this is the case, follow my instructions in the above post EXACTLY as posted and it should halt the COM Surrogate errors until MS releases the hotfix or it's rolled into a Service Pack later.
    Just in case, here's the exact fix again...(Vista)
    "Right click My Computer, select Properties - select Advanced System Settings from the left side pane - in the Performance box, click Settings - click Data Execution Prevention tab - Check the "Turn on DEP for all programs and services except those I select" option - click "Add".
    A navigation box opens, navigate to C:\WINDOWS\system32\dllhost.exe, click it to add and hit OK.
    This should now add this "Com Surrogate", with a checked box, into the list area, OK out, reboot and you're done. The Com Surrogate errors should disappear."
    Now, if after you apply this fix, and the COM Surrogate errors cease, you may also see a problem with other programs that were working before, stop working all of a sudden. If that happens, the very first thing to try is to add that program's exe to the same DEP Ignore list as above and it should be OK again.
    For me, the 1st program to stop working was Avant Browser, so I went to the DEP like above but this time I navigated it to "Program Files\Avant\avant.exe" and added that to the list and it started working again. I've since had to also add DVDSanta.exe and avisplitter.exe to the list because thay also stopped working soon after, but as soon as they're added to the DEP Ignore list they work properly again.
    Hope this helps.
    Wednesday, June 6, 2007 3:13 AM
  • hi bob i went to Programea and features in control panel but there is no URGE in there. please help me remove URGE


    Thursday, June 21, 2007 4:42 PM
  • DOH! cant find how to remove URGE either. Running VISTA Home pro. Removed all the codecs Ive found too. Thanks for the help.\\Gary
    Friday, June 22, 2007 9:26 PM
  • Are you sure it's installed?  WMP will show the word URGE in certain places even when it's not installed.  You just need it installed to be able to use the music store, radio stations.
    Thursday, June 28, 2007 3:09 AM
  • I solved it easy.  Just deleted the DivX video in that folder.  problem gone for me.
    Saturday, June 30, 2007 2:58 PM

    Flash Player was the Culprit on my XP System. Like Nero, Adobe products sometimes cause strange problems and vulnerabilities.



    Friday, July 6, 2007 3:22 PM
  • It's amazing how many possibilities there are causing this error!  I sure hope Microsoft gets an update out soon to fix it!

    Thursday, July 12, 2007 4:21 AM
  • I just came accross this thread and have followed all tips suggested:

    1) I don't have nero installed

    2) Went to uninstall URGE - no such program listed in the "Uninstall Programs" area of Control panel

    3) Added dllhost.exe to the DEP exception list.


    Still getting the error. The funny thing is that it only happens when I click on a video file that uses

    the divx or xvid codec (or so it appears at this stage of research).


    I plan on uninstalling divx and xvid codecs and then reinstalling them to see if that helps.


    Peter Peter pumpkin eater.

    Monday, July 16, 2007 6:10 AM
  • "Doctor, it hurts when I do this."

    "Then stop doing that!"


    If only it were that easy to "stop" doing what we enjoy (which happens to cause the error).


    The only sure way to figure out what program is causing it is to uninstall one at a time and reinstall it if it doesn't resolve the error.  Whichever program's absence brings you peace at mind and with your computer, leave that one uninstalled until MSFT comes out with a high-priority security update to fix the issue.  I hope you figure out which program is causing it.  I'd say start with the program you use to view your divx and xvid files, then if that doesn't work, put it back and try the next closest thing.
    Wednesday, July 18, 2007 1:33 AM
  • You're a the best people!!  I couldn't find the nero, or those other programs but THIS post helped me the most.  You ALL deserve credit though because I would STILL be having this problem, if it were not for this forum!!  I'll past this group forum on to those of us I know that are still having the "Com Surrogate has stopped working" error.


    Thank's to everyone that has posted to this forum.....  Everyone helping each other is how it's supposed to be!!

    Thursday, July 19, 2007 1:46 PM
  • The DEP solution is all well and good, for non 64bit users of Vista. It wont let me add dllhost.exe to the ignore list Sad


    You cannot set DEP attributes on 64-bit executables


    No fair.

    Saturday, July 21, 2007 12:35 PM
  • "Flash player was the culprit on my system."


    I feel sorry for you.  Can't have much fun without Flash Player.

    Tuesday, July 24, 2007 5:02 AM
  • This error is not only caused by URGE, that is just one of the programs that can cause it.  Basically, it boils down to that few programs out there are fully Windows VISTA compatible, even when they say they are, which is quite common with a new operating system.


    This is one of the bugs we have to work through to till microsoft comes out with 'SP2' or similar as they did in XP.


    The temporary fix is to add the dllhost file to the DEP exception list as noted in one of the above statements.  However, I need to add a special note about this: 


    The default status for DEP is only for essential windows services and programs only, and not all programs as previously stated.  The reason the fix is working is because the dllhost.exe is one of those essential windows services, which is accessed by different programs such as URGE and Nero 7.  However, in order to place this as an exception, you must turn on DEP for ALL programs, except for those you place in the list.  This is why you may then have problems arise with other programs such as Avant Browser, because you have now turned on DEP for all programs.  So in order to get rid of one problem, you may be creating others.


    My personal recommendation for this problem, is since, it is really just a nuissance of a little pop up window that must be closed twice, and that I have yet to see stop my actual program from running, is deal with this nuissance until Uncle Bill comes out with a fix for it.   You save yourself alot more headaches this way, because DEP can cause many more issues when being ran for all programs.  Also, check with software vendors of all programs you have installed, to ensure you have the latest updates available.   


    Just to let you know, in case you still have a question about this, you do not have to have URGE in order to get this error, this is just one of the programs that can cause this error.  One other example, although I am sure there are others, is Nero 7, which causes this error as well.

    Friday, August 10, 2007 1:07 AM
  • I am so glad I found this thread!  I didn't know when I got the error message if this was some really important piece of my computer that was no longer working, so I came searching here.   Some of your answers were way to complicated for me to figure out, but I did understand about removing URGE, which I did, and rebooted.  No error message.  YEAH!  What really annoys me is that I used to download all my music on WMP through Walmart for 88 cents, but Walmart is no longer supported through WMP, just URGE (for 99 cents).  AND THEN IT CAUSES ERROR MESSAGES!  Well, I'm hoping for an "SP2" or whatever they come up with, to kind of fix some of the bugs in Vista.  But THANK YOU for all your expertise!


    Wednesday, August 29, 2007 3:07 PM

    how do i get rid of it or fix it
    Thursday, August 30, 2007 3:35 AM
  • Cheryl,


    If you have removed URGE and still want to buy 99 cent downloads, you might try Yahoo! Music Jukebox.

    It's a free music player with thousands of stations and a customizable radio station, all for free.  You can also upgrade your account if you like and listen to a couple of other stations for members only and also skip commercials, but I see no reason to upgrade when they give you as much as they do.  If you wish to purchase a song through the Jukebox, there's a small button labelled "BUY" next to the songs which are available for sale, which quite a nice selection of them are.  I've found that the Jukebox is the perfect substitute for the URGE store, as well as its radio stations.


    Of course, you'll use WMP as you normally did, and use YMJ where you previously used URGE (or Wal*Mart).  BTW, I love the interface in's so friendly that I enjoy even organizing my music, not just listening to it and watching the visualizations!

     Hope this solves your music problem...



    And now,

    Back to the original problem of COM Surrogate...


    I followed the instructions suggested to add COM Surrogate to the list for DEP to ignore, and then I tried reinstalling URGE, to see if it really would help.  It didn't.  COM Surrogate is on my ignore list and with URGE installed once again, I am receiving the error once again.  I even double- and triple-checked the DEP setting...yep, COM Surrogate is the only thing on the ignore list.  The only real solution I can think of at this point is to use Yahoo! instead of URGE.

    Saturday, September 1, 2007 3:15 AM

    This may fix your problem


    Go to start then right click on computer (below recent items), and click on properties


    then click on advanced system settings, then click on settings at the top ,


    then click on the data execution prevention tab and click the circle saying turn on dep for all programs and services except those I select


    then click add and type in dllhost.exe and click open, you should then see a com surrogate box checked


    now click apply, then click ok , then ok again and restart your computer, the problem should stop


    good luck!!

    Saturday, September 1, 2007 1:17 PM
  • i tried this, not it gives a svchost.exe has stopped working error message when windows starts up


    Wednesday, September 5, 2007 7:48 PM
  • I tried the method you suggested, but it only worked for about a week.  COM Surrogate is back to haunt me again.

    Tuesday, September 11, 2007 3:22 AM
  • I know this is a solution for some PCs, but not this PC and others addicted to VisDuh Home Premium. Already I did this suggestion a month ago, no URGE on this one, tried all the updates and hotfixes and work arounds we can find, tried turning off Antivirus and Defender, indexing, Nero removal, and everything else, safe mode, reinstalled VisDuh 4 times -- still the same stupid problems over and over and over and over, ad nauseum.

    I think it is somehow related to the ongoing problem with VisDuh calculating how long it is going to take to copy/move/rename some file. The snotfix for that quickened the problem somewhat, and kept the svchost from hanging the thing in BSD, but  it  still is slower than XP or ME or 2000 or even DOS 3.3, it seems.

    I wonder if this problem is related to Win Media (non)Player messing up all the time: playing mp3s and wma's and other files at variably slow speeds and with crackling noises?

    I hope MSFT finally comes up with a real solution to the problem(s) and SOON and gets it out everywhere.

    We feel like invoicing them for all the 100 or so lost hours of productivity on this mess.

    HELP! PLEASE! Somebody?

    Thanks for all the posts, I will keep searching and waiting and praying and muttering under my breath.

    Friday, September 14, 2007 5:00 AM
  • The COM Surrogate error message first showed up when I downloaded MP 11's update and it automatically downloaded URGE despite my not checking that button.  Immediately on rebooting the COM Surrogate error displayed and did it on the next two restarts.  I saw your message, uninstalled URGE and the error message is now gone.

    Sunday, October 7, 2007 11:28 PM
  • so i purchased a laptop w/ already preinstalled vista ultimate. and i hate it when that COM SURROGATE always appears! when i open a folder with a .avi file in it, it automatically appears! i hate it when wmp11 can't play most video files. so i discovered that i can play some files thru windows photo gallery. so i tried other files and when i played a .avi file, the windows like restarted its system but not shutting it down, more like it's refreshing. and then the COM Surrogate appeared and told me that there's an update available to make the Vista more stable and so on... so i downloaded it thru the link it provided at the balloon. so when i updated, of course it restarts... so it shuts down and boots again, and there's this message that says "configuring updates" it took a while, and when i was waiting for the logon screen to appear, it shuts down again and boots again and it was like its doing the same thing again & again! so i waited. but i was getting sleepy at that time, and i still can't logon! ii think it was more than 10 times that the system does that. so i shut it down.
    the nnesxt day, i tried it again, and there it was still doing the same thing over & over again! so i turned the monitor down trying to get my laptop on sleep state... so after a few hours i opened my laptop and i saw the logon screen... so i logged on... and a balloon message appears and it says something like event logon etc.... and after a few seconds, it shuts down by itself and does the whole thing over & over again! i tried 2 fix it by inserting the restoration disk, and try to run system restore. so i picked a date, and it always fail to system restore! what will i do! i just can't reformat it cuz i didn't have a back-up @ that time! so pls help me!
    Tuesday, October 9, 2007 4:50 PM
  • Thanks Uncle Bob!  Just uninstalled Urge.  "......and the Lord did grin"

    Thursday, November 22, 2007 12:26 AM
  • I am itting here trying to decide if my PC is worth throwing myself off the roof! I keep getting this message COM SURROGATE PROGRAM has stopped working. Until the messages began I had never heard the term. I have read the forum messages concerning this error message, I do have NERO, but I have not downloaded any codecs that I know of. I do download video clips from a P2P site. AVI's and MP3's are what I tend to use. I view them on Window's media player. Do these bring in their own codec's? Does Window's media player automatically pull in codec's? Sorry to ask such stupid questions, but I really have not a clue.





    Saturday, November 24, 2007 4:25 PM
  • Good Idea, I am trying this now, Vista is cool, but not very fast!


    thanks for the good advice.

    Thursday, December 6, 2007 3:11 AM

    i have a (sort of) fix for this problem, its called Windows XP. COM surrogate was only the start of my troubles with Vista, had serious lag over network and internet, hated the Calculating time nonsense which takes longer than the actual process of moving/copying of files. So i thought stuff it, back to XP, and not suprisingly, havent had a single problem since Smile


    Vista looks nice, but the resources it uses to do what it does (or doesnt) do, are ridiculous. I think i'll pass and stick to XP.

    Wednesday, January 9, 2008 11:31 AM
  • I keep getting the same message, "COM Surrogate has stopped working." also.

    Monday, January 14, 2008 6:14 PM
  • Work It Out!!!! Chappy

    You da man 4realyo! Xvid was the problem I uninstalled it and what do you know issue resolved. Much appreciated to all who commented but Chappy, wow if not for your time taken to give detailed info about the causes and solutions where would I have been.....Better yet what would it have cost me...Thx


    Sunday, January 27, 2008 3:47 AM
  • Tried this fix for Vista Home Premium and I still get the "COM Surrogate has stopped working" error. Whatever is causing this error also appears to be interfering with Windows DVD maker and it crashes before I can burn. What really disgusts me since buying my PC with Windows Vista on it is that I have only been able to successfully burn one DVD of my own making in the 12mths I have had it and if I wanted to downgrade to XP Ihave to shell out even more money. Thats if you can find a retailer who is prepared to sell it to you.


    None of the in excess of 500 problem reports submitted automatically via Vista "Problems and Solutions" module has produced any meaningful results. If they had this many problems with a new car there would be a recall notice issued for it. Actually they would probably close the factory that produced them and open a new one somewhere else and build a different model.


    Once again Microsoft is using its paying customers to do its beta testing. Frankly it (Microsoft) should pay us.
    Saturday, February 23, 2008 1:24 PM
  • Hi Maverick-an,

    Your sense of Humor is much appreciated. I am a System Admin, came over looking for answers to same issue. Read your post, and have been laughing for 10 mins now.


    You are awesome




    Sumit Kumar

    Saturday, March 15, 2008 7:44 PM
  • whenever i open movie directory 5 to 6 times the error message "com surrogate has stopped working" appears.
    how can i solve it.

    Sunday, April 27, 2008 8:38 AM
  • Nice one Dave,

    My message has also stopped and It has got live messenger working for the first time on my new PC!

    The problem is media player wont play any movie clips any more. I looked for the exe as per the above instructions but could not find it.

    Help please


    John D T




    Monday, May 12, 2008 8:11 PM

    Just curious, what  is MS doing  about it !?

    Also found this on the web>>

    Please follow these instructions at your own risk and read the warnings carefully.




    Tuesday, May 13, 2008 9:15 PM
  • Hi all,

    I tried all methods but I find out one method finally fixed "COM surrogate..." error, even upgrade Nero to 8.x, that's install the latest version (4.6.7) of Vista Codec Package will resolve the problem.

    Download links:

    Hope you can resolve your problem with Vista Codec Package.

    Terry Tran

    Thursday, May 29, 2008 11:17 AM
  • Hi, I realy appreaciate, if you can tell me how did you solve your problem with de DVD Maker, I just have de same problem. Realy I don´t what else to do.



    Help me please.


    Sunday, June 1, 2008 7:02 PM
  • I am unable to find URGE in the windows media player, and when I try to unistall it, is tells me it is encountering and error and won't install....any suggestions ?? thanks


    Saturday, June 14, 2008 1:36 AM
  • Sounds like you already removed it (partially) and need to fix up your registry, although I'm not the person to instruct you in doing so, much less how to do so.  First, I'd try reinstalling URGE if it will allow you to do so.  Then try removing it again.
    Thursday, August 28, 2008 2:58 AM
  • hi frnd,


     i had also the same problem, i am also did not find the URGE in my system for uninstal. so i uninstall nero 7 from my system.....................

    wat a surprise tat problem  disapeared from my system...............


    god is greattttttttttttttttttt....................... and i am also..................


    amit ......................the greattttttttttttttttttttt


    Friday, September 5, 2008 7:06 AM
  • This resolved the issue for my system...


    First uninstall any "codec" package(s) via add/remove programs...


    reboot (even if it doesn't tell you to do so)!!!




    Go to Start. 

    Right click on Computer, and select Properties.

    Click on Advanced System Settings, click the Advanced Tab,

    In the Performance section, click Settings.

    Select the "Data Execution Protection" tab,

    and then click the 'Turn on DEP for all programs and services except those I select' option.

    Click the Add button, and then browse to C:\Windows\System32\dllhost.exe

    Click Open, click OK on the warning message.

    Click Apply/OK.


    Once again - reboot (even if it doesn't tell you to do so)!!!


    Then install the latest version  of Vista Codec Package...

    Download links:

    This should resolve your problem "COM Surrogate Has Stopped Working" once and for all !!!!!!!!!!!!!!!!!!!!!!!

    Sunday, September 14, 2008 3:45 AM
  • I found that I was getting the "COM Surrogate has stopped working." message as well.


    An AVI torrent that I downloaded did not download completely and must have been corrupted. This file was in my movies folder. I started getting the error after this file was put in the folder.


    I found that after I deleted this corrupt AVI file the error went away. Solved for me!


    Saturday, October 4, 2008 1:36 AM
  • FYI, in case it helps anyone.  I had tunebite installed which seemed to install pixie pack codecs and some ffdshow codec even though it never told you it was going to.  After I uninstalled them everything is working fine.  I've kept my k-lite codecs installed and they don't seem to have any issues.


    Wednesday, October 8, 2008 4:18 AM
  • Ok so this COM surrogate error was driving me absolutley bonkers.


    Tried every bit of advice on here and this one seemed to work for me. No signs of problems yet and I can now paly avi. files through windows media player! Which was the problem i was having which resulted in COM error.


    Install this Vista codec



    All my prayers appeared to have been answered!!




    Saturday, October 11, 2008 10:04 AM
  • I uninstalled divx, installed the

    Combined Community Codec Pack, then restarted and it sorted this problem out rather nicely.

    It disabled CODECs that conflicted and installed the latest DivX, FFDShow etc.

    • Proposed as answer by iamNikhil Thursday, February 13, 2014 12:12 PM
    Wednesday, November 5, 2008 10:35 PM

    "COM Surrogate has stopped working." message as well


    After several downloads and patches of codec files and packages, with no results, Timmy21's post caught my attention...................corrupted avi file it was, once I went to the folder the pop message went nuts, I deleted the file, and

    Poof, no more error messages.


    Thanks Timmy21.

    Wednesday, December 3, 2008 6:23 AM
  • I get this message when trying to use Windows Explorer to "Extract all files" from a zip file.  The zip file contains about 1000 files, but only 638 are extracted, which is rather annoying.  Using Control Panel -> Administrative Tools -> Event Viewer -> Windows Logs -> Application, I find:

    Faulting application DllHost.exe, version 6.0.6000.16386, time stamp 0x4549b14e, faulting module MSVCR80.dll, version 8.0.50727.1434, time stamp 0x4757746d, exception code 0xc000000d, fault offset 0x0003c02c, process id 0x1a64, application start time 0x01c954d006a9cd60.

    Most of the advice for preventing the COM Surrogate message talks about previewing video files and installing codecs, but I am not trying to preview a file, and so I do not see how this advice is relevant to me.


    I have several MSVCR80.dll files in the C:\Windows\winsxs folders; I think they have come from installing Office 2007 and Visual C++ 2005 Express Edition.  The only non-null DllSurrogate values in the registry are %SystemRoot%\system32\iashost.exe and %SystemRoot%\system32\prevhost.exe and those files exist.  The zip file that I am trying to extract is the Eclipse IDE (  The OS is Windows Vista Home Premium SP1 with all the latest patches.


    Can anyone suggest how I can find out what I need to install or unistall to fix this, or at least explain why COM Surrogate is needed to extract files from a zip file.

    Wednesday, December 3, 2008 8:37 PM
  • Hi Folks. I Have had the same prob as "Boschr" with Nero 7. Uninstalled it and problem seems to have gone away. As far as im concerned Nero 6, 8 and 9 work so will try those. Thks for the help.

    Nick Biss
    Thursday, December 25, 2008 7:53 PM
  • Heyy Guys!

    I've read of the COM Surrogate issues and they are common in every PC. This has nothing to do with any software or codec you have installed on your PC.
    Removing the program will Disable it for only a little while.

    I have even seen this problems on BRAND NEW laptops/desktops, with PRESET FACTORY SETTINGS; HP, DELL, IBM you name it.

    Just have a Little paitence people, Vista continues to bug us.
    Lets just hope they don't have these kind of problems in Windows 7.

    Fingers Crossed.

    Saturday, May 2, 2009 5:56 PM
  • Heyy Guys!

    I have figured out a way to stop this error.(Works for most computers)

    You just have to CHANGE THE VIEW of the RESPECTIVE FOLDER!

    Don't use thumbnail views like ; LARGE icons, medium icons,etc.
    Use like details, or small icons ,tiles or list view ... it has worked on most computers and they have been error free since than.

    Best o LUCK
    • Proposed as answer by Messi. _ Monday, May 4, 2009 8:16 AM
    Monday, May 4, 2009 8:15 AM
  • That solved all my problems with a Samsung digicam that only has AVI files. The software that came with it wouldn't even read them. Now the “COM surrogate has stopped working” doesn't show up constantly and everything works. How you came up with that convoluted fix is beyond me, but thanks !!
    Monday, May 25, 2009 10:42 PM
  • Hey Folks,
    i had the same problem, every time i was scrolling with the mouse over media files: movies, audio and pictures i got the Error Message "COM Surrogate has stopped working" .. blah blah... -> also in other views of the folders (details etc.)
    I just searched a bit around Google and found a lot of methods with a lot of changes in the system. At least i found the Software "Uniblue RegistryBooster" (Microsoft Partner Corp.) it solved my problem. In the "ActiveX, OLE, COM" Section. The App is Shareware but it will do his job unregistert!


    I Hope i could Help!


    ps: sorry for my english Skills! this site sucks in opera!
    Saturday, June 27, 2009 2:37 AM
  • Dude If u have have NERO 6 or older versions installed in your computer, you will may get such an error. NERO 6 is not compatible with Vista. If you have NERO 6 installed in your computer you may also get an error rundll32 error. Uninstall NERO 6 and then I'm sure your computer is all set. Later you can install the NERO 7 or higher versions. At times you will it difficult to uninstall the NERO 6 from Win VISTA, in that case you have to go with deleting the corresponding registry files. HOPE THIS HELPS YOU ALL... :-)
    Saturday, August 22, 2009 3:29 PM
  • I keep getting the same message, "COM Surrogate has stopped working."


    I get it when I first login, and I get it a few times while I'm doing what I normally do, which is using a varying combination of the Internet, Yahoo! Music Engine, Access 2003, and  jGrasp, and both Yahoo! and Windows Live Messengers.


    I don't have Nero installed, so I can't figure out what to do about it.  I already removed the only set of codecs that I know of, some oggcodecs thing from illiminable.



    Sunday, August 23, 2009 2:12 AM
  • hey I got the solution!!,what ever may be ur Os codecs are sometiem brokenso U need to reinstall ur codecs.
    SO I removed my Vista codecs with klm codec pack and so it said many registry values are broken and it fixed thm ! and so no Comsurrogate probs guys!!
    Thursday, August 27, 2009 1:50 PM
  • Why is this still a problem after more than 2 years? I have several options after reading all of these posts!  Thanks...
    Monday, October 12, 2009 10:34 PM
  • This just happened to me for the first time and I've had Vista from its launch! 

    Nero 7 and all my other installed players had been working fine for me. However, my occurrance happened when 'checking' an AVI file using Media Player Classic.  After a little investigation, it turned out to be a problem with the DirectVobSub filter, which was opening the associated subtitles (a file I dont usually download, which is why I probably didnt get the problem before).  Anyway, I simply downloaded the latest DirectVobSub codec (2.9) and that fixed everything.

    Hope that helps some of those who dont have Nero but still have this problem.

    Sunday, December 6, 2009 12:25 AM
  • Hi guys was just going over this thread.  Thanks you did help.

    In my case looked for Ultra; not there.  Looked for Nero; not there.  However I did have Divx installed removed components one at a time.  In my case it was the One that had "Filter in the Title" no longer get the error.

    Best I can tell from what has gone down in the past and current experience it could be 1 of several components that have to do with Video play.  I still have Divx Player installed and it works also have Codec but error is gone.

    Looks like it is start removing those extrainiouse components that come in with that wonderful Free Downloads until you find the right 1.
    Saturday, December 26, 2009 6:21 AM
  • Dear Celtic Gizmo, I am on your same boat.  Vista user since 2006, never had this problem.  It began when opening a picture from an e-mail on Monday, and the other solutions did not help.  I am looking for DirectVobSub codec (2.9) but I do not find it.  Do you have the link by any chance?
    Thank you in advance.
    Wednesday, February 10, 2010 6:23 PM
  • Hi Patricia, sorry for the delay - just got back from a trip. Anyway, you can download the latest DirectVobSub codec, which is 2.39 (I mentioned 2.9 before - a typo), from the offical source forge site:

    Hope that helps.
    Tuesday, February 16, 2010 8:45 PM
  • May 11, 2010

    THANKS TO CHAPPY1 and JUSTJAYHERE! Their solutions worked for me!

    I had been getting the "COM SURROGATE STOPPED WORKING" message along with a "DATA EXECUTION PREVENTION" warning.  They first started showing up as "A PROBLEM WITH COM SURROGATE HAS OCCURRED", then a "DATA EXECUTION PREVENTION" warning, and then "COM SURROGATE PROGRAM CLOSED" message, or words to that effect. That is, I'm not sure I have reproduced the wording of the messages and warnings exactly here, but if you're having the same problem it should be familiar enough.


    In the beginning, I had both NERO Multimedia Suite 10 and FFDSHOW installed. In the end I was able to keep NERO 10 and was able to replace FFDSHOW with Vista CODEC Pacage 5.6.9 from . The Vista CODEC package seems to be more stable. Be sure to following Chappy1 and JustJayHere 's directions closely and remove/uninstall any and all previous installed CODEC's / CODEC Packages, such as FFDSHOW, K-LITE, and CCCP. In the end, I did more uninstalling than installing to fix the problem.

    The problem first occurred while I was using Windows Explorer (not IE Explorer), and was searching through directories and moving and renaming files. The error messages seemed to correspond to the action of generating thumbnails for audiovisual files in those directories I was displaying as Large Icons. I had enabled thumbnail generation while installing NERO 10 and any other time I had the opportunity to enable thumbnail generation in the past, I chose to do so.

    Remove/Uninstall ALL CODEC's and CODEC packages installed on your computer, FFDSHOW, K-Lite, CCCP, etc. Use the Uninstall routines that came with these packages, usually in the same folder on the start menu as a first choice, Control Panel>Programs and Features as a second choice. If there is no uninstall routine and there a re codecs that do not show up on the Programs and Features list, you may need to the help of a reputable Uninstall program to help you remove them all. I use Revo Uninstaller Pro for such situations and do a lot of reading and research before I take any actions.

    When you are sure you have removed all the CODEC's and CODEC PACKAGES, add dllhost.exe to the Data Execution Protection (DEP) Ignore list, here's the method for Vista (all Flavors):

    Right click on "My Computer" (or "Computer"), select "Properties", the "Control Panel > System" window will open, choose "Advanced System Settings" from the left side pane, from "System Properties" select the "Advanced" tab and in the "Performance" box click on "Settings", from "Performance Settings", click on the "Data Execution Prevention" , select/highlight the bullet next to "Turn on DEP for all programs and services except those I select:", click on "Add". A navigation box opens, navigate to the C:\WINDOWS\system32 directory and click on (select) "dllhost.exe", click "Open". "COM Surrogate" will now show up in the box, ensure the check box next to it is checked. Click "OK", "OK", and close the "Control Panel > System" Window. Reboot your computer for changes to take effect.

    Thanks again to Chappy1 and JustJayHere!

    Regards to all!

    Richard A. Sorensen (Dick Sorensen)

    Tuesday, May 11, 2010 7:20 PM
  • Go into control panel, then folder options, then view and tick Always show icons, never thumbnails. Thats it it now shouldn't come up anymore. It isnt a nero problem, it seems to only come up when folders are opened up that contain video files.  It has something to do with various video codecs bla bla bla. Do this and all should be fine......
    Wednesday, January 26, 2011 12:04 PM
  • hey guys,,

    i also got this error,,, i tried evey possible solution.. it's still not solved...

    my machine is a 64-bit,, whenever i tried to DEP the hostdll.exe it give a message "You cannot set DEP attributes for 64-bit executables"


    can anyone help please?????



    Sunday, March 20, 2011 7:40 AM
  • Hi,

    please download this reg file from my SkyDrive:

    and make a double click on the file to import it.

    When the DLLHost.exe (COM surrogate) crashes, Windows Error Reporting Service [1] creates a dmp file under C:\Localdumps. Please upload the file to your public Skydrive [2] folder and post the link here. I take a look at the dump with the Debugger, maybe I can see which Video Codec is the cause.


    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo:
    Sunday, March 20, 2011 9:31 PM
  • Solution "com.surrogate un Cesse de trabalho" pour Windows 7  64 bits  

    Enfin, délivré a de CE cauchemar Qui me poursuivait DEPUIS Plus d'un non. Si comme moi vous ÊTES confronté à un message de ce "Com substitution d'un Cesse de trabalho ... etc." ou pire encore le message Les pas de ne apparait, but Alors les imagettes des Icônes disparaissent, les Recherches Dans l'explorateur de Fichiers deviennent impossibles, l'ONU clic droit sur ​​un Fichier Est inopérant, programme de l'ONU ne se lance pas, Alors je ai Peut -Être solution Trouvé de juin. 
    Jusque-là et Parfois PLUSIEURS Dizaines de Fois par jour il me Fallait aller DANS LE Gestionnaire des Tâches et Dans Processus, Description, "tuer" le Fichier "dllhost.exe * 32" pour Pouvoir Reprendre Une activité normale . 
    l'ONU pendentif un Essaye Je Ai Toutes Les manips proposées Dans Les forums, sans succès. Il existait bien solution de juin de Apparemment Mais qui concernait  W7 32 bits. Rien pour la versión  64 bits. 
    Je ai trouvé CECI: 
    Il Faut supprimer le Fichier dllhost.exe, pas Celui qui is Dans windows / system32 Mais Celui qui is Dans Windows / SywWoW64. Là Bien Sûr impossible de supprimer ous modificateur CE Fichier protégé par le Système. D'où la démarche suivante: 
    - Cliquez droit sur ​​"dllhost.exe" (Dans Windows / SywWoW64) 
    - "sécurité" Onglet 
    - "Modifier" 
    - selectionner "Administrateur" 
    - Dans la colonne Autoriser, cocher «Contrôle total» 
    - Si vous Avez La Ligne "Trusted Installer", cocher "Contrôle total» Dans la colonne Refuser 
    - Sortez en Cliquant sur ​​OK ... / OK 
    Voilà, Maintenant le Fichier dllhost.exe Peut-Etre ous Modifié supprimé. Il Est préférable de le renommer en dllhost.old ous Mieux encore en ZZZdllhost.exe (il se retrouvera AINSI juste en fin de répertoire) et en CAS de Probleme il suffira simplement de le renommer à nouveau. 
    DEPUIS Maintenant 3 semaines je ne ai Plus CE Problème de "com.surrogate" Et je ne ai pas CONSTATE de dysfonctionnement par ailleurs en. 
    Je ne sais pas Toujours Pourquoi ça marche (conflit Entre dllhost.exe * 32 et 64 * dllhost.exe?) Mais ça marche!
    Wednesday, January 27, 2016 7:55 PM