none
Search still not working in Outlook 2010 64 (RTM)

    Question

  • Since the beta, the search feature in 64bit version of Outlook 2010 no longer works. Whenever I type in a keyword in the search field, it always returns 0 results. I have gone through numerous troubleshooting steps, and rebuilding the search index does not make a difference. I can see that "Microsoft Outlook" is listed in the "Included Locations" column, and under "Advanced Options" I can see that the msg extension is set to "Index Properties and File Contents".

    I am out of ideas and need some help getting to the bottom of and fixing this problem. It's very inconvenient not being able to search.

    I wonder, can this issue be related to the "Software Reinstallation Process" issue I am having? Because Office 2010 does not appear to be installing correctly, could this also affect the search functionality???

     

    Software/Platform: Windows 7 Pro 64 RTM, Office 2010 Pro Plus 2010 64 RTM. Here are some screen shots that may be helpful:

     FIGURE 1 (BELOW): Example of search issue - Notice the email message from "Likno Software" that is highlighted...

    FIGURE 2 (BELOW): Example of search results - When I search for the keyword "Likno" in the search field, it says "No matches found..."

    FIGURE 3 (BELOW): Indexing Options. Notice how "Microsoft Outlook" is in the list...

    • Edited by eq07 Monday, May 17, 2010 4:30 PM edits
    Monday, May 17, 2010 4:20 PM

All replies

  • Not sure if the following still works - but its a simple workaround that used to fix broken searches in Outlook 2007. Though this is supposed to be the 'last option', no problem trying it first.

    http://restartis.wordpress.com/2009/10/23/issue-series-outlook-search-not-working-under-vista


    - Thanks, Jinesh.
    Tuesday, May 18, 2010 6:40 AM
  • Dear Eriq07,

     

    Based on my research, this issue can be related to some restrictions in the registry settings. Also, most of these issues can be resolved by repairing Office and then rebuild the Indexing options. I would like to confirm if you have tried the Jinesh’s suggestions on that website. If not, I would like to list the steps below and you can try to see if the problem can be resolved by the steps.

     

    Step 1: Check registry settings

    ====================

    Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs.

     

    1.       Click Start, in the Search box, type regedit and press Enter to open the registry editor.

    2.       Locate the following registry subkeys:

    HKEY_LOCAL_MACHINESoftware\Policies\Microsoft\Windows\Search\PreventIndexingOutlook

    HKEY_LOCAL_MACHINESoftware\Policies\Microsoft\Windows\Search\PreventIndexingEmailAttachments

     

    3.       Please first back up the registry subkeys above. Then, check if the value data is set to 1. If it is, please change it to 0, or delete the registry subkey.

     

    For more information, you can also refer to the following article:

    http://technet.microsoft.com/en-us/library/cc178983.aspx

     

    If the problem persists after this, let’s continue.

     

    Step 2: Repair Office program

    ==========

    1.       Go to Start\Control Panel\Programs\Programs and Features, and locate the program Microsoft Office.

    2.       Right click the program and choose Change, then Repair to repair the program.

     

    Step 3: Rebuild Indexing options

    ===============

    1.       Click Start, in the Search box, type Indexing, and open Indexing Options under Control Panel.

    2.       Click Advanced, click the Index Settings tab, and then click Rebuild.  If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Best Regards,

     

    Sally Tang

    • Marked as answer by Sally Tang Monday, May 24, 2010 7:09 AM
    • Unmarked as answer by eq07 Tuesday, May 25, 2010 5:53 AM
    Wednesday, May 19, 2010 2:13 AM
  • @SallyTang

    This is not the answer. So I unmarked your answer proposal. Regarding your recommendations:

    FOR STEP 1 - Those registry keys do not exist. The "Search" subkey does not exist. In fact, the path only goes to HKLM\Software\Policies\Microsoft\Windows, with IPSec, Network Connections, safer and WSDAPI located underneath. But no "Search" subkey.

    FOR STEP 2 - I have tried this 6 times. I even uninstalled and reinstalled a couple of times and ran the Microsoft installation repair tool. No avail.

    FOR STEP 3- I tried this even more times. This was one of first things I did.

    Overall I have troubleshooted this issue for many months now since the beta, and it's still not working across two different computers. Still need assistance...

    Tuesday, May 25, 2010 6:00 AM
  • Hi,

     

    You can also check if this works:

    http://www.msoutlook.info/question/47

     

    Regards,

     

    Sally Tang

    Thursday, May 27, 2010 9:53 AM
  • Thanks Sally but no avail.

    Recreating the profile doesn't fix, I'm not working from a PST (it's an Exchange acount), I can't "deselect" Outlook as mentioned, and rebuilding/resetting the index doesn't fix either.

    It's definitely an installation bug/issue from what I can tell, but repairing Office doesn't help either. Something is really wrong with the 64 bit verison of Office as I am experiencing other widely experienced issues as well. Since I am also still experiencing the "Office installation/configuration issue", I wonder if these issues are related because Office/Outlooks is not installing properly.

    All-in-all I haven't been able to get anywhere with any number of things recommended and suspect these are related. Just not receiving any real fixes from Microsoft.

    Thank you for your attempted help, though.

    Friday, May 28, 2010 12:16 PM
  • I have been having the same issues with searching shared email, contacts and calendar items.  Search seems to work fine with my own items but is broken with my shared ones.  I too have tried to rebuild the indexing.  It seems to be a problem with the program.
    Saturday, June 12, 2010 7:27 PM
  • What about a search tool which is able to find your contents (in contrast to the worse working standart search which is a problem since Outlook exists).
    Sunday, June 20, 2010 9:29 AM
  • I am having the identical problem with the 32bit version. I have tried all of the steps proposed above to no avail.  The search feature worked fine in Beta, but when I upgraded to the final version, search within Outlook no longer works.  Search within Windows works normally.  It is only in Outlook that the issue presents itself.
    Tuesday, June 22, 2010 5:32 PM
  • same here, worked fine in beta and stopped working when I purchased the full copy.
    Tuesday, June 22, 2010 10:22 PM
  • This is ridiculous.  I am having the same issue with the 64 bit version.  I upgraded from 2007 64 bit.  I have tried rebuilding the index, and I have tried Sally's "answers."  WHERE IS THE FIX?
    Wednesday, June 23, 2010 2:48 PM
  • Hi, I found this search tool for Outlook (for all people who have still problems):

    Lookeen

    Works very fast and is easy to use.

    Friday, June 25, 2010 10:13 PM
  • Still no real answer here?  I have issue on 64-bit Outlook 2010 on 64-bit Win7, and have tried all recommendations I could find, but still no instant search results in Outlook.
    Wednesday, June 30, 2010 4:19 PM
  • I had the problem with 32-bit Outlook on 64-bit Windows.  I think it is finally working, and what eventually solved it was

    (1) Going into the Outlook search options, clicking indexing options, then advanced options and then "rebuild". 

    (2) Enabling mssphtb.dll.  This required 2 steps.  (a) go to Outlook options, add-ins, then manage disabled addins and enable it;  (b) go to Outlook options, add-ins, then manage com add-ins and check the box next to Windows Search Email Indexer.

    Friday, July 09, 2010 7:08 PM
  • I performed the two steps you recommended and neither worked.I saw that mssphtb.dll was disabled and enabled it successfully, and did a rebuild to no avail.

    I am now using Outlook 2010 on two computers - 1 computer running Windows 7 Pro 32bit + Office 2010 32, and the 2nd PC running Windows 7 Pro 64 + Office 2010 64. The search function doesn't work in EITHER installation.

    Very frustrating.

    Monday, July 12, 2010 2:07 AM
  • Got the same problem as well. I have added the question to SuperUser in the hope that someone over there can help out.

     

    I have been impressed with the improvements in search introduced in Outlook 2010. Unfortunately, in the last week search has stopped working for me.

    I have tried all the obvious repair tasks such as repairing office, disabling all add-ins, rebuilding the index, compacting the PST, but no luck.

    It appears that 'mssphtb.dll' (Used by search) keeps crashing and as a result Outlook Disables it. I have tried re-enabling it, but Outlook immediately disables it again.

    I have had a look in the Windows Event Log as well, but Outlook does not appear to log any errors that occur when loading add-ins.

    A lot of people appear to have the same problem, but no fixes so far.

    I am considering installing Xobni, but I prefer to make Outlook work the way it is supposed to and not rely on 3rd party applications.

    Wednesday, July 14, 2010 7:48 AM
  • I have given up and decided to remove the Windows Search feature ENTIRELY to at least get the (slow) search feature back working in Outlook 2010 again. This is what I did:

    1. Control Panel > Programs & Features
    2. Click on "Turn Windows Features On/Off"
    3. Find "Windows Search" and uncheck it
    4. Restart

    After removing Windows Search, the Outlook search feature now works again--but it's not the "instant indexing" method and is much slower. But it still returns proper results nonetheless.

    The only other downfall is that the main search bar is missing from the Windows Start menu, so I can no longer search for files and programs from the Start menu. But since I rely on email searching more than other file types, it's a trade-off that I had to make. 

    I tried reinstalling Windows Search after uninstalling it (and after testing Outlook without it), but then the Outlook search stopped working entirely again. Keep in mind that I did rebuild the index after reinstalling Windows Search and waited until it was complete before testing search again (no luck returning ANY results). Removing Windows Search a second time re-enabled (the slower) search within Outlook. But at least it works.

    It sucks that I can't have the best of both worlds--the ability to use Windows Search AND be able to search for emails from within Outlook. It has to be one feature or the other. Go figure.

    • Edited by eq07 Friday, July 16, 2010 3:42 PM edit
    Friday, July 16, 2010 3:33 PM
  • Any further news?  My issue is that after every reboot, Outlook 2010 email remains unindexed --- until I open it --- then I must wait while 20,000 emails are re-indexed (I have archives).

    I'm trying the steps John F mentioned... I'll let you know if any success here.

     

    Win7 64-bit, Office 2010 64-bit

    Thursday, August 05, 2010 1:15 PM
  • Solution Found!

    For Windows 7, apparently when upgrading from 2003 or 2007 Outlook to 2010, the windows Indexing Service gets shut down and never comes back up on its own. 2010 Outlook no longer uses the add-in mssphtb.dll for Windows Search Email Indexer. Instead, it just uses the Indexing Service.

    The solution is, turn the Indexing Service back on (duh!) and wait a while for it to do its thing. (The new and improved Windows Indexing Service runs slower in the background thus not consuming so much CPU and interfering with the user like the previous one. But, it does a very fine job IMHO.)

    Control Panel >> Programs >> Programs and Features >> Turn Windows Features on or off

    2. Tick (check mark) the Indexing Service check box and hit OK

    Thats it.  You may want to restart your computer just for good measure.  Once you are back up, you will need to wait for a while for the indexing service to Index everything (many hours), but after a short time (half hour) you can check your email search bar and find that some of your email is now showing in the search results.

    This worked for me and I wrote about it on my blog... here: http://blog.corewebsolutions.com/general/outlook-2010-search-add-in-mssphtb-dll-disabled-solution

     

    Hope that helps.

    • Proposed as answer by Coreweb Thursday, August 12, 2010 5:19 PM
    Thursday, August 12, 2010 5:15 PM
  • I was having this exact same problem.  Having read dozens of threads over 2 weeks, I came up with a scorched earth combined solution that seems to have worked.  I'm running Windows 7 Enterprise 64x, Outlook 2010 64x.

    The issue was that email just did not show up in searches.  I would get 0 results.  And when I would go into Indexing Options, Outlook showed as being indexed, but it did not exist in the list to check/uncheck.  So all the solutions where I was supposed to uncheck Outlook were not an option for me.  Repairing Outlook would make the checkbox show up temporarily, so I could uncheck/reboot/check it.  But it did not solve the problem, and the checkbox would disappear within 3-4 reboots.

    It seems the root cause of the issue was with Windows Live Beta or the Outlook Hotmail Connector.  I'm not sure which.  Below is the solution detail:

    1. I uninstalled Windows Live Beta (Control Panel > Programs and Features)

    2. I uninstalled the Outlook Hotmail Connector (Control Panel > Programs and Features)

    3. I downloaded and installed Glary Utilities (the free version) and ran its registry scanner/repair to try to get rid of any leftover registry entries left behind by the uninstalls.  Just google "Glary Utilities" or go to www.download.com

    4. I turned off Windows Search by unchecking it in 'Turn Windows Features On or Off' (Control Panel > Programs and Features > Turn Windows Features On or Off)

    5. Turning off Windows Search prompted a reboot, so I rebooted.

    6. With Windows Search still turned off, I repaired Outlook by finding it in the list of installed programs (Control Panel > Programs and Features) Right-clicking it and clicking Change then click on Repair.

    7.  Repairing Office 2010 prompted a reboot, so I rebooted.

    8.  I turned Windows Search back on by checking it in 'Turn Windows Features On or Off' (Control Panel > Programs and Features > Turn Windows Features On or Off)

    9.  Turning on Windows Search prompted a reboot, so I rebooted.

    10. I went into Indexing Options and grabbed a screenshot (or just make a list) of all the locations being indexed (Control Panel > Indexing Options).  Then I unchecked/removed every single item by clicking Modify and removing them.  The list was completely clear, Indexing was turned on but I wanted it to have nothing to index.

    11.  I rebooted

    12.  I went back into Indexing Options and checked Outlook only.  Since only Outlook was being indexed, I would know that if I saw any progress with items being indexed,  that it was truly Outlook being indexed.

    13. This next part is important...  Wait about 1 hour with no computer use before checking on Indexing progress!!!  Also ensure your computer is not going to go into sleep or hibernate mode.

    I think I may have solved the problem on a previous day, but when I looked at the indexing progress after about 10 minutes it showed 0 items indexed so I thought that I had not solved it and started working on it again.  I wasted a lot of time because I thought the problem was still there, when I should have just been a little more patient.  Windows Search takes a while to even begin indexing and it must be (1) while the computer is turned on, (2) with no user giving it any input, (3) and the computer does not go into sleep/hibernate.

    14.  After an hour, I came back to my computer and saw that it was indexing.  Since Outlook was the only thing being indexed, I figured that was what was being indexed.  I went away again, and came back after a couple more hours.  Indexing was showing Complete and I had ~28,000 items indexed.  I tried searching in Outlook and everything worked.  Success!

    15.  I went back into Indexing Options and, using my screenshot (or the list you made) as a reference, I turned on indexing for all the other locations I needed.  The next morning everything was back to normal.

    You may not need to do everything I did, but hopefully some/all of it helps you figure out a solution if you're having a similar problem.

    • Proposed as answer by ALANWILSON1953 Thursday, August 26, 2010 5:20 PM
    Sunday, August 22, 2010 7:00 PM
  • Yes, my problem began immediately after install of Windows Live Beta and the Outlook Hotmail Connector. Even though I have removed these, instant search in Outlook will not work. Doing many, if not all, of the things you suggested did at least bring back the ability to do a (slow) search in Outlook. However, doing a search from the Start menu will not find email messages (it will find other files and folders).

    This seems to be a widespread problem that is being ignored by MS. I would have expected a fix by now. Maybe they broke it and don't know how to fix it :)


    Thursday, August 26, 2010 5:24 PM
  • After almost 5 months I can't believe I FINALLY FIXED THE PROBLEM!!! What I did was move the indexing location: In "Indexing Options" control panel under Advanced, I clicked the "Select New" box at the very bottom, created a new folder called "Microsoft Search" under the "C:\ProgramData" folder (it was previously set to C:\ProgramData\Microsoft) and selected the new folder I just created as the new Index location.

    After doing that, my Indexing Options began showing a checkbox next to "Microsoft Outlook" and listed all email accounts and PST's below (also with checkboxes). Previously, it never even showed a checkbox next to Microsoft Outlook. Nor did it list any of my email accounts.

    What's also great is that "Offline Files" suddenly appeared as an available option. I never saw an "Offline Files" option prior to this.

    After leaving Outlook open for several hours after doing the trick, it finally indexed all of my emails! I didn't even think about moving the index--nor can I believe no one suggested that at all before LOL. Everyone suggested rebuilding the index and all kinds of stuff, but I'm glad I finally got it working!

    Thursday, September 09, 2010 11:08 AM
  • I did this (moving the index location) before. Instant search worked for a little while, then stopped working. I opened a support ticket with Microsoft and they are helping me find a solution. I'll report back here if any of their suggestions work.

     

    Friday, September 10, 2010 3:16 PM
  • @ALANWILSON1953 Please do. Thank you!
    Friday, September 10, 2010 10:43 PM
  • No luck. Online Support sends me a message with the following:

     

    Together we have performed most of the steps that should have resolved the issue but I am afraid it has not in our case.

    Monday, September 13, 2010 7:57 PM
  • No luck. Online Support sends me a message with the following:

     

    Together we have performed most of the steps that should have resolved the issue but I am afraid it has not in our case.


    That's ALL they told you? Surprising but not surprising. Although it's working for me right now, I'm still very frustrated that Microsoft has not responded to anyone with a clear answer as to why/how and how to resolve. It seems to be a well known problem for many people, and the steps taken to resolve seem to be different for everyone at the same time.

    It shouldn't be this difficult. They're basically saying "it's broke and we CAN'T fix it." What other levels of support are there?

    Monday, September 13, 2010 8:05 PM
  • Eric,

    Make sure you have Exchange cached mode as ON. Yes, putting that on actually fixed my problem. If doesn't fix yours then good luck!

    Jon

    Wednesday, September 15, 2010 8:21 PM
  • Tenacious,

     

    Thanks for taking the time to post this solution. 

     

    I'm running Windows 7 Professional x64 and Office 2010 Professional Plus and have had the indexing issue since a couple of months from new installation.  This helped me get the indexing issue working for a few months until I have to repeat this process.

    I'd love to hear from Microsoft or anyone that has found a permanent solution to this issue, as this seems to be acknowledged by users as an issue but brushed aside by the support at Microsoft.  It is either too hard to deal with or just not enough of a concern, it seems. 

     

    It is suprising that this issue wasnt caught or acknowledged during RC testing.  Given the failures of Vista, I would have thought that everything would have been thoroughly tested before release for sale.

     

    Long live open source, I'm not wasting time and money on Microsoft products again.

    Thursday, November 11, 2010 1:45 PM
  • Any other ideas?
    Monday, December 27, 2010 3:27 PM
  • None of these helped, anything else?
    Monday, December 27, 2010 3:28 PM
  • Ditto to all above. I am very disappointed in Microsoft re: resolution--acknowledgment--of this issue.

    I am running Windows 7 (64 bit) on a dual boot MacBook Pro; and MS Office 2010 (64 bit).

    Not sure if this helps, as I'm primarily a Mac user, but the Windows Search Email Indexer com file is located in the System 32// mssphtb.dll folder (now, as I understand it, a dated search format). Why isn't it there some equivalent add-in in the System folder (64 bit)? Rather, it does seem that the old search agent is incompatible with the 64-bit system. On the Mac side, any 32-bit apps, etc., must be, esentially, restarted in order to use them (see especially 32-bit System prefs), which seems to be the case with this add-in.

    Apologies for the wandering wandering thoughts of a beginner here.

    • Proposed as answer by jarmakani Sunday, January 16, 2011 10:04 PM
    Saturday, January 08, 2011 7:24 PM

  • hey guys...  i found a way to fix this.  i had all the problems stated above and tried everything. anyway...  below is a post from another forum:
    Microsoft Support helped in the solving of this problem. In retrospect it may have been solved by running SCANpst.exe on the Outlook Data file. SCANpst.exe is found in C:\Program Files\Microsoft Office\Office 14\ or in Program Files (x86)\... if using 64 bit Windows 7.

    I hope this helps someone else with an Outlook problem.
    • Proposed as answer by jarmakani Sunday, January 16, 2011 10:06 PM
    Sunday, January 16, 2011 10:06 PM
  • John Federico - Your right, it worked. mssphtb.dll was disabled and needed to be enabled. Thank you!
    Friday, March 25, 2011 6:25 PM
  • After much effort I was able to fix the problem with my search-

    My problem was with Windows 7 and Outlook 2010.  Searching email gave a message "Search results may be incomplete because items are still being indexed".  If I wait until indexing completes, it works – Until the next day, when I again get the same message.  I tried a lot of things; finely the last set of actions worked- 

    1.       BACKUP YOU SYSTEM…

    2.       In Control Panel/Uninstall Programs/Turn Windows features on and off.  Uncheck indexing service and uncheck windows search.  Reboot.

    3.       In Control Panel/Uninstall Programs/Microsoft Office. Select Change.  Remove Outlook. Reboot.
    (this sounds extreme, but when you add Outlook back in #5, it retains all of your settings)

    4.       In Control Panel/Uninstall Programs/Turn Windows features on and off.  Leave indexing service UNCHECKED and check windows search.  Reboot.

    5.       In Control Panel/Uninstall Programs/Microsoft Office. Select Change.  Add Outlook. Make “not available” or “install on 1 use” any options that you do not use.  Reboot.

     

    At this point my search began working again - 3 weeks later it remains fixed!!!

    There is an add-in, “windows search email indexer” that remains disabled for some unknown reason and does not affect the search.  Scanpst.exe still shows “minor inconsistencies”; with no effect.  It does this even with a new empty data file.

     

    Some considerations- 

    I did not try to isolate the exact cause of the problem.  It might be as simple as running only steps #2 and #4; I suggest trying this first.

    Things I did earlier that did not participate in the immediate solution, but could possibly have had an influence:

    ·       In Outlook/file/options/add-ins/manage-com addins GO.  Uncheck addins that you are not using.

    ·       In Outlook/file/account settings/data files.  Select your data file(s)/settings make sure that they say “Outlook Data File”, not something with a year like “Outlook Data File 97-2003“.  If you have an old version data file, use select ‘add’ to add a new data file with a different name.  Use file/options/advanced/export to import the old file into the new data file. Set the new file as default.   Leave Outlook running for an hour(yes an hour I’m not sure it ever ends and you might want to close the window then) while it says copying defaults.  Then you should be able to choose remove on the old file.

     

     

    Saturday, April 02, 2011 6:26 AM
  • I just posted my fix and i find this very simple fix, which makes a whole lot of sense-

    http://www.pcreview.co.uk/forums/instant-search-not-working-and-outlook-indexing-never-completes-t3455077.html

    Here is his fix(too late for me to try...):

    OK - I spent days trawling through Google searches trying various ways to resolve this problem.
    It was so easy in the end - I just re-installed Windows Search from here:

    http://www.microsoft.com/windows/products/winfamily/desktops earch/choose/windowssearch4.mspx

    • Proposed as answer by DenverJohn Thursday, September 22, 2011 5:52 PM
    Saturday, April 02, 2011 6:33 AM
  • In Administrative Tools, Services I started the Indexing Service.  Now it works perfectly!
    • Proposed as answer by Billfas Friday, August 05, 2011 9:51 PM
    Friday, August 05, 2011 9:47 PM
  • In order to resolve the search issue with Outlook.Open the Exchange server Management console and Move the mailbox to another storage group  it will definitely resolve the problem.
    I am a Champion!!
    Monday, September 12, 2011 12:42 PM
  • I just posted my fix and i find this very simple fix, which makes a whole lot of sense-

    http://www.pcreview.co.uk/forums/instant-search-not-working-and-outlook-indexing-never-completes-t3455077.html

    Here is his fix(too late for me to try...):

    OK - I spent days trawling through Google searches trying various ways to resolve this problem.
    It was so easy in the end - I just re-installed Windows Search from here:

    http://www.microsoft.com/windows/products/winfamily/desktops earch/choose/windowssearch4.mspx

    This is from HardDrive Miami!!!!  He rules on this one!

    This solution works.  At least it did for me.  If you have Google Desktop search, remove, apply the fix for WIN Search and it works.

    Thanks for this easy solution HDM!  I now can search and filter as designed.  Avoid Registry Fixes, this works.



    • Proposed as answer by DenverJohn Thursday, September 22, 2011 5:34 PM
    • Edited by DenverJohn Thursday, September 22, 2011 5:42 PM
    Thursday, September 22, 2011 5:33 PM
  • Hi all. 
    I have tried all the possible solutions on tons of different forums and eventually found one thing that works across the board. I followed the steps above being :
    • Control panel -
    •  Programs - 
    • Turn Windows Features on/off - 
    • Turned windows search off and indexing on. then wait for changes to take effect. Do a restart. open outlook and do a search. 
    Then after finding a few things, go to : 
    • Control Panel - 
    • Programs - 
    • Turn Windows Features on/off - 
    • Turn Windows search back on and leave indexing on. 
    Let new settings take effect and then restart again. During restart power down/up you will see 'Windows is Configuring....%' . That means it is (should be) working. After the restart, open outlook and let it index completely. This should do the trick. ( It did it for me) .
     DON'T FORGET to check all the indexing folders are correct before doing this. This can be done in outlook search options - index folders - modify.
    Hope this helps.

    Regards, Paul Bristow Proudly South African
    Tuesday, September 27, 2011 3:48 PM
  • I have been having this same problem since upgrading my system to Vista 64bit and Office 2010 64bit, and been trawling the internet looking for answers.  Just as I was giving up after trying every suggested answer I found, I discovered the answer on my own.

    My email is through an Exchange Server, and in the Account Settings - More Settings - Security the option to Encrypt Data between Microsoft Outlook and Microsoft Exchange was checked, and then in the Search Options - Indexing Options - Advanced, Index Encrypted files was unchecked.  This made me think to myself "can Instant Search not index my emails because they are encrypted?".

    I removed the check from Encrypt Data between Microsoft Outlook and Microsoft Exchange, and then rebuilt my index.

    I am now able to find indexed emails in my Exchange Email folder, with Cached Exchange Mode Selected.

    I have not tried it the other way round, i.e. Leaving a check in the Encrypt Data between Microsoft Outlook and Microsoft Exchange, and then adding a check in the Index Encrypted files option.  But this may also work.

    Hope this helps anyone that has been scratching their heads over this.
    Wednesday, May 02, 2012 3:18 PM
  • Please check if your inbox is selected to crawl. If outlook is selected and the inbox/folder is not selected then the contents of the folder are not crawled. 

    Outlook > File > Options > Search > Indexing Options > Highlight Outlook > Click on Modify button. Verify if the inbox(es) are selected. 

    Outlook indexing options


    Chandra

    Tuesday, May 22, 2012 12:20 AM
  • I'm having the same problems as Eqiq07. Every time I close Outlook, it loses the index. Every day I rebuild it, every time I close outlook it loses it. Windows Indexing just won't stay turned on. I've had 10 different MSFT techs work on it, and they're all opting for the easy solution offered by so many people above. That solution works fine - until I close Outlook. They all refuse to believe me.

    I'll try some of the more complex solutions later this weekend. Using Ver 14.06 of Outlook in Office Pro 2010

    Friday, June 01, 2012 11:49 PM
  • I have been searching for a solution on many forums. Found this on microsofts site. Hope it helps.

    http://support.microsoft.com/kb/2528748

    Tuesday, June 19, 2012 7:05 AM
  • Everyones issue/solution is different, but I was having the exact same issue and even managed to reproduce it on 2 clean build, separate machines.

    The issue for me was as follows

    • Install new x64 Office 2010 with SP1 on Win 7 x64 machine
    • Configure Outlook, restarted several times to test search, all work.
    • Windows updates (including an update for Office 2010), reboot machine
    • Open Outlook, search doesn't work.
    • Rebuild Index - search works, reboot search doesn't work

    I then decided to do a repair on my Office installation. Reboot the system, rebuild the index. Test, Reboot and test again, working. I have done this on all 3 machines. Also, I didn't change any of the default indexing settings, just rebuilt it after doing a repair.

    I'm not sure which update it is, but its working and that's all I care about. Hope this helps someone else.

    Paul

    • Proposed as answer by HMS_Support Thursday, October 25, 2012 7:57 AM
    Thursday, October 25, 2012 7:57 AM