Attachment Icon Missing in List View?


  • I am running MOSS 2007 and have just noticed that when I view items in a list that have an attachment, the file type icon is not displayed in the Attachment column, rather I get a red X in it's place with the word "Attachment".  It does not matter what type of file I try to attach, I get the same result.  The site does, however, display the correct file type icon for items in my document libraries, this just seems to be an issue with lists such as Tasks or custom lists.  I am able to open the attachment from the list item detail page, so the attachment itself seems OK, I just can't figure out why the attachment icon isn't being displayed correctly.




    Wednesday, February 13, 2008 9:33 PM


All replies

  • You are facing a security issue: the gif for the paperclip attachment is not reachable. Check your _layouts hive through your IIS and check the box Basic Authentication for that hive to see if it is solving your problem: it did at my implementation anyway.


    Saturday, February 16, 2008 5:08 PM
  • Thanks Patrik,


    I modified the security settings through IIS as you described and did an iisreset but the icons still do not show up correctly.  I have confirmed that the icons are in the images folder, they're just not showing up for list attachments.


    Monday, February 18, 2008 2:03 PM
  • I've double-checked the security just to make sure I haven't missed anything but no luck.  I have, however, cleared up some additional details for my own sake which may help.  The icon that is not being displayed is attach.gif (the small paper-clip image), not the individual doc-type icons (for things such as Word, PDF, etc.).  There are two strange things that I've now figured out as well:


    1) The attach.gif icon displays fine on my primary site, it just does not display for sub-sites, and

    2) The attach.gif icon displays in the heading of the list (if I have an attachment column and a title column the paperclip icon is displayed above the attachment column next to the word Title over the title column), it just does not display for the individual row in the list that has the attachment.


    Hopefully that clarification will help with an answer.




    Monday, February 18, 2008 10:11 PM

    Hi Chanda,


    this is 100% exactly the same issue like we had. The attach.gif was displayed on some sites, on others it wasn't. Please check your security settings in IIS for the directories where the gif is stored and check the box Basic authentication. You have to do this through IIS and not on the physical file system, as these files are stored for each site in kind of a virtual hive. Please check it on the lowest level, as sometimes we noticed the security settings aren't inherited by subfolders for one reason or another.

    Tuesday, February 19, 2008 7:42 AM
  • I am looking at IIS right now at I can't see that there is more than one directory that the .gif is stored.  In IIS I have a website called Intranet, and when I expand that site the only location that houses that icon is the virtual directory called '_layouts' which has the 'images' folder right beneath it.  Both _layouts and images have Basic Authentication checked under Directory Security.  I've even selected Basic Authentication for the entire Intranet website in IIS but still the attach.gif icon is not displayed for subsites.  I have 4 sub-sites that were created within the Intranet site, and these are the areas that do not display the icon, however they do not show up in IIS (unless I just don't know where to look) so I'm not sure where else I need to be looking.  Thanks


    Tuesday, February 19, 2008 1:41 PM
  • Hi,


    We're having exactly the same problem in MOSS, but I don't understand why basic authentication would be needed. I'd rather not use it if it is not necessary. What is wrong with Integrated Windows Authentication?



    Friday, May 16, 2008 3:46 PM
  • Friday, May 16, 2008 8:45 PM


    This fixed our issue.  Thanks!


    Admin had pointed the site to an alternate application pool while troubleshooting another issue and forgot about it.

    Thursday, May 22, 2008 9:16 PM
  • I'm moving the thread to Admin. This is not a customization issue.
    Friday, May 23, 2008 6:04 AM
  • Thanks Mindy, this fixed the issue for me as well - somewhere along the line in testing I changed the Application Pool account and never switched it back.


    Friday, May 23, 2008 12:56 PM
  • A user reported this issue to me recently, and none of the solutions above resolved my issues.  There is one entry which proposed modifying the docicon.xml file in :\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\XML.  Most of us have attempted or successfully modified this file to get the pdf icon to show up (with iFilter).  In my case, there were duplicate entries for the pdf icon location.  Once I removed the duplicate and executed iisreset, my icons are properly showing up in the search results.  I have always been able to see my document type icon in the library.

    I hope this helps someone that is currently having this issue.  There were not very many "helpful" posts about this.

    • Proposed as answer by Waylin Thursday, October 16, 2008 6:20 PM
    • Edited by Waylin Thursday, October 16, 2008 6:23 PM
    Thursday, October 16, 2008 6:20 PM
  • the site is down. can you please explain the solution? i have similar problem: sometimes i see the icon and sometimes i don't (even on the same page).

    Wednesday, August 19, 2009 1:04 PM
  • i tried to get to the site where the solution is supposed to be:***lly/archive/2008/05/16/some-icons-disappear-in-moss.aspx but i receive a "not found" error, so i cannot view the solution. anybody have an idea of the correct site above which contains the solution to this problem ? thanks
    Monday, February 01, 2010 4:10 PM
  • I had this problem and in my case the issue was that the images virtual directory was configured to use a different application pool than either it's parent (_layouts) or the web application.

    Some time ago I had changed the application pool being used by this SharePoint site and the change must not have cascaded down to all the required locations.  As soon as I changed the images virtual directory to use the same app pool the issue disappeared - it didn't require an IIS reset or anything.

    Hope that's helpful.

    • Proposed as answer by meharrison Thursday, August 30, 2012 5:39 PM
    Monday, February 08, 2010 7:27 PM
  • The links above have "***" in the middle and don't work... Here is the correct link:

    Mike Smith
    Monday, February 08, 2010 7:41 PM
  • This was exactly my issue.  It took me a minute to find the right place to make the change however, so I thought writing out my steps would be helpful.  Our web application was initially set up on port 80, which was creating conflicts elsewhere, so it had to be changed to port 8080.  I clicked on the images folder under _layouts and clicked on Basic Settings and was able to change it to the correct application pool and it now works great.
    Thursday, August 30, 2012 5:43 PM