locked
Do not allow / Show to select "Tentative" option in Responce RRS feed

  • Question

  • Hi, 

    My requirment is that,  the user should not able to select "Tentative" option in Response to the meeting / appointment that is being created. 
    These meeting / appointment are created using C# something like vcalendar generation. 

    Is there any option of dis-allowing same, while generating the  meeting / appointment. 

    Thanks
    Saturday, November 27, 2010 5:26 PM

Answers

  • Hi,

    Turning off the request responses programmatically consists of three steps.

    • Create a custom form
    • Publish the form in your Calendar folder
    • Make the new form the default appointment form

    To create a custom form, follow these steps:

    1. In the Outlook Calendar view, on the Calendar menu click New Meeting Request.
    2. On the Tools menu, click Design Outlook Form.
    3. On the Form menu, click View Code.
    4. In the Visual Basic Script Editor type the following:
         Function Item_Open()
          Item.ResponseRequested = False
         End Function
      						
    5. On File menu, click Close.

    You can publish forms several ways. This example shows how to publish your form in your Calendar folder. Follow these steps to exit the design mode and publish the form:

    1. On the Tools menu, click Design Outlook Form to exit the design mode.
    2. On the File menu, click Publish Form As.
    3. In the Form name box, type MyForm and click Publish In.
    4. In the "Set Library To" dialog box, click to select Folder Forms Library.
    5. In the folder list, click to select your Calendar folder and click OK.
    6. Click Publish to publish MyForm in your Calendar folder.
    7. On the form File menu, click Close. When prompted, Do you want to save changes? Click No.

    The form is now available under the Calendar menu as New MyForm.

    To set this new form as your default appointment form, follow these steps:

    1. In Folder List view, right-click the Calendar folder and on the shortcut menu click Properties.
    2. Click to select MyForm from the "When posting to this folder" list.
    3. Click Apply.

    For more information about how to disable the option that requests responses for meetings, you can refer to this KB article: http://support.microsoft.com/kb/174716

    Hope that helps.

    • Marked as answer by bdnp Thursday, December 2, 2010 12:01 PM
    Monday, November 29, 2010 9:03 AM