none
Excel unable to save or open password protected xlsx files...

    Question

  •  

    Hi guys one of our users is having trouble saving & opening password protected xlsx files in Excel. This has only just started happening yesterday.

    The errors are:

    When opening:
    "Excel cannot open this file. The encryption type used is not available, contact the author of the files. More encryption types are available using the High Encryption Pack"

    When saving:
    "Excel is unable to encrypt your file. Please contact your system administrator to resolve this problem. Do you wish to remove encryption and try again? "

    It is doing this no matter where the file is, network share, desktop, my documents etc. With different files & new files so it's not just limited to one file.

    I've tried opening Excel in safe mode still no joy.

    I've also tried logging in as me on the problem PC & I can open the files & save new password protected files fine. Also no one else on the network is having this issue.

    I've also tried logging the user in on a different machine & there's no problems there either.

    This problem has got me rather baffled & I've drawn a blank on Google so hopefully someone can help me?

    I also tried doing an Office repair & still no luck

    Oh also the machine is fully patched.

    • Moved by Jennifer ZhanModerator Wednesday, November 03, 2010 5:49 AM (From:Office 2010 Application Compatibility)
    Tuesday, November 02, 2010 12:13 PM

All replies

  • Hi,

    I guess this issue is related to the permissions of this user. Your user maybe has lost ownership of those files & folders or it no longer has the required permissions. If so, try following method:

    First, navigate to that problem Excel file, right click on it and select Properties.

    In the Properties window go to the Security tab and click on Advanced.

    Now go to the Owner tab. Here you will see the current owner of that file. If your user is not the owner, click on Edit. If you have User Account Control enabled, press on OK.

    In the Owner window, click on Other users or groups. Now you need to type the user name or the group of users that will take ownership of the selected folder. If you type "Administrators" you will give ownership to all the users that are administrators on your PC. If you want to give ownership only to your user, then type your user name. After that, press on Check Names.

    If the user or group was found on your computer, you will see that the text you typed was changed to [Your PC Name]\[User] or [Your PC Name]\[Group]. If so, press on OK.

    If the user/group was not found you will receive a Name Not Found error window. Make the necessary corrections and try again.

    In the Owner window, select the user/group you just added, select Replace owner on subcontainers and objects and press OK.

    Now you will receive the confirmation that you have taken ownership of the folder. Press on OK and that's it.

    Hope that helps.

    Wednesday, November 03, 2010 5:48 AM
  • I'll try it but but all the permissions are set by AD.

    Also she can't save brand new password protected excel files anywhere either (desktop, my docs etc) but she can save normal Excel files (and any other type of file for that matter).

    The really weird thing is if we try to save a new blank password protected Excel file in the old xls format it works.

    Also just thought to have a look in the event viewer (why i didn't do this sooner i don't know) and found the below which occurs when trying to save or open passworded files.

    Log Name:      Application
    Source:        Microsoft Office 14
    Date:          11/3/2010 3:37:08 AM
    Event ID:      2010
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      <snip>
    Description:
    CAPI Create Key Error: 0x80070057, CngCipherAlg: AES, Prov: Microsoft Base Smart Card Crypto Provider, ProvType: 1, Algid: 0x0000660e, KeyBits: 128, Block size: 0, Hash size: 20
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft Office 14" />
        <EventID Qualifiers="0">2010</EventID>
        <Level>2</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2010-11-03T08:37:08.000000000Z" />
        <EventRecordID>12611</EventRecordID>
        <Channel>Application</Channel>
        <Computer><snip></Computer>
        <Security />
      </System>
      <EventData>
        <Data>CAPI Create Key Error: 0x80070057, CngCipherAlg: AES, Prov: Microsoft Base Smart Card Crypto Provider, ProvType: 1, Algid: 0x0000660e, KeyBits: 128, Block size: 0, Hash size: 20</Data>
      </EventData>
    </Event>

    Wednesday, November 03, 2010 8:40 AM
  • Oh forgot to mention the machine in question is in a remote office, so I'm slightly limited by what i a can try :(

    I'm half tempted to try removing her profile & see if that solves it, as anyone else that uses that machine is ok & if i log in as her on another PC it's also fine.
    Wednesday, November 03, 2010 8:58 AM
  • so no one has any idea?
    Friday, November 05, 2010 3:02 PM
  • Definitely sounds like a server policy problem.

     


    Elected! Your votes and support have got me my 2010 MVP!

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews

    Friday, November 05, 2010 4:04 PM
  • I am having the same issue on my network. In my case I am able to pin point the problem to a settings change that the user made inside Excel 2010. I have been playing around with the settings with no luck. I recommend that you check the settings and look for a section where you can change the encryption or password preferences on XLSX files.  If I am able to find the section I will post it here shortly.
    Friday, November 05, 2010 8:38 PM
  • The OP mentioned the use of AD so I suspect settings are influenced by the policies of the server in use.

     


    Elected! Your votes and support have got me my 2010 MVP!

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews

    Friday, November 05, 2010 8:40 PM
  • I am having the same issue on my network. In my case I am able to pin point the problem to a settings change that the user made inside Excel 2010. I have been playing around with the settings with no luck. I recommend that you check the settings and look for a section where you can change the encryption or password preferences on XLSX files.  If I am able to find the section I will post it here shortly.
    Hrm yeah i think it's got to be a setting she has changed somewhere or something has gone wrong with her profile on this machine. Just need to try & find what or where...
    Tuesday, November 09, 2010 10:55 AM
  • Hmm no it's not a 'setting'.  This has happened for me ever since I upgraded to 2010, a couple months ago.  Other users with 2010 can save encrypted files just fine, but I cannot.  I'm a Domain Admin so it has nothing to do with permissions or any of that ____.

    This is a problem with Excel that Microsoft needs to sort out.  I'm F**KING sick of constantly searching for workarounds for Microsoft Products

    Thursday, January 20, 2011 7:35 PM
  • I have some secure worksheets and they seem to be OK so I wonder if something else has tampered with you installation of Office 2010.

    to be safe, use the system file checker, in the search box of the start menu

    sfc /scannow

     


    My MVP is for Windows XP, Vista and Windows 7 IT, and I am getting increasingly good with Visual Studio.

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews

    Thursday, January 20, 2011 7:37 PM
  • i have the exact same problem, 100 users same deployment pack, 1 have this issue

    tryed fixit packs from Microsoft for 100 % uninstallment - no luck.

     

    I know it is a pretty new case but you solved it?

     

    Wednesday, March 09, 2011 9:36 PM
  • I have had no problems in my shop but I run everything so I am on top of any issues.

    If you password protected sheet is not opening, make sure the password is correct.

     

    Try to copy the sheet to a local drive and open it, if it opens then there is a server permissions problem that needs to be fixed

     


    My MVP is for the Windows Desktop Experience, i.e. Windows XP, Vista and Windows 7 IT

    I am best with C++ and I am learning C# using Visual Studio 2010

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews

    Wednesday, March 09, 2011 9:42 PM
  • Lokal workseet or word same issue

    user is lokal admin

    dont think this is a rights issue

     

    Monday, March 14, 2011 8:29 AM
  • rights to the file are distinct to the spreadsheet password which is set by Excel itself

     


    My MVP is for the Windows Desktop Experience, i.e. Windows XP, Vista and Windows 7 IT

    Remote Assistance is available for a fee.

    I am best with C++ and I am learning C# using Visual Studio 2010

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews

    Monday, March 14, 2011 7:18 PM
  • Solution is simple.. you just need to install the SP2

    2007 Microsoft Office Suite Service Pack 2
    Friday, March 09, 2012 2:36 AM
  • We had this problem after installing "card reader" verification for logon, with Office 2010. 

    For Office 2010, use hotfix 2596996

    http://support.microsoft.com/kb/2596996

    Wednesday, October 31, 2012 11:14 AM