none
Open Documents in Client Application not working RRS feed

  • Question

  • Need a little bit of help here. We have a site collection that the users are asking that their Excel document in a document library open in their Excel desktop application, not in the OWA browser. 

    These are the steps that I have tried.

    1. Turn on the "Open Documents" feature in Central Admin. Went into Site Settings and activated the site collection feature.

    2. Enabled Client Integration in Central Admin. Went to manage web applications - selected our web app - authentication providers - default - selected yes for Client integration.

    3. went to the site collection and enabled "Open Documents" in the site collection features.

    4. Changed the library settings where the document is saved. Library tab - library settings - Advanced settings - and tried both "use server default" and "Open in the client application".

    No matter what setting we try, the Excel document always opens in OWA browser. 

    Here's some side notes. The Excel document was created in Office 2010 32bit. I also tried uploading an Excel document that I created in Office 2016 32bit. I tried opening the document in Chrome as well as IE 10 (32bit). I read online that I should "repair" Office. I tried that with no help.

    Does anyone have any other suggestions? Know what to look for in ULS? I don't even know where to start. We are running SharePoint 2013 Enterprise On Prem Build 4797 on SQL 2014. We also have an OWA server for the farm as well. 


    Bill

    Wednesday, April 20, 2016 6:28 PM

Answers

  • Hi Bill,

    Per my test in my environment without office web app, to open excel documents in client application, there are two methods. My SharePoint version is 15.0.4481.1005.

    1. In the library settings->advanced settings->select “Open in the client application” for the Default open behavior.

    2. Activate the “Open Documents in Client Applications by Default” in site collection features, and in the library settings->advanced settings-> select “use the server default” for the Default open behavior.

    You could check the ULS log, the ULS log path is C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\Logs and you could search excel or excel calculation services in the log file.

    And you could reset IE to check if it can work. Go to internet options->advanced tab->reset.

    And you also could do IIS reset to check if it can work.

    If the issue still exists, you could create a new library and in the advanced settings, you could select “Open in the client application” for the Default open behavior to check if it can work.

    More reference:

    Set the default open behavior for browser-enabled documents (Office Web Apps when used with SharePoint 2013).

    https://technet.microsoft.com/en-us/library/ee837425.aspx

    Best regards,

    Sara Fan


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Thursday, April 21, 2016 6:31 AM
    Moderator

All replies

  • Hi Bill,

    Per my test in my environment without office web app, to open excel documents in client application, there are two methods. My SharePoint version is 15.0.4481.1005.

    1. In the library settings->advanced settings->select “Open in the client application” for the Default open behavior.

    2. Activate the “Open Documents in Client Applications by Default” in site collection features, and in the library settings->advanced settings-> select “use the server default” for the Default open behavior.

    You could check the ULS log, the ULS log path is C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\Logs and you could search excel or excel calculation services in the log file.

    And you could reset IE to check if it can work. Go to internet options->advanced tab->reset.

    And you also could do IIS reset to check if it can work.

    If the issue still exists, you could create a new library and in the advanced settings, you could select “Open in the client application” for the Default open behavior to check if it can work.

    More reference:

    Set the default open behavior for browser-enabled documents (Office Web Apps when used with SharePoint 2013).

    https://technet.microsoft.com/en-us/library/ee837425.aspx

    Best regards,

    Sara Fan


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Thursday, April 21, 2016 6:31 AM
    Moderator
  • Thanks Sara! I think the IIS reset worked. 

    From what I was reading Office 2010 wasn't going to be able to open the Excel document when we clicked on it in the library, but it did work. I was pleasantly surprised. 

    Thanks for the suggestions!!


    Bill

    Friday, April 22, 2016 1:22 PM
  • Hi Bill,

    It is very happy that you have resolved the problem.

    Thank you for your sharing and it will help others have the same issue.

    Best regards,

    Sara Fan


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, April 25, 2016 12:38 AM
    Moderator