none
RDP windows always start at 0, 0 RRS feed

  • Question

  • An issue that has always caused me frustration is that whenever I open a remote desktop window, that window opens at 0, 0 on the screen.  With my 22" 1680x1050 monitor, that is hard to see; I prefer my windows to open in the center of the screen.  Even better, let a specific rdp connection open in the same location as I last closed it.  For years, whenever I open a remote desktop window, I have to drag the window into a comfortable location on the screen for viewing.

    While this has always been frustrating, now with Windows 7 it is even worse.  Now it is time to plead with the remote desktop team to fix this issue.  In Windows 7, when a window opens at 0, 0 it is automatically maximized and if you drag it away from 0, 0 it automatically "un-maximizes" - as in "restore".  So by this behavior in Windows 7, all my remote desktop windows open maximized at 0, 0 (but still at the specified screen size, such as 1024x768).  When I drag them to the center of the screen, they shrink way down and I have to manually resize the window to show the entire remote desktop.

    So, previous to Windows 7:  minor frustration in having to relocate the remote desktop window every single time for every single remote desktop.
    With Windows 7: big frustration because now I have to relocate the remote desktop window and then resize the window every single time for every single remote desktop.

    Big difference in frustration level.

    Please, RDP team, update the client to remember user preferences from session to session.  This is standard Windows certified software behavior.

    Regards,

    Dale
    Sunday, September 13, 2009 3:06 PM

Answers

  • Hi Dale,

    Please try disabling Aero Snap feature as a workaround.

    Control Panel--Ease of Access Center--Change how your mouse works, check Prevent windows from being automatically arranged when moved to the edge of the screen.  Or if you like your Control Panel view to be small icons it is Control Panel--Ease of Access Center--Make the mouse easier to use, check Prevent windows from being automatically arranged when moved to the edge of the screen.

    Please let me know if this helps.

    Thanks.

    -TP

    Monday, September 14, 2009 2:36 PM
    Moderator
  • Dale At Work,

    try messing with the settings in the RDP file. Open the RDP file in notepad and look for the winposstrs setting.

    It will look something like this:  winposstr:s:0,1,23,16,823,616

    This is what I get from changing these fields:

    winposstr:s:0,(open maximized or not),(left-right position or left side),(up-down position of top),(left-right position of right side),(up-down position of bottom)

    So, to get my window to open in the 1,1 position but with no scroll bars, and at 800 x 600 I have to care about 3 settings in the RDP file.

    The first ones in the RDp file are:

    desktopwidth:i:800
    desktopheight:i:600

    winposstr:s:0,1,1,1,830,630

    Now,

    to change this so that the window opens more towards the middle of my screen and at 1024 x 768, I do this:

    desktopwidth:i:1024
    desktopheight:i:768

    winposstr:s:0,1,50,50,1104,848 

    (what works for me is to add 30 plus whatever amount i choose to move the screen.  So, 1024 + 30 + 50 and 768 + 30 + 50)

    You may be able to home in on this a bit more through testing.


    PS - All that testing was done with win2k8 and Vista.  When I test with Win7 connecting to a Win2k8 R2 server, I have to offset by 40, not 30, like this:

    desktopwidth:i:800
    desktopheight:i:600
    winposstr:s:0,1,100,100,940,740


    You will have to test to see what works for you. 







    Hope this helps,

    Kristin L. Griffin

    Co-Author of the Windows Server 2008 Terminal Services Resource Kit (and a SUPER BIG fan of the Microsoft RDV Team!!!)
    Monday, September 14, 2009 3:25 PM
    Moderator

All replies

  • Hi Dale,

    Please try disabling Aero Snap feature as a workaround.

    Control Panel--Ease of Access Center--Change how your mouse works, check Prevent windows from being automatically arranged when moved to the edge of the screen.  Or if you like your Control Panel view to be small icons it is Control Panel--Ease of Access Center--Make the mouse easier to use, check Prevent windows from being automatically arranged when moved to the edge of the screen.

    Please let me know if this helps.

    Thanks.

    -TP

    Monday, September 14, 2009 2:36 PM
    Moderator
  • Dale At Work,

    try messing with the settings in the RDP file. Open the RDP file in notepad and look for the winposstrs setting.

    It will look something like this:  winposstr:s:0,1,23,16,823,616

    This is what I get from changing these fields:

    winposstr:s:0,(open maximized or not),(left-right position or left side),(up-down position of top),(left-right position of right side),(up-down position of bottom)

    So, to get my window to open in the 1,1 position but with no scroll bars, and at 800 x 600 I have to care about 3 settings in the RDP file.

    The first ones in the RDp file are:

    desktopwidth:i:800
    desktopheight:i:600

    winposstr:s:0,1,1,1,830,630

    Now,

    to change this so that the window opens more towards the middle of my screen and at 1024 x 768, I do this:

    desktopwidth:i:1024
    desktopheight:i:768

    winposstr:s:0,1,50,50,1104,848 

    (what works for me is to add 30 plus whatever amount i choose to move the screen.  So, 1024 + 30 + 50 and 768 + 30 + 50)

    You may be able to home in on this a bit more through testing.


    PS - All that testing was done with win2k8 and Vista.  When I test with Win7 connecting to a Win2k8 R2 server, I have to offset by 40, not 30, like this:

    desktopwidth:i:800
    desktopheight:i:600
    winposstr:s:0,1,100,100,940,740


    You will have to test to see what works for you. 







    Hope this helps,

    Kristin L. Griffin

    Co-Author of the Windows Server 2008 Terminal Services Resource Kit (and a SUPER BIG fan of the Microsoft RDV Team!!!)
    Monday, September 14, 2009 3:25 PM
    Moderator
  • Thanks both for your help.  I disabled the Aero Snap as a work around.  And I won't miss Snap at all.  Kristin, I will try what you suggest and get back.  It will be a few days before I can but I won't forget.

    Regards,

    Dale
    Tuesday, September 15, 2009 1:43 AM
  • Disabling Aero Snap worked for me. That has been my only major frustration since moving to Windows 7. I now have to send out an email to the entire office staff on how to fix this issue.

    To Microsoft, if you see this, please change this "functionality". I can't imaging anyone desires to have their RDP windows resize every time they move them.
    Thursday, October 1, 2009 7:50 PM
  • Disabling Aero Snap worked for me. That has been my only major frustration since moving to Windows 7. I now have to send out an email to the entire office staff on how to fix this issue.

    To Microsoft, if you see this, please change this "functionality". I can't imaging anyone desires to have their RDP windows resize every time they move them.
    Hopefully that fix would be to simply 'remember" the window location of RDP windows on a per-remote-computer basis.  Seems like an easy fix; perhaps it just never came up.   I know that the not-remembering was always a frustration to me but never so significant of one that I bothered to tell anyone.

    Dale
    Saturday, October 3, 2009 2:29 AM
  • I too have had the high frustration level of the RDP client being snapped but to hear the diabling of aero snap will fix it is more frustrating - I like the Aero snap.

    Is there another solution that would not involve editing all the RDP files?

    I add to Dale's plea for the RDP team to update teh client to remember some stuff and allow up to take a maximized RDP window that is not as large as our main screen and move it without un-maximizing it.

     

    Thanks all - Chris

    Friday, May 28, 2010 11:45 AM
  • I too have had the high frustration level of the RDP client being snapped but to hear the diabling of aero snap will fix it is more frustrating - I like the Aero snap.

    Is there another solution that would not involve editing all the RDP files?

    I add to Dale's plea for the RDP team to update teh client to remember some stuff and allow up to take a maximized RDP window that is not as large as our main screen and move it without un-maximizing it.

     

    Thanks all - Chris


    I agree completely. I use multiple RDP sessions at a time, rapid fire logons are much more cumbersome now that I have to move each window and resize them...and then do the whole thing over again the next time I need to logon to the same servers. Very annoying.
    Wednesday, June 2, 2010 12:55 PM
  • I found an interesting solution that seems to work.

    Right click on the RDP and choose Edit.  Go to the Display tab and check the back that says "Use all my monitors for the remote session" then press connect.

    Size the window to the position that you want and then discconect the remote session.  The Edit window of the RDP will still be up, go to the General tab, click Save and then close the Edit window.

    Open your RDP session again and it should open where you last position it.  This has worked for me on all my RDP connections (I have 9 that I use regularly) and I have used this method to get all of them to open on my second monitor.

    Hope this helps, and I hope Microsoft will put our a fix for this, no reason for it not to work just like XP did.

    Thanks,

    Matt

    Thursday, July 22, 2010 1:03 PM
  • found an even better fix....

    It still involves editing the RDP files but at least you get pre-win7 functionality

    you dont need to disable Aero-snap, nor do you need to resize the windows every time

    While its a crude fix, i found it amazing and WAY WAY WAY better than the crap weve had to put up with.

    Here it is:

    winposstr:s:0,1,200,200,5000,5000

    0 (maximized), 1 ( have no idea), 200 (200 pixels down from top), 200(200 pixels from left, or the other way around), 5000 (max window size), 5000 (max window size)

    And voila no scroll bars, no matter how big the windows are, windows are SORTA centered, no need to scroll or get scroll bars, and window is fully sized and draggable without removing aerosnap.

    While it isnt a perfect fix (open centered and window position saved) its the next best thing, i hope its usefull for someone.

    Friday, February 4, 2011 10:33 AM
  • Well, it is especially irritating that after Service Pack 1 for Windows 7, the issue still occurs. Microsoft, please, please resolve some of these lingering issues.
    Tuesday, March 8, 2011 8:12 PM
  • Please fix this MS! It's such an easy fix and there's such a difficult change/approval process over there.

     


    MCTS 70-620 Certified
    Wednesday, March 9, 2011 2:04 AM
  • Right click on the RDP and choose Edit.  Go to the Display tab and check the back that says "Use all my monitors for the remote session" then press connect.

    Size the window to the position that you want and then discconect the remote session.  The Edit window of the RDP will still be up, go to the General tab, click Save and then close the Edit window.

    Open your RDP session again and it should open where you last position it.  This has worked for me on all my RDP connections (I have 9 that I use regularly) and I have used this method to get all of them to open on my second monitor.

    This put me on the right track. I don't use separate RDP files--I just have the standard RDP shortcut pinned to the Win7 taskbar (uses C:\Users\<User>\Documents\default.rdp). This does require a multi-monitor setup. This worked for me:

    1. Open RDP, choose Options > Display, check "Use all my monitors for the remote session" then press Connect.

    2. You will be connected in full screen mode. Click the Restore button in the top bar; the screen will no longer be full screen. Disconnect. This closes Remote Desktop.

    3. Restart Remote Desktop. Uncheck "Use all my monitors for the remote session" and choose your desired screen size, e.g. 1024x768. Click Connect. The window should appear in the new size but not docked to the upper left corner.

    I'm not sure why this overrides the default "dock upper left" behavior. I just hope it lasts.

    Mark Berry
    MCB Systems

    Wednesday, April 13, 2011 8:31 PM