Exchange 2010 AD Prep, ExchangePre-deployment Anaylzer found Inheritance Block on Organizational Unit

    General discussion

  • I have an Specific OU where Inheritance is blocked (all of the of them are domain admin users) , we don't even configure this accounts with a mailbox.

    Would it be ok to go ahead and preapre the Schema for Exchange 2010 leaving the inheritance blocked for this specific OU ? some of this accounts include people like me that would be managing Exchange 2010, we have separate accounts as regular users that are mail enabled, and accounts to manage things in the domain that don't need to be mail enabled.

    Thanks a lot.



    Friday, February 25, 2011 3:49 AM

All replies

  • My suggestion is to temporarily remove the inheritance block and then proceed with /ADprep. After finishing the transition to Exchange 2010 you can insert the inheritance block again.

    Jesper Bernle | Blog: http://xchangeserver.wordpress.com
    Friday, February 25, 2011 9:30 AM
  • thanks Jesper, i missed this post yesterday night :(

    I ran the Setup /pl and Setup /PrepareAD /OganizationName yesterday night without removing the inherintace to this OU. I thought it's not going to pose a problem as long as i don't see inheritance blocked at the Exchange server object level.

    Setup completed without errors, so hopefully this won't be a problem in 2 weeks when i'll introduce the first Exchange 2010 into our Exchange 2003 Environment.

    Is there something i can check in the AD attributes to guarantee this step won't be a problem later on ?

    Friday, February 25, 2011 8:05 PM
  • I have confirmed with ADSIedit that the objectversion for the Exchange services configuration/organization name container is now 13214, it was 6903 (Exchange 2003) before the changes. I do have the new Microsoft Exchange Security group OU along with all the new managment roles inside in AD as well.
    Friday, February 25, 2011 8:09 PM
  • Verified

    Exchange 2010 SP1

    Value of rangeUpper attribute of ms-Exch-Schema-Version-Pt object in Schema NC has changed to 14726

    objectVersion attribute of Organization container in Configuration NC has changed to 13214.

    objectVersion attribute on Microsoft Exchange System Objects container in Domain NC has changed to 13040.

    Friday, February 25, 2011 8:24 PM
  • Well, it looks ok so let's hope it is. I just wouldn't know what missing stuff to go looking for (based on blocked inheritance issues) so if I can I always try to go for the safer path ... if there is such a thing. ;-)
    Jesper Bernle | Blog: http://xchangeserver.wordpress.com
    Friday, February 25, 2011 9:31 PM
  • I hope it is as well, I'll sure update this post if i run into issues. Thanks again for you input, it's well appreciated.


    Friday, February 25, 2011 11:44 PM