none
Can't connect to RD Gateway server from Windows 10 1709? RRS feed

  • Question

  • I'm experiencing an issue where i can't connect through my newly installed Windows Server 2016 with RD Gateway.

    I'm just getting "Your Computer can't connect to the Remote Desktop Gateway server. Contact your network administrator for assistance."

    Older versions of Windows 10 doesnt have this issue...?

    Any help would be appreciated.

    Wednesday, November 1, 2017 12:35 PM

Answers

  • Hi Brian,

    Please try to add this entry below on Windows 10 1709 system to test:

    HKCU\ Software\ Microsoft\ Terminal Server Client\

    RDGClientTransport     REG_DWORD     0x00000001

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, November 2, 2017 2:55 AM
    Moderator

All replies

  • Hi Brian,

    Please try to add this entry below on Windows 10 1709 system to test:

    HKCU\ Software\ Microsoft\ Terminal Server Client\

    RDGClientTransport     REG_DWORD     0x00000001

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, November 2, 2017 2:55 AM
    Moderator
  • Right, that fixed the issue. 

    Any info on what this registry key does exactly, -and maybe why its only som machines experiencing it?

    I had this on my work with Windows 10 Enterprise, but not at home on Windows 10 Pro...

    Friday, November 3, 2017 3:40 PM
  • Hi,

    The registry changes RD Gateway transport from modern HTTP to legacy RPC-HTTP as it's the most stable one.

    What’s new in Windows Server 2012 Remote Desktop Gateway

    https://cloudblogs.microsoft.com/enterprisemobility/2013/03/14/whats-new-in-windows-server-2012-remote-desktop-gateway/

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, November 7, 2017 10:31 AM
    Moderator
  • Thank you very much. Issue solved. 

    ravindraraju

    Tuesday, September 4, 2018 7:06 AM
  • I have the same issue but I have RDS setup to bypass the Gateway.

    This works for for my internal users but not some of my VPN users.

    From the VPN network, I can telnet to 3389 on both the connection broker and my host servers from the client.

    As soon as I launch a remoteapp I get the 'Your computer can't connect to the remote desktop gateway server. Contact your network administrator for assistance"

    This reg key does fix it but I don't want VPN users routing through my RD Gateway. From my understanding, It will try the connection broker first, If it fails, it then falls back to the RD Gateway.


    Tuesday, July 16, 2019 1:44 PM
  • So thankful this was the solution, modified reg and didn't have to reboot, it worked.

    Now, WHY IN THE NAME OF PETE did I have to loose 6 hours of time at home with my family to solve this RDP riddle?

    Hesus Christie,  riding on a unicycle through downtown San Francisco, why, why, why Microsoft have to tamper with "Modern" HTTP...  Really.... What so "Modern" that it don't work?  Just like your "Modern" apps, and your "Modern" Windows 8.0 interface, now mess with HTTP and break it too trying to make it "Modern"  Would you please just leave well enough alone before you break the whole Internet?  And the sooner the CHROME Edge Explorer the better.  Guess Edge not so "Modern" either.  6 hours of my life....gone over this.  Miller Time.

    Tuesday, December 31, 2019 6:13 AM