none
Distorted cell display in Excel 2010 – scroll away & back fixes it?

    Question

  • I have seen this problem on more than one of my clients computers.  The problem is the display of an Excel cell is wrong/distorted.  Scrolling so that cell is off-screen (out of site) and scrolling back to it fixes it.

     

    I’ve seen this in two situations:  when a user performs a paste operation, cells (or even whole rows) appear distorted with the formatting totally off (for example, it adds a bunch of extra space under the row or something).  I know the user was using the right Paste option, and scrolling away from the row/cell and scrolling back to it fixes it.

     

    The second situation I’ve seen this is when a user enters information into Excel cells and the text wraps around in a cell.  The rows below where the user is entering information distorts visually.  Again, scrolling away from the row/cell and scrolling back to it fixes it.

     

    Any idea what is causing this, and if there is any way to fix it?  Again, functionality remains, just visually cells and/or rows get distorted & one fix for it is to take that cell/row out of site by scrolling away from it and scrolling back.

     

    Thanks,

    Elizabeth

    Tuesday, May 10, 2011 9:37 PM

All replies

  • Hi,

    Whe the user tries to paste, does he/she select some the text including some extra space?

    Best Regards,

    Sally Tang

    Monday, May 16, 2011 9:25 AM
  • The user highlights only the cells he wants to paste into. 

    The other scenario, the user is not using Paste at all - he is just entering text that happens to wrap around in the cell.

    Tuesday, May 17, 2011 5:16 PM
  • We encounter the same problem in our organisation.

    It happens when trying to edit a text wrap cell.

    It happens even in a new Excel 2010 file.

    You just need to create a new table where one of the cell is formatted as text wrap, go to the last row of the table and edit the long cell. Sometimes scrolling to another place in the sheet doesn't help, & you need to close & reopen the file, which is very annoying.

    It looks like a bug with the refresh.

    Monday, July 25, 2011 10:50 AM
  • Hi

    Just out of interest what happens when you press CTRL+ALT+SHIFT+F9, without scrolling to fix the screen?

    As this is a superior form of recalculation and you are refering mainly to text in cells the answer should be nothing.


    G North MCT
    Monday, July 25, 2011 11:55 AM
  • Are you already at SP1? There's an issue fixed:

    "Cells that have “center across selection” formatting options applied are not correctly redrawn after a calculation. This can create "redraw artifacts" or the appearance of a recalculation problem."

    It could be a problem related to the display driver as well. Check, if the compatibility option "Disable Desktop Composition" for the Excel shortcut solves anything.

    Monday, July 25, 2011 3:15 PM
  • Thanks for the responses. We checked the problem on a computer with SP1 but the problem wasn't solved. I tried now to check the compatibility option "Disable Desktop Composition" like Alexander suggested but it didn't help. I found another discussion about this problem: http://communities.intel.com/thread/20966 but we tried to bypass the intel Hd with an external screen & the problem still appeared (so it's not a hardware problem).
    Tuesday, July 26, 2011 7:39 AM
  • We have the same problem here at our company.  Our group uses frozen panes and text wrapping on virtually every spreadsheet.  This bug is very annoying, and has caused data corruption for users who don't know about the issue.  It is NOT the fault of the graphics driver, as it occurs with wildly different HW platforms:  Notebooks, basic integrated graphics desktops, Dell Precision workstations, etc.  All have the exact same issue.

    This is most definitely a bug.  This bug was not in Excel 2007 or earlier.  It is in 2010 only.

    Thursday, September 8, 2011 9:35 PM
  • I have had this problem also, and it does look initially like a display card driver issue.  But it's not.  I believe that what is happening is when you edit within a cell and text wrap occurs the entire spreadsheet needs to be refreshed on pressing Enter, but no display refresh occurs.  In order to force the screen refresh I usually click on a tab for another worksheet and then click back to the active worksheet.  But this is highly annoying to do for each cell entered.  If doing a lot of entry, one can enlarge every row to avoid expanding cells during data entry, then "right size" every row again when data entry is complete.

    Thursday, September 15, 2011 3:12 PM
  • Hi,

    I had a very similar issue with my Excel which I am now close to resolving.  It happened when I changed laptop and upgraded to Windows 7 but stuck with Excel 2003.  My display would distort so rows weren't in the right place and you couldn't even read it sometimes.  Some cells just blanked out as well and you could see the cell refs at the top and the left often moved slight down and across as well.  I upgraded to Excel 2010 but still the same issue.  I tried different screens, keyboards and a new mouse - still the same issue.  My step daughter was watching me work one day and see me switching screens without the mouse so I explained to her how ALT TAB works - she said maybe that's the problem.  I stopped using alt tab and the issue went away. It's been a week now and it only happens when I accidentally use alt tab.  Seriously, a 16 year old computer novice identified the problem!

    I then remembered back to when I upgraded and hated the aeropeek alt tab as it was hard to find the screen you want and would then switch to the wrong screen if you waited too long.  To resolve this I googled "classic alt tab" and found a way of going back to the old alt tab by changing the registry (my IT person is not happy with me!)  We have removed the entry I made in the registry and it looks as though the issue may now be resolved.  Having said that, it's morning and the issue was always worse in the afternoon so it may kick in then.  Regardless, at least I know what's causing the issue (alt tab) and so should now be able to find the solution.

    So, do you use alt tab to switch screens?  Have you made any changes to the registry?  If so, this might be why you are having the issue.

    Cheers

    Viv

     

    Friday, October 7, 2011 10:58 AM
  • I think I stumbled upon the solution.  Go to FILE - OPTIONS - GENERAL, uncheck "Enable Live Preview".   Mine was doing the screen distortion to the point it was maddening. It has not done it since I did this.
    • Proposed as answer by Gunslinger313 Sunday, November 6, 2011 7:49 PM
    Sunday, November 6, 2011 7:47 PM
  • I am having the same issue and have tried "Enable Live Preview" but it did not work for me.

    I also tried File|Options|Advanced - Disable Hardware Accelaration under Display to no avail.

    Is Microsoft aware of this problem and is there anything about it listed? 

    Thursday, November 10, 2011 4:11 PM
  • How come it is so rarely reported in the web? it is a very important bug! I use Alt+Enter - I ll check whether this causes the problem.

     

    Tuesday, November 15, 2011 5:39 PM
  • Am jumping on this thread as I have a client who is experiencing the same issues, am going to try to Disable Live Preview first and report back.

    Been running all sorts of tests on the PC to see if it was down to the PC itself, although its a fairly new Optiplex i7, 8GB RAM, Win 7 Pro x64.  All updated with the latest service packs.

    Will report back soon, thanks for the tips.

    Monday, December 12, 2011 3:53 PM
  • I think I stumbled upon the solution.  Go to FILE - OPTIONS - GENERAL, uncheck "Enable Live Preview".   Mine was doing the screen distortion to the point it was maddening. It has not done it since I did this.

    Unfortunately this didn't work for me. I still get the screen corruption for every cell that I edit in a table.

    Description of the file I'm editing:

    • Excel 2010 spreadsheet
    • Cells formatted as a table (from the Styles menu)
    • Cells in the table are word-wrapped
    • If I type a sentence or two into the cell and press enter, it produces the screen corruption/artifacting for the row I was editing and the one below
    • Scrolling past the row so it's no longer on screen, and then scrolling back, fixes the problem

     

     

    Monday, January 16, 2012 1:18 AM
  • I believe I may have found the answer to this problem involving Excel 2010 and having to scroll away & then back to fix the redraw.  Try this:

    1. Click File, then Options, then select the Advanced menu.
    2. Scroll down to the Display section, then put a check mark (click the box) in the box next to Disable hardware graphics acceleration.
    3. Click the OK button and try again. 

    This solved the problem for me! 

    Good luck!

    IKINAWANA

    • Proposed as answer by IKINAWANA Friday, March 2, 2012 10:23 PM
    Friday, March 2, 2012 10:22 PM
  • I believe I may have found the answer to this problem involving Excel 2010 and having to scroll away & then back to fix the redraw.  Try this:

    1. Click File, then Options, then select the Advanced menu.
    2. Scroll down to the Display section, then put a check mark (click the box) in the box next to Disable hardware graphics acceleration.
    3. Click the OK button and try again. 

    This solved the problem for me! 

    Good luck!

    IKINAWANA

    That worked perfectly for me.  Thank you, Ikinawana!!!!!
    Thursday, March 22, 2012 4:31 PM
  • So far so good with diabling hardware graphics acceleration for me.  I'll report back soon if this is actually the 'fix' I've been searching for.

    THANKS!!!

    Friday, March 23, 2012 10:52 PM
  • This ended up not being the fix as Excel is still doing the same thing.  Anyone have any more ideas?
    Monday, March 26, 2012 3:35 PM
  • I had the same issue and was driving me nuts

    Today i tried something that i saw in another forum and it's working so far, the symptoms went away immediatelly

    If you have intellimouse / intellipoint drivers installed.. uninstall them.

    Fixed

    • Proposed as answer by Ampedrosa Friday, June 22, 2012 2:14 PM
    Friday, June 22, 2012 2:14 PM
  • I had similar problem with centered text being truncated when I scrolled the screen.  Based on this thread it led me to do the following:

    1) Select all cells included in the "Center across selection"

    2) Right Click and select [Format Cells]

    3) On [Alignment] Tab uncheck [Wrap Text]

    This is working for me.

    • Proposed as answer by TrixSil2 Tuesday, July 14, 2015 3:57 PM
    Tuesday, July 10, 2012 9:45 PM
  • I had the same issue and was driving me nuts

    Today i tried something that i saw in another forum and it's working so far, the symptoms went away immediatelly

    If you have intellimouse / intellipoint drivers installed.. uninstall them.

    Fixed

    I have experienced this problem with Office 2003 and Office 2010.  I skipped 2007.  My OS is Windows XP.

    The other solutions seemed reasonable and I tried them, but they all failed.

    I never would have suspected Microsoft Intellipoint to be the culprit, but it certainly seems that way.  While I did not uninstall the software/drivers, I did use Task Manager to terminate the process ipoint.exe (Ver. 6.1).  The relief was immediate!  I have now configured my computer to not load ipoint.exe upon startup.  I did not want to lose the other benefits of the Intellimouse software.

    Thank you for sharing.


    Roy Sprunger

    Monday, October 8, 2012 1:18 AM
  • Hello everyone,

    I came across the same problem only in Excel 2010 with Windows 7.

    Solution:

    Switch your desktop color scheme to "windows 7 Basic"

    or

    Use compatibility mode and "disable visual themes" and disable "desktop composition" in the Excel 2010 shortcut or .exe.

    It’s under properties, you will get it right clicking on the program icon then choose compatibility tab.

    I don’t know what caused it, since it wasn’t doing this before…

    Hope I could help someone.

    Joao


    • Proposed as answer by Joao Pascoal Wednesday, December 12, 2012 11:40 PM
    • Edited by Joao Pascoal Wednesday, December 12, 2012 11:41 PM
    Wednesday, December 12, 2012 11:40 PM
  • To me, the bug was related to the hide columns option. If you hid the non-used columns at right side of your spreadsheet, try to unhide them. With luck, if your bug is similar to what happened to me, it will be solved.
    Wednesday, April 10, 2013 6:41 PM
  • Yes, I have had this problem too.  It seems to me that the problem was tied to the Page Layout View.  As long as I kept the sheet in the Normal View, I had no problems.  Check which view mode the sheet is in.  Also, I'll bet others will also have problems in the Page Layout View but just don't use it as often.
    Wednesday, June 26, 2013 3:47 PM
  • Yes changing the view to "Normal View" works for me.  Once I change the view back to "Page Layout", it is all messed up again.  This is unfortunate because I prefer "Page Layout" the best.  I hope Microsoft gets a fix for this issue.

    JCO

    Saturday, July 27, 2013 5:21 PM
  • I had the same error and fixed it by disabling desktop composition as suggested by another poster. However I was unsatisfied with this fix and found that by updating my graphics driver excel now functions properly. I use a nvidia GTX 550 Ti graphics card.
    Sunday, July 28, 2013 2:17 PM
  • Your recommendation has worked every time I've run into this....every time, that is, before today.  Today it isn't working at all.  The worst part isn't tha tI have to recreate the check boxes, it's that many of the boxes were checked and I can't tell which ones were checked and which were not, so I have to start all over again.  Wah wah wah wah wah.
    Tuesday, November 12, 2013 9:02 PM
  • Try changing the view to "Normal" instead of "Page Layout".  This has been an ongoing issue on all versions going back to Office 2002.   I, as most folks, like the Page Layout view the best but that is when the problem occurs.

    Thanks


    JCO

    Tuesday, November 12, 2013 9:33 PM
  • < <Make sure you have no frozen rows. >>

    I also had this issue. It looks like it may be a number of separate bugs.

    The various fixes suggested (disable hardware acceleration, live preview) didn't work for me.

    I can cause it to occur in Excel 2010 when I filter and then unfilter rows including a "frozen" row (such as row 1).

    Unfreezing the row caused the screen te be redrawn properly again, in my case.

    Thursday, January 9, 2014 4:48 AM
  • Thank you! Everything else did not work. Killing ipoint provided immediate relief.

    But, I was only able to kill the process and I just removed it from the startup list.

    I didn't find it listed in the programs list so I can "uninstall it".

    Tuesday, April 29, 2014 4:53 PM
  • It's been an ongoing issue for many years and something that (apparently) Microsoft has no concern in fixing. The best way to avoid it is to change the view from Page Layout to Normal.  I hate the work around because I like looking at everything in Page Layout much better.

    At any rate, that is the best solution that I have found.  Many people have suggested other solutions but none have worked for me except what I have already explained.

    Thanks


    JCO

    Tuesday, April 29, 2014 7:29 PM
  • Fixed a very annoying problem. Don't know how you found that Key Combo, but it's a keeper.


    Thursday, May 22, 2014 7:45 PM
  • My issue is the same, and I have tried everything listed here, all to no avail.  It happened when I switched from 
    Windows 7 to Windows 8.  If I have two larger files open, portions of one of them remains on the screen when I switch to the other.  It is fixed by scrolling out of view or selecting another tab and returning, but what a pain.  I have 16 GB of AM, so I doubt if that is an issue.  Never a problem when just one file is open.
    Thursday, October 16, 2014 9:46 PM
  • Yep... this seems to have stopped it for me, too. This has been bugging me for years. I've generally been just using one excel workbook at a time.
    Friday, October 17, 2014 10:27 PM
  • I had this problem but mine was from expanding the Formula Bar so that I could see the large amount of data that was in the cell and see the results after I ran a macro on it. But before I reset it I my monitor form landscape rotated to Portrait rotated back.

    So, when I restarted my computer the Formula Bar was so large that I couldn't reach or see that the Formula Bar was so large.  

    I remembered that I rotated the monitor. So i put it back and and wow, I could see that the Formula bar was open very big.  That was what was wrong with mine in the end.

    Friday, March 20, 2015 6:25 PM
  • This worked perfectly for me.
    Tuesday, July 14, 2015 3:57 PM
  • This stupid problem has driven me nuts for the last several years !!!

    I think I have a fix for some of you to try, please respond if it works for you.

    Go to Page Layout - Margins - Custom Margins.  UNCHECK center on page Vertically

    Now try and see if the problem is gone.

    BMR

    Tuesday, July 28, 2015 6:39 PM
  • I simply would not have believed it, but killing ipoint also solved the problem for me.  I've been fighting the tearing issue for three years and was ready to tear my hair out.  I use large spreadsheets and it was perhaps the most annoying problem I've ever run into, computer-wise.  I hope it works well for others.

    Bruce

     
    Thursday, July 30, 2015 7:53 PM
  • I've tried everyone else's solutions but to no avail...Changing to Normal View worked for me...Thank You!

    Tuesday, February 2, 2016 9:43 PM
  • Hi Roy

    Thank you!  This worked for me.  This was driving me crazy, but thank you for the solution.

    Dawn

    Saturday, February 20, 2016 3:34 PM
  • I sorted my problem out by creating a New Windows Admin User. When I logged in using that New User credentials and worked on the same spreadsheet it was working as per factory settings. Hard to believe it but this method can also work.
    Wednesday, August 3, 2016 12:47 PM
  • I have Excel 2007 and face the same situation. Cells distorted, even the frozen rows appear white when I open some files. After I scroll out and back it fixes the visual distortion but after a few edits it reappears. It happened after windows 10 32bits upgraded automatically to Windows 10 anniversary update.

    UPDATE:

    I have just restored windows 10 to before anniversary update (which happened last week - 22.09.2016) and now i got everything back. My office 2007 does not display inccorectly but instead opens files with some sort of LAG... about 7-8 seconds. Maybe reinstalling it will correct the problem. I will return with a feedback on it.

    • Edited by IoanBV Monday, September 26, 2016 12:01 PM
    Monday, September 26, 2016 11:16 AM
  • Thank you Gunslinger, I just solved it the way you did it!...
    Tuesday, October 4, 2016 6:18 PM
  • Elizabeth,

    I'm now using Excel 2016 and have not noticed this issue (yet), however, I've seen it happen for many years now.  while nobody seems to know what causes it, the only real work around that works is to change the view from Page Layout to Normal View.  It does not seem to occur in Normal View.  This is not the best work-a-round because I like using the Page Layout View the best, but it is all I can offer.  I hope this helps those that have not found any other solutions. 

    Thanks


    JCO

    Wednesday, October 5, 2016 7:33 PM
  • Hello all.  I have been struggling with this for days, but thanks be to God!, I think I found the issue (after some prayer) and it is a MS bug. 

    When in excel, if I was to Merge Cells or Unmerge Cells, the screen would go totally distorted with ghost images.  I had to scroll down and up to clean it up as all have pointed out.  I tried EVERYTHING posted here and no help. 

    Then I found another MS forum page that advised to select a different printer in the File-Print menu, and magically, this seemed to make the problem go away instantly. They advised to update printer drivers.  BUT, after I updated all printer drivers, the issue continued.

    I noticed when I opened excel, if I changed the printer selection at least one time, the problem was gone for that entire session, until I closed excel, and would need to do it again. THEN Finally, I noticed I did not have a printer selected as DEFAULT.  The new version of Windows 10 anniversary edition is trying something new. They want to auto-manage printers and have none selected as default. So go to your Start, Settings, Devices, Printers, and select one of them as DEFAULT, then the problems in excel are gone. Amazing.

    You will see a message from Windows 10 when selecting your printer as default that says, "If you pick the printer as default, Windows will no longer manage your printers." or something like that.  HIT OK!

    Update: There is actually a setting button for this setting. 

    "LET WINDOWS MANAGE MY DEFAULT PRINTER"  Turn this feature off!!


    • Proposed as answer by pjwaszko5 Friday, October 21, 2016 1:41 PM
    • Edited by pjwaszko5 Friday, October 21, 2016 1:58 PM
    Friday, October 21, 2016 1:40 PM
  • Thank you SO much for posting this fix!  I have tried every singe thing in this thread to no avail, but it was worth all the trouble to get to the last post from you.  I turned off  "Let windows manage my default printer", and this IMMEDIATELY worked.  I have trouble everyday in ever spreadsheet I am in, and now it's fixed!  YAY 
    Wednesday, October 26, 2016 1:41 PM
  • Yay thank you so much. Had this problem for ages now.  Nothing else worked.
    Thursday, November 3, 2016 1:33 AM
  • thank you pjwaszko5, your post on Friday October 21 worked for me! 
    Friday, November 11, 2016 10:17 PM
  • 5 years later I'm having the problem with merge and center, every time I try to use it most of the page turns black.  I tried this solution and now everything works...I did have to save, close and reopen after changing the setting.  Thanks SO MUCH.
    Monday, November 14, 2016 7:54 PM
  • You are a legend!
    Wednesday, November 16, 2016 4:59 AM
  • Thank you pjwaszko5!!!

    You are a Gawd!

    Wednesday, December 7, 2016 3:53 PM
  • No, I am a sinner.  Only God is a God.  But I am very glad to share this solution with others.  As He has shared much with me.  See Acts 12:21-24.
    • Edited by pjwaszko5 Saturday, December 31, 2016 8:14 PM
    Saturday, December 31, 2016 8:12 PM
  • A different solution that worked for me:

    Right click on the offending sheet tab and make a copy. Then delete the original.

    Thursday, January 5, 2017 11:53 AM
  • thank you pjwaszko5.

    Been struggling with this for over a year....... THANK YOU!

    Thursday, January 19, 2017 4:44 PM
  • Yep - this works - after many months of absolute frustration - you have got my vote......!!! Thank you so very much!!
    Friday, February 10, 2017 11:20 AM
  • Terrific !!! Im on Windows 10  Latest updates. I use Office 2016, Latest updates too.

    AND YESS !! After being freed almost 2 years. There it is again !!!!

    Every manipulation to the contents of a cell gets accompanied by a random border. Scrolling the focus area ofscreen and back onscreen, all seems normal again, as long as you don't change a thing.

    Tried all the tips above, user has a default printer, no Ipoint.exe, loads of memory, temp files stored locally, no preview etc... The complete works.

    I think it has to do with the way Excel cleans up the screen memory after a change. It only occurs in some specific situations, but it doesn't correct itself. That would mean it's a flaw in the basic design of the display handling that Excel uses and that would explain why MS doesn't volunteer to go fix it.

    Guess we have to learn to live with it :\

    Wednesday, September 27, 2017 11:05 AM
  • Same here... Any other forums covering this?
    Friday, September 29, 2017 12:01 AM
  • This worked for me.

    https://social.technet.microsoft.com/Forums/office/en-US/bf15f45d-ebde-47a8-b39b-3e98c3c21470/random-borders-appearing-in-excel-2016?forum=excel

    https://support.microsoft.com/en-us/help/4011165/september-12-2017-update-for-excel-2016-kb4011165

    • Edited by DrDoctor903 Tuesday, October 31, 2017 5:40 PM
    Tuesday, October 31, 2017 5:40 PM
  • didn't work initially, but restarted Excel after Disabling hardware graphics acceleration and it was fixed in Excel2016. Thanks!
    • Edited by DVesalT Friday, December 22, 2017 7:08 PM
    Friday, December 22, 2017 7:07 PM
  • A different solution that worked for me:

    Right click on the offending sheet tab and make a copy. Then delete the original.


    This fixed it for me!!! Thank you @smackeroo
    Monday, August 6, 2018 4:16 AM