none
Publishing a form is really slow RRS feed

  • Question

  • I hav ecreated an InfoPath form and published it. Suddenly it takes around 40 minutes to Quick Publish a form. Same thing with opening a form or saving one after updating it.

    The first couple of times when I published the forms it didn't take any longer time than expected, but suddenly everything went slow. I haven't changed anything important in the form, exept changing some names in the textboxes. I had the same problem with another form a week ago: first everything was fine, but suddenly it took over half an hour to publish.

    I don't think anything has been changed on the server (proxy, firewalls etc).

    Any ideas?

    I am really new to InfoPath...

    Tuesday, November 22, 2011 7:53 AM

All replies

  • Another thing, when I click on Cancel when opening a new form, the form opens. Using the Cancel option is only possible when I add a new form, otherwise it renders an error.

     

    The form itself only contains a couple of text boxes, dropdown lists and date pickers. There are a couple of different views created. No data is retrieved from any other source. There are no rules except the standard Sbumit rule, no other logics are added.

    I used the publishing wizard to publish the form to a SharePoint library, and then quick publish. There is only one data connection for submitting the data to the SharePoint library (created with the data connections wizard).

    All in all, I can't see anything strange. It is a simple form with nothing "extra". The most advance thing in it is that some of the dropdown lists in the default view is set to read-only text boxes in the second view.

    Thanks in advance for any ideas regarding this!

    • Edited by Jenny Fergeus Tuesday, November 22, 2011 8:29 AM adding information
    Tuesday, November 22, 2011 7:59 AM
  • After I have removed the data connection and reset the Publish settings, the loading time went down to around 45 seconds. Great (or at least a huge improvment), but now I have updated the form a couple of times in InfoPath and every time the form takes longer and longer to load. Right now it takes almost 20 minutes to publish (using the quick publish). The most advanced thing I have done is to add a couple of rules (like update a fields value when submitting the form). Nothing is done through coding, I just use the standard functionality.
    Thursday, November 24, 2011 9:05 PM
  • Did you get the reason for slow publish ?
    Thursday, June 27, 2019 3:40 PM