Excel 2013 - Export CSV with comma delimiter


  • Hi

    How do you export a comma delimited file in Excel 2013 & Windows 8 using the "Save As"
    You would think that CSV (since its name says its comma separated values) would use a comma, but no, it uses semi-colons.
    I have tried changing the "list separator" value in my region settings to "," from ";" as suggested on some other forums but this does not help. Its still exports a COMMA separated file with a semi-colon separator. Ridiculous.
    I do not want to change my entire region to US, as that changes date & number formats, and that's not acceptable.



    Thursday, June 20, 2013 1:07 PM

All replies

  • Hi,

    Since you have set the "list separator" in control panel, then try to check whether you have checked the option "Use system separators" in File -> Options -> Advanced.

    Jaynet Zhang
    TechNet Community Support

    Friday, June 21, 2013 3:43 AM
  • Hi

    Thanks for the reply.
    The "use system separators" is ticked, but it still uses semi-colons.
    Just to see, I unticked it and tried, but still semi-colons.

    Any other ideas?


    Friday, June 21, 2013 6:44 AM
  • I have faced exactly the same problem and found not a solution, but rather a workaround. As my regional decimal separator is not a dot, but a comma, thus I had to uncheck "Use system separators" and manually change decimal separator from comma to dot in Excel > File > Options > Advanced. It looks like the list separator in Regional settings must be different from decimal separator. It's logical, but very frustrating to keep in mind every time I export CSV files from Excel. Microsoft could be much more flexible by implementing options to choose which CSV delimiter to use in Save As file type CSV dialog. As alternative I also use OpenOffice Calc to manage my CSV files. It's much more easier.

    I hope it will help!



    Saturday, January 10, 2015 10:13 AM
  • The thing is, the csv separator is NOT a nummerical separator. So it has nothing to do with the regional settigs !!

    It is the field separator in a text based file. Excel exports with a delimiter that is a semicolon. Outlook, for example, imports only when it's a comma !

    It is the way Excel exports to a CSV format.

    I have searched all options in excel, but can't seem to find a way to change the separator.

    For now i change the semicolon into a comma in notepad pretty pathetic..... :(

    • Edited by Ger Voeten Thursday, January 22, 2015 11:30 AM
    Thursday, January 22, 2015 11:22 AM
  • Hi

    I tried few of the suggested workarounds, but did not get it to work. Tried Google sheets and it worked first time :/


    Thursday, August 20, 2015 9:20 AM
  • Hi

    Since I posted the original post, some update fixed the issue. Changing the list separator as below works for me now. You must use the "control panel" and not the "region settings" windows 8 app. I didn't have to change anything in Excel.

    Choose "Click,Language And Region", then "Change date, time or number formats"

    In the dialog that opens, click "Additional Settings" and change the "List separator" to a comma

    • Proposed as answer by ZaJacksonS Thursday, October 08, 2015 6:56 AM
    Thursday, August 20, 2015 9:32 AM
  • Thanks a lot! This worked for me.
    I was sharing your frustration :)

    • Edited by ZaJacksonS Thursday, October 08, 2015 7:00 AM
    Thursday, October 08, 2015 6:57 AM