none
Can't edit Sharepoint 2013 site page.

    Question

  • I'm running into an issue in Sharepoint 2013 where I can't edit a page on a sub-site, that it appears I should have permissions to, and I'm the sole administrator. I click on 'Edit Page', and most of the options are greyed out. What's interesting is that I can still edit all of the Lists, Libraries and Wikis within the page, just not the main page layout. 

    This isn't the case on any of the other Sharepoint sub sites, or the top level site. The permissions are inherited, which means that it should work.

    Is there a way to reset the permissions, like a propagation downwards in Windows?

    Monday, April 1, 2013 10:32 PM

All replies

  • Hi Tim,

    You need to first checkout the page then try "Edit Page"

    Navigate to

    Site Settings -> Site Content -> Site Pages -> Click on "..." next to page name -> Click on "..." -> Check out

    Help image link: Image Here

    Now when you "Edit page" it will work. Once done with editing make sure to check in the page.

    Thanks,

    Mayank

    • Proposed as answer by Mayank Chavan Tuesday, April 2, 2013 6:21 AM
    Tuesday, April 2, 2013 6:21 AM
  • Hi Mayank,

    That wasn't the answer, but it led me to the solution :) What happened was that I had edited the site properties, and messed something up. While looking through every menu option, I clicked 'Add a Page', it fixed whatever had broken, and now is back to normal. Strange!
    Wednesday, April 3, 2013 4:05 PM
  • Hey Tim,

    i experienced the same problems.

    I tried a lot of different approaches and found a solution which worked for me:

    I am using an Alternate Access (for example: sp.blabla.com directs to serversp-bla)

    When I tried to edit it on the sp.blabla.com-adress it always threw me out of editting mode. 

    But when I tried doing it on the "real" adress (serversp-bla) I had no problem editing the page and adding or deleting web parts, add parts, etc.

    I hope you can follow my line of thought and hope this will help you.

    Greets, PoetmitKnall aka. Francesco.

    Thursday, January 23, 2014 3:30 PM
  • This did not work
    Monday, February 24, 2014 7:03 PM
  • Hi Tim,

    You need to first checkout the page then try "Edit Page"

    Navigate to

    Site Settings -> Site Content -> Site Pages -> Click on "..." next to page name -> Click on "..." -> Check out

    Help image link: Image Here

    Now when you "Edit page" it will work. Once done with editing make sure to check in the page.

    Thanks,

    Mayank

    Checking the page out, then clicking edit worked for me :-)  Thanks!
    Thursday, March 20, 2014 8:17 AM
  • I am in edit mode with the page checked-out and am I Site Collection Admin. The page layout refuses to be allowed to be changed. 
    Wednesday, May 20, 2015 5:10 AM
  • Did you ever solve the issue? I am in the same trouble right now.
    Wednesday, July 15, 2015 5:10 PM
  • I have found some limited success by using the full domain name of the server in the URL. For some reason, the aliased name doesn't give me the same abilities. Something to do with the server admin / installation not being quite right. Maybe this helps you perhaps. Good luck.
    Monday, July 27, 2015 1:54 PM
  • I'm still having trouble with this as well.  Anyone?

    I am now the site designer so I can get in, but others on my team are unable to edit page.  It's not checked out to anyone either. 

    We also discovered that sometimes they can get in and other times they cannot.

    Friday, October 9, 2015 9:04 PM
  • I have the same problem and the "workarounds" couldn't fix it here.

    Has anyone an idea?

    Wednesday, July 6, 2016 1:01 PM
  • I am also having the same issue, but it seems to be only the Project Template that is the problem.  When I create a project template (and I have done this with on-prem and O365) the site contents do not include a site pages doc library app.  So no site page app means no checkout (nothing to check out) and no edit properties.

    So my question is, where is this page coming from if not from the site page doc lib? and how do I edit it?

    Thursday, July 7, 2016 2:31 PM
  • I resolved the same problem by opening the page in "maintenance mode" (edit properties/Link to Open in maintenance mode). There was a script inside that wasn't supposed to be there. I deleted it and then everything was OK again.
    Wednesday, September 14, 2016 10:04 AM
  • I was hoping this would fix it (Maintenance Mode) ... no go. :(
    Thursday, September 22, 2016 4:36 PM
  • This incident occurred to me, when I made some edits to the custom master page we had applied. Restoring to a previous version solved the issue.  I made my edits again but the problem did not appear. So, I am clueless as to what exactly caused the issue but atleast I now know what could be a probably cause.

    shreyas ganta

    Thursday, October 20, 2016 4:32 PM
  • I have the same issue.  I am not able to use the edit page option from the Site cog wheel, however when I use the Edit button next to the Share / Follow options (page checked out), then I am able to edit page content.   Otherwise I can only edit apps. 

    MS support wouldn't support me as I have a customer master page.  I'm checking through the page now for any errors, but would love an answer for this. 


    Thursday, November 24, 2016 3:52 PM
  • If you are unable to open a SP page in Edit Mode(Edit option do not work) in SharePoint 2013. Mostly it happened due to JavaScript error. Reason could be many. This time we thought that we should delete the page and recreate this but do not do this immediately without doing research.  

    One example/scenario of above problem is below:

    i) Suppose you did any JavaScript change recently in Script Editor and in Content Editor WebPart.  

    Solution: 

    1) Open the page in SharePoint Designer to Edit. SP Designer will open it in Browser and you could edit there to fix the problem. you could revert you recent changes to change 

    2) Open the page in SharePoint Designer to Edit. SP Designer will open it in Browser and you could revert your latest changes to get the previous correct state of page.

    3) Go to Site contents on same SharePoint page. You will get this page by clicking on Settings wheel available on top right menu. On "Site Contents" Page click on "Pages" then you will get the listing of pages. Select your page and click on 3 dots(...), it opens a new small dialogue, here also you will get 3 dots(...), as you will click on these dots you will get a sub menu. In this Sub menu many options are there. So please choose Version History, It will opens Version History page to show all the versions of this page. Please select the last successful version and you will get Restore option by clicking the down arrow link(You will get once you hover mouse on that version title) next to title of Version.

    If it will not solve then also please comment/query.

    Thanks.

    Shekhar

    Friday, June 30, 2017 7:23 AM
  • Although old, thought I'd comment that I am facing same issue.  It has nothing to do with not checking out, etc.  Fact is, I can create and edit a new page, there is just this one page that ... one that I created a year ago ... that will not allow edit even though I can check it out, and can place the page in edit mode.  I am using an account that has permission to about everything in the enterprise from the page up through the domain, so I am guessing the issue is neither permissions nor my ability to know how to click the checkout button on this page that sits in a library that does not require checkout. 

    One solution is to simply re-create the page with web parts.  Trouble is that this happens periodically and would be nice to know the root cause.

    • Edited by DaveVickery Tuesday, August 8, 2017 2:26 PM
    Tuesday, August 8, 2017 2:24 PM
  • I had a similar option in SharePoint Online trying to edit a Blog site homepage. Enable the site feature "Site Pages", then you can edit the blog homepage. To verify its not permissions, use a site collection admin account to test.

    I blogged the solution here: https://eschrader.com/2018/02/28/sharepoint-online-blog-site-how-to-edit-the-homepage/

    • Proposed as answer by ESchrader Thursday, March 1, 2018 2:18 AM
    Thursday, March 1, 2018 2:18 AM
  • There will be some javascript embedded in the page, that's the reason you won't be able to edit the page.


    If its a wiki page, try it, should work fine. add the below text in front of the page url:

    ?WikiPageMode=Edit&WikiMergeTarget=true



    ex: ........./sites/ABC/SitePages/myPage.aspx?WikiPageMode=Edit&WikiMergeTarget=true


    • Edited by Arun Allagi Monday, March 19, 2018 10:10 AM
    • Proposed as answer by Arun Allagi Monday, March 19, 2018 10:10 AM
    Monday, March 19, 2018 10:08 AM
  • i have the same issue , can't edit home page

    2 days 'm looking for it , even caald with microsoft , couldn't helpme

    i'm desperate

    Saturday, March 24, 2018 1:06 PM
  • tekoko

    Did you find an answer to this mine has just stopped allowing me to edit

    Monday, April 16, 2018 11:04 AM
  • perhaps this can help :

    https://www.qdoscc.com/blog/sharepoint-o365-permissions-deny-add-and-customise-pages-issue

    In SharePoint online management shell (download if you don’t have it)

    Enter:

    Connect-SPOService 

    then

    Enter URL of admin site https://<yourdomain>-admin.sharepoint.com

    Then username and password

    Set-SPOSite -Identity https://<yourdomain>.sharepoint.com -DenyAddAndCustomizePages $false


    • Edited by tekoko10 Monday, April 16, 2018 12:10 PM
    • Proposed as answer by DenBro Friday, July 13, 2018 8:55 AM
    Monday, April 16, 2018 12:09 PM
  • That worked for me!  Thanks!
    Thursday, July 5, 2018 6:45 PM
  • perhaps this can help :

    https://www.qdoscc.com/blog/sharepoint-o365-permissions-deny-add-and-customise-pages-issue

    In SharePoint online management shell (download if you don’t have it)

    Enter:

    Connect-SPOService 

    then

    Enter URL of admin site https://<yourdomain>-admin.sharepoint.com

    Then username and password

    Set-SPOSite -Identity https://<yourdomain>.sharepoint.com -DenyAddAndCustomizePages $false



    This fixed my problem thanks
    Friday, July 13, 2018 8:55 AM