none
Can't populate SQl Server Store dropdown RRS feed

  • Question

  • I am starting to setup Lync 2013 in order to upgrade from Lync 2010.  I will use a Standard Edition Front-End (SEFE) server with Archiving, Monitoring, and Mediation co-located.  The SEFE is running in a Windows Server 2012 Standard VM which is hosted on a Server 2012 Datacenter machine.  The Lync 2010 servers are hosted in Windows 2008 R2 VMs on the same physical machine.

    The problem that I am having is that I cannot get an entry into the SQL Server Store dropdown for neither the Archiving nor the Monitoring store.  As shown in the image below, there are entries for SQL Server stores, but the dropdown list is empty.  If I attempt to add a new one and it is already shown in Topology Builder (TB) under the SQL Server Stores under Shared Components - I get an error.  If I create a new entry that is not in the list, it does not end up in the field, and it does not show in the Shared Components list.  If I try to add the same new item again, TB says it's already there.  Where are these entries stored in AD?

    Any advice will be greatly appreciated.

    Sunday, December 2, 2012 5:16 PM

Answers

  • Strictly speaking, non-FQDN server name is not supported. When you "create" a new SQL instance with merely the host name, Topology Builder just assumes it to be a completely new server with no services/stores on it, therefore you can use this new SQL instance to host any stores.

    Though this workaround exists, it is not a recommended solution. Topology Builder mandates that every single server must either host Lync 2010 or Lync 2013, but not both. If your server is already a Lync 2010 application server, then TB does not allow to host SQL stores on this server for a Lync 2013 pool. Of course you can workaround this limit by using host names, or even creating DNS CNAME aliases to make TB believe it is a different server, but as I said this is not recommended.

    Friday, December 7, 2012 2:55 AM

All replies

  • Hi,

    Please run the topology builder as administrator then download the topology to add the new sql server store again. I can add a new sql server store in the FE properties and it can work correctly for me.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Sean Xiao
    TechNet Community Support

    Monday, December 3, 2012 8:49 AM
    Moderator
  • Hi Sean.

    Thanks for the reply.

    I was logging-in to the Lync 2013 FE server as Domain\Administrator.  I even tried right-clicking the tile, and choosing "Run as Administrator".  I tried something different this morning that DID work.  Instead of specifying the server FQDN, as the Add SQL Server Store dialog requests, I entered only the server name and instance, as I would do in SSMS.  This didn't work: Lync-App.rmsanswers.local\Default.  This did work: Lync-App\Default.

    I got an error when first trying the Lync-App\Default parameter because the Domain\Administrator account did not have the rights to create databases on the SQL Server.  After granting the rights - the Lync Archiving and Monitoring databases were created.  The only comment in the log was that the SQL Server Agent wasn't running.  It has now been configured to start Automatically.

    Someone should investigate why SQL Server Stores listed under Shared Components do not populate the dropdown list for Archiving and Monitoring.

    • Edited by CJADuva Monday, December 3, 2012 12:47 PM
    Monday, December 3, 2012 12:46 PM
  • SQL instance won't show up in Archiving drop down under certain situations. Here are some I can think of:

    1. The SQL instance(or some other instance on the same FQDN) is used as a mirror or witness, and it will not show up for any principal store selection.

    2. The SQL instance is <SomeSE>\RTC, which TB assumes to be a SQL Server Express installation, while Archiving/Monitoring does not support Express.

    3. The SQL instance(or some other instance on the same FQDN) is already hosting stores for some Lync 2010 pools/servers.

    Probably one of these caused your issue?

    Wednesday, December 5, 2012 6:34 AM
  • Thanks for the reply Yuan.

    The SQL instance that I was trying to use is a SQL Server 2012 instance that does not have any involvement in the current Lync Server 2010 installation.  The server on which the SQL Server 2012 instance is running is an application server in the Lync 2010 topology.

    Wednesday, December 5, 2012 1:39 PM
  • Yeah that is probably the cause. Topology Builder won't allow you to mix up 2010 and 2013 servers/stores.
    Thursday, December 6, 2012 1:58 AM
  • Hi Yuan.

    I'm still not clear on what causes the problem.  I did not have to remove the server hosting SQL 2012 as an application server for Lync 2010.  I just had to feed Lync 2013 a Non-FQDN server name for the SQL Server.

    Thursday, December 6, 2012 11:29 PM
  • Strictly speaking, non-FQDN server name is not supported. When you "create" a new SQL instance with merely the host name, Topology Builder just assumes it to be a completely new server with no services/stores on it, therefore you can use this new SQL instance to host any stores.

    Though this workaround exists, it is not a recommended solution. Topology Builder mandates that every single server must either host Lync 2010 or Lync 2013, but not both. If your server is already a Lync 2010 application server, then TB does not allow to host SQL stores on this server for a Lync 2013 pool. Of course you can workaround this limit by using host names, or even creating DNS CNAME aliases to make TB believe it is a different server, but as I said this is not recommended.

    Friday, December 7, 2012 2:55 AM
  • It's the issue with Lync server 2013 TB, because running SQL server is supported on Lync 2010 Arc&monitoring server !  and I and others can't use it as SQL store.


    • Edited by k0syak Friday, May 31, 2013 9:50 AM
    • Proposed as answer by k0syak Friday, May 31, 2013 9:51 AM
    Friday, May 31, 2013 9:48 AM
  • up for new thoughts

    Saturday, July 27, 2013 7:42 AM