none
External lists has no view selector RRS feed

  • Question

  • Hi,

    i created two external list from two different external content types.

    One list will be rendered with the view selector and the SP13 list rendering (new checkboxe, new subcontext-menu), but the second list will be rendered like an SP10 list, with the old checkboxes, old context-menu and no view-selector above the list.

    Both have client-rendering activated.

    List 1:

    List 2:

    How do i get the second list to look like the first list ?

    Thursday, February 15, 2018 9:58 AM

All replies

  • Hi Thomas,

    To display the second list as the SP13 list rendering, I suggest you creating a new view and set it as default:

    1. Go to the list settings->create a new view under Views section.

    2. Select the relevant columns you want to display.

    3. Return to the external list and check if the view display correctly.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, February 16, 2018 6:32 AM
  • Unfortunately not working.

    The only difference that i think could also be relevant is, the problematic external list derives from a content type with a .NET-assembly-connection. The list with the SP13 rendering is from a content type with SQL-connection.

    Friday, February 16, 2018 7:26 AM