locked
Exchange 2007and IIS7 RRS feed

  • Question

  •  

    have Exchange 2007 up and running and its on a Server 2008 standard 64bit server. IIS is all of a sudden starting to throw me errors, but was working. The error im getting is the following:

     HTTP Error 500.0 - Internal Server Error

    Calling LoadLibraryEx on ISAPI filter "C:\Program Files\Microsoft\Exchange Server\ClientAccess\owa\auth\owaauth.dll" failed

     I attempted to do thge following: http://forums.iis.net/t/1149050.aspx

     That did not fix my problem. Here is what is in my application host:

    <isapiFilters>
                <filter name="ASP.Net_2.0.50727.0" path="%windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_filter.dll" enableCache="true" preCondition="bitness32" />
                <filter name="ASP.Net_2.0.50727-64" path="%windir%\Microsoft.NET\Framework64\v2.0.50727\aspnet_filter.dll" enableCache="true" preCondition="bitness64" />
         <filter name="Exchange OWA Cookie Authentication ISAPI Filter" path="C:\Program Files\Microsoft\Exchange Server\ClientAccess\owa\auth\owaauth.dll" enabled="true" preCondition="bitness64" />
                <filter name="Exchange ActiveSync ISAPI Filter" path="C:\Program Files\Microsoft\Exchange Server\ClientAccess\sync\bin\AirFilter.dll" enabled="true" preCondition="bitness64" />
            </isapiFilters>

    Can anyone help?

    Module IIS Web Core
    Notification Unknown
    Handler StaticFile
    Error Code 0x80070005

    Requested URL https://chexchange:443/
    Physical Path C:\inetpub\wwwroot
    Logon Method Not yet determined
    Logon User Not yet determined
     
     
     

    I was able to get this to display:

    <?xml version="1.0" encoding="utf-8" ?>

    - <Autodiscover>
    <!--
     This is a placeholder file 
      --> f(clean);
      </Autodiscover>
     
    Is that what i want to see?
    Monday, November 10, 2008 12:57 PM

All replies

  • Now i can't seem to login to OWA, where i was able to before.

     

     

    when i sign in i get this error.

     

    https://emailserver.domain.com/owa/auth/owaauth.dll

     

    "The custom error module does not recognize this error."

     

    Monday, November 10, 2008 12:59 PM
  • Hi,

    We need to check the setting on OWA virtual directory first. You can follow the steps below:

    1.    Please try to ensure that the "/owa" directory is running in the OWA Application pool by:
    1) Launch IIS Manager
    2) Expand the Server
    3) Expand Web Sites
    4) Expand Default Web Site
    5) Right-click the "owa" virtual directory and choose properties.
    6) On the Virtual Directory tab make sure that the "Application Pool" is set to
    MSExchangeOWAAppPool.

    2.    Ensure that the MSExchangeOWAAppPool is running as Local System.
    1) Launch IIS Manager
    2) Expand the Server
    3) Expand Application Pools
    4) Right click MSExchangeOWAAppPool and choose properties
    5) Click the Identity tab and ensure that the security account is set to Predefined:
    Local System

    If the IIS_IUSRS group does not have the appropriate permissions for the ApplicationHost.config file or for the Web.config file, it will cause the issue. Grant the Read permission to the IIS_IUSRS group for the ApplicationHost.config file or for the Web.config file. To do this, follow these steps:

    1)    In Windows Explorer, locate the ApplicationHost.config file that is associated with the Web site, or locate the Web.config file that is associated with the Web site.

    2)    Right-click the ApplicationHost.config file, or right-click the Web.config file.

    3)    Click Properties.

    4)    Click the Security tab, and then click Edit.

    5)    Click Add.

    6)    In the Enter the object names to select box, type computername\IIS_IUSRS, click Check Names, and then click OK.

    Note: Computername is a placeholder for the computer name.

    7)    Click to select the Read check box, and then click OK.

    8)    In the ApplicationHost.config Properties dialog box or in the Web.config Properties dialog box, click OK.

    Detail information you can refer to the article below:

    Error message when you visit a Web site that is hosted on IIS 7.0: "HTTP Error 500.19 – Internal Server Error"

    http://support.microsoft.com/kb/942055/en-us

    Also please check the article below, it may be helpful to you.

    894435 How to switch between the 32-bit versions of ASP.NET 1.1 and the 64-bit
    version of ASP.NET 2.0 on a 64-bit version of Windows
     
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;894435

    If all the step above do not help, then please check event log and post the error event information here.

    Hope it helps.

    Xiu

    Thursday, November 13, 2008 3:41 AM
  •  

    Step 1 - I can't click on properties.

    http://screencast.com/t/RU4qNDxqJb

    but if i go to advanced settings i get this:

    http://screencast.com/t/7bFJoVB7LB

     

     

    step 2 - it says localsystem but i can't click on properties

    http://screencast.com/t/HTFVhD0dj7L

     

    its a domain group, not a local user?

    IIS_IUSRS - applicationhost http://screencast.com/t/aXnBwFV2nr

    IIS_IUSRS - web http://screencast.com/t/1ShNHIqj

     

     

     

    Thursday, November 13, 2008 12:49 PM
  •  

    The HTTP Filter DLL C:\Program Files\Microsoft\Exchange Server\ClientAccess\owa\auth\owaauth.dll failed to load. The data is the error.

     

     

    Could not load all ISAPI filters for site 'DEFAULT WEB SITE'. Therefore site startup aborted.

     

     

    The HTTP Filter DLL C:\Program Files\Microsoft\Exchange Server\ClientAccess\owa\auth\owaauth.dll failed to load. The data is the error.

     

     

    Could not load all ISAPI filters for site 'DEFAULT WEB SITE'. Therefore site startup aborted.

     

     

    over and over and over Smile

    Thursday, November 13, 2008 3:37 PM
  • Hi,

     

     Please check the version of .net framework if it is v2.0.50727(64-bit)

     

    How to determine which versions of the .NET Framework are installed and whether service packs have been applied

     

    Please check ISAPI filters on Default Web Site and post here.
     
    Xiu
    Friday, November 14, 2008 3:17 AM
  • This is an old post, but it kept coming up in my searches for a similar problem with the ISAPI filter for ActiveSync: Airfilter.dll. This article ended up pointing me at the solution to my problem: http://blogs.msdn.com/b/david.wang/archive/2005/06/21/howto-diagnose-and-fix-common-isapi-filter-installation-failures.aspx

    My particular issue was due to the explicit permissions for Authenticated Users on the folder "%program files%\Microsoft\Exchange Server\ClientAccess\Sync\Bin" were not correctly set. This folder requires 'Authenticated Users' to have 'Traverse folder / execute' permissions on all subfolder and files. Then IIS was able to properly load the ISAPI filters for ActiveSync and OWA, and everything started working again.

    In the particular case of owaauth.dll failing to load, you need to do the same thing with the permissions of the folder '%Program Files%\Microsoft\Exchange Server\ClientAccess\Owa\auth'.

    I hope this helps someone, it certainly took a lot of my time to figure this out, and I was about to reinstall CAS to fix, but managed to avoid it in the end.


    • Proposed as answer by Hados Friday, December 7, 2012 7:53 PM
    • Edited by Hados Friday, December 7, 2012 8:00 PM
    Friday, December 7, 2012 7:53 PM