locked
Sudden problems with inserting ActiveX basic controls such as Command Buttons RRS feed

  • Question

  • Out of the blues the error "Impossible to insert the control" started occurring in my Excel everytime I try to insert a basic ActiveX control, such as Command Buttons and ListBoxes, in a Sheet. The application already has a Command Button, which I inserted and coded on before the error started occurring. No problem occurs if I open the VBA Editor and dubug the code of the application and even the code of events related to the Command Button. There is also no problem with inserting Command Buttons and such in UserForms. I cannot click the Command Button that already is in the Sheet, it won't show like clicked or trigger the events that it should. So, I need a solution that stops these errors and allows me back to insert basic ActiveX Controls in sheets. I think it may be some bug related to Libraries referencing or such.

    Can anyone please help me out with that?

    Jorge Barbi Martins

      
    Thursday, December 11, 2014 12:42 PM

Answers

  • Quit Excel.
    Start Windows Explorer.
    Select the system drive (usually C:).
    Use the Search box to search for *.exd
    Delete all found files.
     
    (Thanks to Excel MVP RoryA for this tip)

    Regards, Hans Vogelaar (http://www.eileenslounge.com)

    Thursday, December 11, 2014 4:19 PM

All replies

  • Quit Excel.
    Start Windows Explorer.
    Select the system drive (usually C:).
    Use the Search box to search for *.exd
    Delete all found files.
     
    (Thanks to Excel MVP RoryA for this tip)

    Regards, Hans Vogelaar (http://www.eileenslounge.com)

    Thursday, December 11, 2014 4:19 PM
  • Hello,

    We have heard such issue for several times recently, and we are working on it now. We'll keep you updated if we get any detailed information on this issue.

    Thanks for your support and understanding.

    Regards,

    Steve Fan
    TechNet Community Support


    It's recommended to download and install Configuration Analyzer Tool (OffCAT), which is developed by Microsoft Support teams. Once the tool is installed, you can run it at any time to scan for hundreds of known issues in Office programs.

    Friday, December 12, 2014 8:45 AM
  • Hans,

    That did not work for me. The same error keep occurring.

    Friday, December 12, 2014 10:57 AM
  • Steve,

    Ok. But that is really bad. I cannot go on with my application development with this error. I will really be waiting. Thank you. 

    Friday, December 12, 2014 10:59 AM
  • Make sure that you display hidden files and folders - the .exd files are stored in hidden folders.

    And you probably should reboot after deleting the files.


    Regards, Hans Vogelaar (http://www.eileenslounge.com)

    Friday, December 12, 2014 12:44 PM
  • Hans,

    I didn't even know about hidden files. How do I track them down? My computer is connected to my office's internal web, that might be a problem for finding all of the .exd files. I deleted all the .exd files I found so when I search for those I get nothing. However, the error remains! Any idea?

    

    Monday, December 15, 2014 10:20 AM
  • You'd only need to look for .exd files in your profile on the local hard disk, not on the network.

    See https://social.technet.microsoft.com/Forums/en-US/473b1980-56b3-49ff-be71-3a60c0db048b/form-controls-stop-working-after-december-2014-updates?forum=excel for other options.


    Regards, Hans Vogelaar (http://www.eileenslounge.com)

    Monday, December 15, 2014 4:02 PM
  • Hans,

    My team and I ran into this issue this morning.  Your solution worked.  The link provided here goes into more detail should anyone need to deploy a group policy, but simply deleting all *.exd files (making sure Hidden Files are shown) should/does solve the issue immediately.  I personally didn't need to reboot.

    Thanks!

    Anthony DeMichael

    Monday, December 15, 2014 8:05 PM
  • This, finally, fixed the problem for me (on 3 computers):

    * Search & erasing all *.exd files then,

    * Office program or suite: REPAIR (seems to fully reinstall, have keys or account info ready)

    I have turned off all Office automatic updates... now...

    I understand this is not a viable solution for those managing many computers.


    Marcel Saucier (An old DOS guy since 1983...)

    Monday, December 15, 2014 8:22 PM
  • Anthony, I tried the solution but no way...it doesn't work for me!!!

    In details, we have some spreadsheet to export data using buttons. From beginning of this week the buttons are "frozen"! I mean they do not do anything clicking on them...

    Any other suggestion?


    Tuesday, December 16, 2014 11:42 AM
  • Hans,

    I transferred the file in which everything started to my pc (the file was originally on the computer from the company I work at). So, in my computer, I deleted all the .exd files and it just worked!!!! Man I am so damn happy. Thank you for the awesome support. The reason it did not work at the computer from my work is probably because it is connected to an internal LAN so I could not fin all the .exd files from the entire LAN. Well.. whatever.. Thanks buddy

    Tuesday, December 16, 2014 10:43 PM
  • The same thing happen to me. Just delete *.exd and my activex excel button working again.  How's that happen? What is exd files ? Any explanation on this problem? Is it kind of bug in excel ?
    Tuesday, December 30, 2014 4:14 AM
  • The .exd files contain cached versions of ActiveX controls. Microsoft released an update for Office on December 9, 2014 that changed the behavior of ActiveX controls and made the cached versions invalid. By deleting the .exd files, you force Office to create them anew, using the updated version of the controls.

    Regards, Hans Vogelaar (http://www.eileenslounge.com)

    Tuesday, December 30, 2014 10:33 AM
  • Thanks for this tip!!!! Worked flawlessly for me. :)
    Friday, January 9, 2015 10:23 PM
  • Thank you so much....this VB error has come up for some reason and I have spent days and countless IT hours.  This worked for me....  Had Compile error for VB.
    Monday, January 12, 2015 9:43 PM
  • My Microsoft Excel 2013 Macro enabled button was not able to click until I delete *.exd files in temp folder. Thanks Hans for the tip.
    Friday, September 30, 2016 7:25 PM