none
401 UNAUTHORIZED RRS feed

  • Question

  • Setup Sharepoint stand alone to begin playing with. I can access the site from the server it's installed on (still prompts for user and password - wtf SSO not working on a domain joined server automatically?).

    Servername is Sharepoint - it's setup as default as http://sharepoint

    I attempt to browse either to http://IP or http://sharepoint.asd.local (I'm not on the same domain) and get "401 UNAUTHORIZED". No prompt for username and password.

    I should NOT have to be an expert on Sharepoint authentication to BEGIN learning about the product. This should not have these issues by default. Either as described or SSO not working is NOT acceptable.

    Wednesday, May 1, 2013 12:59 PM

Answers

  • >>I attempt to browse either to http://IP or http://sharepoint.asd.local (I'm not on the same domain) and get "401 UNAUTHORIZED". No prompt for username and password.

    You need to extend your web application to zone http://IP or http://sharepoint.asd.local  , or add these url as internal url in AAM.

    • Marked as answer by GuYuming Monday, May 13, 2013 9:45 AM
    Monday, May 6, 2013 3:17 AM

All replies

  • WTF. If I browse on the server to http://localhost it redirects to http://localhost/_layouts/15/start.aspx#/SitePages/Home.aspx... WITH NO PROMPT FOR CREDENTIALS!!!???

    This is the TEST ONLY version BY DEFAULT. THIS SHOULD NOT BE THIS COMPLICATED.

    Wednesday, May 1, 2013 1:02 PM
  • If you are being prompted on the server itself check your IE security settings.  By default it should be passing your logon credentials to IIS in the background if you are accessing the site as http://sharepoint.  If you are accessing it using the FQDN then you need to change your browser settings because IE only passes for the local intranet zone.  None of that has anything to do with SharePoint.  SharePoint doesn't do Authentication, it only does Authorization after you are authenticated.  Authentication by default is left up to IIS.  There is no SSO involved.  The default settings for IE pass your logon credentials to IIS in the background for the Local Intranet zone. 

    When you browse to the SharePoint from another computer using the IP (which won't work if you are using a host header) or the FQDN you should be prompted for a user ID and password.  The fact that you aren't would suggest that something in your environment is supplying responses to the authentication prompt for you.  Since you mention SSO I suspect you have a default SSO system enabled in your domain, but not configured correctly to supply credentials to SharePoint.

    But the bottom line is that none of this is SharePoint specific.  you would have the exact same problem with any authenticated web site in IIS on that server.


    Paul Stork SharePoint Server MVP
    Principal Architect: Blue Chip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    Wednesday, May 1, 2013 1:10 PM
  • Hello,

    Paul's correct, any URL with a period in it whether it's IP or domain will be automatically be placed in the internet zone for internet explorer.  By default user credentials aren't passed here.  Single label names, by default are in the intranet zone where current logged on user credentials are passed.  You can modify this behavior by adding your IP and FQDN to the intranet zone of IE.

    This isn't a SharePoint issue.


    MCITP-EA | "You don't understand anything until you learn it more than one way" | Hope This Helps!


    Wednesday, May 1, 2013 1:49 PM
  • That would be by design.  Localhost is in the Local Intranet zone, which passes your current logon credentials from the OS in the background.  That is the expected behavior.  As I said in my other post that is the way IIS is designed to work with IE.  It really isn't SharePoint specific.

    Paul Stork SharePoint Server MVP
    Principal Architect: Blue Chip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.


    Wednesday, May 1, 2013 3:22 PM
  • >>I attempt to browse either to http://IP or http://sharepoint.asd.local (I'm not on the same domain) and get "401 UNAUTHORIZED". No prompt for username and password.

    You need to extend your web application to zone http://IP or http://sharepoint.asd.local  , or add these url as internal url in AAM.

    • Marked as answer by GuYuming Monday, May 13, 2013 9:45 AM
    Monday, May 6, 2013 3:17 AM