none
Your licence for Office Server Search has expired.

    Question

  • Hello,

    I am trying to use the MOSS server search feature in a custom web part through C# code.   I copied example code verbatim from an article on MSDN titled "Creating Search Queries Programmatically by Using the Search Object Model in SharePoint Server 2007".   The code compiles fine, but when I open the website and run the example code, I get the error message:

    Your licence for Office Server Search has expired.
    at Microsoft.Office.Server.Search.Query.FullTextSqlQuery.Execute()
     at ... [rest of stack trace]


    We have a valid MSDN subscription license for all the SharePoint products.  

    I have searched high and low for any forum posts that describes this issue, but only a few come up and only one being similar in nature to my problem:  
    http://forums.technet.microsoft.com/en-US/sharepointsearch/thread/2ece879a-6de9-44c2-b75d-4a51fca9ceb9/

    The solution there was to do a complete OS reinstall, but I find this unacceptable.

    Here is my setup:

    Windows Server 2003, R2
    MOSS 2007, Version 12.0.6219.1000
    MS SQL Server 2005
    Visual Studio 2008
    MS Office SharePoint Designer 2007
    MS .Net Framework, 2.0, 3.0, and 3.5

    All this software is installed on a virtual machine (VMWare 6.0.4) and is not connected to the internet (this is a local box used for development only).   Also, I have checked the Crawl Logs, so content is being crawled regularly.

    Any ideas?  This is very frustrating and time consuming!

    Robert
    Monday, August 11, 2008 3:13 PM

Answers

  • Hello All,

    We just had this problem with our SharePoint Sever this morning. We applied the following steps to resolve the issue:

    1. Go to SharePoint Central Administrator and select Operations –> Convert license type
    2. Convert License Type page will show a warning message “Office SharePoint Server Trail with Enterprise Client Access License”. You will also notice that “Enter the Product Key” box is enabling.
    To solve the issue, enter the product key you have for your SharePoint installation and click OK.
    3. It will apply the key and show you a success message.
    4. Check the Convert License Type page again. Now it will show you the correct message - “Office SharePoint Server with Enterprise Client Access License”. Also you will notice “Enter the Product Key” is not disabled.
    5. Re-start the IIS (iisreset)
    6. Search again and it should work.

    Citation: http://blog.laksha.net/2009/12/sharepoint-your-licence-for-office.html (Many thanks to Vinni.)

    Best of Luck!


    Tanzil

    • Edited by Tanzil Malek Monday, February 15, 2010 3:15 PM citation
    • Marked as answer by Mike Walsh FIN Tuesday, March 23, 2010 1:22 PM
    Monday, February 15, 2010 3:13 PM
  • Hi
    It's been some time but this was the first link i got from google.
    My solution after searching everywhere was:
    1. Backup DataBase from Sharepoint Administration
    2. Uninstall all of MOSS and WSS and restart
    3. Install MOSS 2007 and setup a full instalation
    4. Install WSS SP1 and MOSS 2007 SP1 running configuration wizard after each one
    5. Restart
    6. Install WSS and MOSS 2007 cummulative HotFixes (KB 960010 and 960011) running configuration wizard after each one
    7. Restart
    8. Configure an SSP and a new Top level Site
    9. On Search Administration put only Top level Site (e.j. http://localhost)  as my source content
    10. Setup incremental crawling and start a full crawl. At this point you should have a working search on your site.
    11. Restore ONLY content database from your backup. Here i got and error because Sharepoint couldn't attach the database to my site because of the name, so i made it manually.

    And voilà. That work form me after 3 nights of work.

    Good luck

    Jorge
    • Marked as answer by Mike Walsh FIN Tuesday, February 10, 2009 7:05 PM
    Tuesday, February 10, 2009 2:17 PM

All replies

  •  I am having the same problem.

    Here is my setup:

    Windows Server 2003 R2 x64 Standard
    MOSS 2007, Version 12.0.0.6318
    MS SQL Server 2005 Express
    Visual Studio 2005
    MS .NET Framework

    Current License:
    Office Sharepoint Server with Enterprise Client Access License

    It was working fine until I moved the database files from the C drive to the D drive
    doing a detach-attach.


    Bob

    btw i have applied sp1

    • Edited by ChiefE Tuesday, August 26, 2008 5:02 PM forgot to add sp
    Tuesday, August 26, 2008 4:58 PM
  • Hi
    It's been some time but this was the first link i got from google.
    My solution after searching everywhere was:
    1. Backup DataBase from Sharepoint Administration
    2. Uninstall all of MOSS and WSS and restart
    3. Install MOSS 2007 and setup a full instalation
    4. Install WSS SP1 and MOSS 2007 SP1 running configuration wizard after each one
    5. Restart
    6. Install WSS and MOSS 2007 cummulative HotFixes (KB 960010 and 960011) running configuration wizard after each one
    7. Restart
    8. Configure an SSP and a new Top level Site
    9. On Search Administration put only Top level Site (e.j. http://localhost)  as my source content
    10. Setup incremental crawling and start a full crawl. At this point you should have a working search on your site.
    11. Restore ONLY content database from your backup. Here i got and error because Sharepoint couldn't attach the database to my site because of the name, so i made it manually.

    And voilà. That work form me after 3 nights of work.

    Good luck

    Jorge
    • Marked as answer by Mike Walsh FIN Tuesday, February 10, 2009 7:05 PM
    Tuesday, February 10, 2009 2:17 PM
  • Hello All,

    We just had this problem with our SharePoint Sever this morning. We applied the following steps to resolve the issue:

    1. Go to SharePoint Central Administrator and select Operations –> Convert license type
    2. Convert License Type page will show a warning message “Office SharePoint Server Trail with Enterprise Client Access License”. You will also notice that “Enter the Product Key” box is enabling.
    To solve the issue, enter the product key you have for your SharePoint installation and click OK.
    3. It will apply the key and show you a success message.
    4. Check the Convert License Type page again. Now it will show you the correct message - “Office SharePoint Server with Enterprise Client Access License”. Also you will notice “Enter the Product Key” is not disabled.
    5. Re-start the IIS (iisreset)
    6. Search again and it should work.

    Citation: http://blog.laksha.net/2009/12/sharepoint-your-licence-for-office.html (Many thanks to Vinni.)

    Best of Luck!


    Tanzil

    • Edited by Tanzil Malek Monday, February 15, 2010 3:15 PM citation
    • Marked as answer by Mike Walsh FIN Tuesday, March 23, 2010 1:22 PM
    Monday, February 15, 2010 3:13 PM
  • Thanks Tanzil, one of my clients just reported this issue and your suggestion worked.

    Tuesday, March 23, 2010 11:27 AM
  • Also, you can apply the follwing patch from Microsoft KB article:

    http://support.microsoft.com/kb/971620/en-us


    Tanzil
    Monday, April 05, 2010 3:31 PM