none
Outlook 2003 PRF will not append RRS feed

  • Question

  • I need to update the POP3 and SMTP SSL settings and nothing else. The problem starts with the Custon Installation Wizard. In order to enter the SSL ports you have to add user account information. I need to make just these changes to multiple accounts. How do I edit the PRF to make just these changes.

    ; **************************************************************
    ; Section 1 - Profile Defaults
    ; **************************************************************

    [General]
    Custom=1
    DefaultProfile=Yes
    OverwriteProfile=Append
    ModifyDefaultProfileIfPresent=TRUE

    ; **************************************************************
    ; Section 2 - Services in Profile
    ; **************************************************************

    [Service List]
    ;ServiceX=Microsoft Outlook Client
    ServiceEGS=Exchange Global Section

    ;***************************************************************
    ; Section 3 - List of internet accounts
    ;***************************************************************

    [Internet Account List]
    Account1=I_Mail

    ;***************************************************************
    ; Section 4 - Default values for each service.
    ;***************************************************************

    [ServiceEGS]

    ;[ServiceX]
    ;FormDirectoryPage=
    ;-- The URL of Exchange Web Services Form Directory page used to create Web forms.
    ;WebServicesLocation=
    ;-- The URL of Exchange Web Services page used to display unknown forms.
    ;ComposeWithWebServices=
    ;-- Set to TRUE to use Exchange Web Services to compose forms.
    ;PromptWhenUsingWebServices=
    ;-- Set to TRUE to use Exchange Web Services to display unknown forms.
    ;OpenWithWebServices=
    ;-- Set to TRUE to prompt user before opening unknown forms when using Exchange Web Services.


    ;***************************************************************
    ; Section 5 - Values for each internet account.
    ;***************************************************************

    [Account1]
    UniqueService=No
    AccountName=
    POP3Server=
    SMTPServer=
    POP3UserName=%username%
    EmailAddress=
    POP3UseSPA=0
    DisplayName=
    ReplyEMailAddress=
    SMTPUseAuth=1
    SMTPAuthMethod=0
    ConnectionType=0
    LeaveOnServer=0x0
    ConnectionOID=MyConnection
    POP3Port=995
    POP3UseSSL=1
    ServerTimeOut=60
    SMTPPort=465
    SMTPUseSSL=1

    Monday, June 14, 2010 5:24 PM

Answers

All replies

  • Hi,

     

    You can create a Outlook Profile File (.prf) by the instructions on this website:

    http://www.outlook-tips.net/howto/prf.htm

     

    You can select Customize additional accounts to add POP3, IMAP, HTTP, additional PSTs or LDAP address books to your profile.

     

    For more information, you can also refer to this article:

    http://www.outlook-tips.net/howto/prf_listing.htm

     

    Sally Tang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

    • Marked as answer by Sally Tang Tuesday, July 13, 2010 8:16 AM
    Tuesday, June 15, 2010 3:30 AM
  • Hi,

     

    I am writing to see how everything is going with this issue. Is the problem resolved? If there is anything I can do for you, please feel free to let me know.

     

    Sally Tang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

     

    Thursday, June 17, 2010 7:02 AM
  • Hi,

     

    As I have not heard from you for several days. I will go ahead and close this thread. If this issue is not resolved or you have any questions, please feel free to reply to us and this thread will be re-opened.

     

    Best Regards,

     

    Sally Tang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

    Monday, June 21, 2010 1:06 AM
  • Sorry I did not reply

    The problem is not resolved. I found the links you posted before I posted here. The profiles will not appended. When the file is set to append the profile is overwritten, copied, or nothing happens.

    Tuesday, June 22, 2010 8:03 PM
  • Hi,

    Please open a support incident with Microsoft on this issue. We need to investigate this issue more thoroughly and see if we can resolve\workaround the issue or give you an alternative method(s) to use to modify the POP/SMTP account's settings.

    Warrensi, I am also going to give you the notes I made while reproducing the issue so that you can hand them over the Outlook Support Engineer when\if you open an incident.

    ========================================================================================

    I've tried a CIW-generated PRF and the sample PRF to make changes to the I_Mail account and Append to the Outlook profile.

    None of the I_Mail settings are applied to the default POP/SMTP account when the PRF has OverwriteProfile=Append.

    However, a second POP/SMTP account will be added to the profile. The second profile will have whatever settings\values that were set in the PRF.

    For example, the desire is to only modify the options from Tools | Account Settings | POP/SMTP account's Internet e-mail settings | More Settings | Advanced to

    Incoming server (POP3) => 995

    Select "This server requires an encrypted connection (SSL)

    Outgoing server (SMTP) => 465

    Set "Use the following type of encrypted connection:" +> SSL

    Set Server Timeouts to 1 minute (60 seconds)

     

    Since the PRF is set to Overwrite=Append, this infers that you are only going to set what you want modified\change in the profile.

    <From PRF>


    [Account1]
    UniqueService=No
    ;AccountName=
    ;POP3Server=
    ;SMTPServer=
    ;POP3UserName=
    ;EmailAddress=
    POP3UseSPA=0
    ;DisplayName=
    ;ReplyEMailAddress=
    SMTPUseAuth=0
    SMTPAuthMethod=0
    ConnectionType=0
    LeaveOnServer=0x0
    POP3UseSSL=1
    ConnectionOID=MyConnection
    POP3Port=995
    ServerTimeOut=60
    SMTPPort=465
    SMTPSecureConnection=1

    The ";" is used to comment out the line so it is not used.

    <Expected results>

    The default profile would have the I_Mail account's non-commented settings modified to the values above.

    <Actual results>

    The default POP/SMTP account is not affected at all by the PRF. --No changes.

    A second POP/SMTP account is added to the profile with nothing filled out for the commented out settings\values above. To see the settings changes that the PRF made, you'd need to populate User information, server information, and Logon information so that the More Settings button would become enabled and thereby giving you access to the Internet E-mail Settings | Advanced dialog boxes.

    Furthermore, in order to successfully\properly complete the POP/SMTP account that would be added by the PRF, you're going to need to know the User information, server information, and Logon information. My suggestions on that would be to get the following information:

    1. Can "Your name" and "User name" --AccountName, POP3UserName, and DisplayName --use the %UserName% environmental variable?

    2. Is the POP and SMTP server names the same for all of your users?

    3. Is the "E-mail Address:" something like %UserName%@yourcompany.com? --Where the email address would be the value of the %UserName% env. variable and the mail domain would be the same for all of your users?

    Depending on what things are common between all your users, you might be able to set most\all the settings you need to in the PRF for the Internet e-mail account.

     

    Monday, June 28, 2010 11:32 PM
    Moderator
  • We are having a similar problem with using the admin tools to create an automated installation of Office 2003 on Windows 7.  In particular to Outlook, the profile settings to not get created so the users are always prompted to create the Outlook profiles on first use.  The PRF file is not getting imported correctly on a Windows 7 machine.

    Is this something that is supposed to work with Windows 7 or is there a special way to automate profile creation differently than on Windows XP?

    Friday, July 2, 2010 10:22 PM
  • Following up for a status.  Is the Admin/Automated install supposed to work for Office/Outlook 2003 in Windows 7?
    Wednesday, July 7, 2010 5:33 PM
  • Sme thing here - Office 2003 on Win2008 R2 on our TS Farm.   Running the CIW and it is applying (creates the shortcuts I want) but does not create an Outlook Profile.   Prompts new users every time.
    JC
    Monday, November 29, 2010 7:33 PM
  • Any reso;ution? im having a similar issue. Im trying to update existing profiles to point to a new ex2003 server.

    Import prf seems to be working fine on my Outlook 2007 users.  I can run outlook.exe /importprf c:\outlookupdate.prf and a new profile is generated and copies the settings of the old profile.  However, when I run the same script on an existing 2003 client, Outlook starts and displays the exchange is not available would you like to work offline" message.  If I check the mail profile, the only thing configured is the exchange server name.  There is no username or rpc/https settings.  These are all defined in the .prf file and work fine on Outlook 2007. 

    I'll also note that if there is no pre-existing profile, or i configure the prf to create a new profile, the importprf works fine for OL2003.  My prf file is setup to modify the existing profile is one exists.  However, if a profile exists, it creates a new profile, and the only information it populates in the profile is the exchange server name.

    Im runng Win 7.

    Jeremy

    Monday, May 30, 2011 3:04 PM