none
Sharepoint: User not in directory RRS feed

  • Question

  • I have added external users to access my sharepoint page. I received an error containing the following message.

    That didn't work

    We're sorry, but username@domainname.com cann't be found in the domain.sharepoint.com directory. Please try again later, while we try to automatically fix this for you.

    Waiting for some suitable answer please.

    Kamran

    Tuesday, August 29, 2017 1:45 PM

All replies

  • Verify what kind of Trust relationship exist between two domains, internal and external? If none then you can't add. 
    Tuesday, August 29, 2017 3:38 PM
  • To provide access to external users, you will have to set up external SharePoint site. There are plenty of blogs and videos on the internet to show the steps.

    ViviSP

    Tuesday, August 29, 2017 3:43 PM
  • Guys, it's pretty clear we're dealing with SPO here. Neither of your answers are applicable. Please make sure you read the context of the question.

    As for your error Kamran, is External Sharing enabled on the tenant and Site Collection?


    Trevor Seward

    Office Servers and Services MVP



    Author, Deploying SharePoint 2016

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Tuesday, August 29, 2017 3:54 PM
    Moderator
  • Some of the external members can access the sharepoint and others not. They are facing the following problem.

    That didn't work

    We're sorry, but username@domainname.com cann't be found in the domain.sharepoint.com directory. Please try again later, while we try to automatically fix this for you.


    Wednesday, August 30, 2017 7:27 AM
  • Are you using Microsoft Accounts or are these users from another O365 tenancy?

    Trevor Seward

    Office Servers and Services MVP



    Author, Deploying SharePoint 2016

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Wednesday, August 30, 2017 2:53 PM
    Moderator