none
Hardware Clock Not Updating - Reverting to incorrect time - "System time synchronized with the hardware clock"

    Question

  • Hi all,

    after the recent switch to daylight savings here in the uk, one of our servers keeps dropping an hour - reverting it back to the incorrect time. In the event log we see the following message:

    The system time has changed to ‎2016‎-‎03‎-‎28T23:13:32.500000000Z from ‎2016‎-‎03‎-‎29T00:13:32.170967700Z.

    Change Reason: System time synchronized with the hardware clock.

    Has anyone any advice as to what may be causing this? To my understanding, the boot up process goes like this:

    1. Machine Boots

    2. Machine pulls time from local source (CMOS)

    3. Windows loads and uses ntp to check the internet time

    4. If the internet time is different then the OS will change the local (CMOS) time accordingly

    We can sucessfully run a manual sync of the time through control panel, but at some point within the next hour, the system time will sync with the Hardware Clock and we will lose an hour. Has anyone any advice on what may be causing this? BIOS related would be my guess but since this server is hosted remotely, checking it is somewhat tricky.

    Thanks for any help

    Tuesday, March 29, 2016 4:53 PM

Answers

  • Hi Andy,
    thanks for getting back to me. Not sure you quite understood my question (the key issue was that the OS couldn't update the hardware/CMOS clock) but appreciate you taking the time to reply! As it turns out the problem lay with the server itself, which was an HP Proliant Gen9 DL580:

    h20564.www2.hpe. com/hpsc/doc/public/display?docId=emr_na-c04557232&lang=en-us&cc=us

    The fix was to make the following registry change then reboot the server:

    "Create a new DWORD sized Microsoft Windows registry setting named RealTimeIsUniversal under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\ and set the value to '1'. This option will cause the Windows operating system to treat the Real Time Clock time as UTC rather than local time. "

    Cheers
    • Marked as answer by Robot Archive Thursday, March 31, 2016 9:38 AM
    Thursday, March 31, 2016 9:38 AM

All replies

  • Hi Robot,

    Thanks for posting here.

    >>Has anyone any advice on what may be causing this?

    As far as I know, this was caused by the daylight savings.

    Our machines connect to the internet and synchronize time with internet time service.

    So, if in your places using daylight savings the ITS might change the time then your machine's time would be changed.

    If you don't want to use the ITS, just need to let your machines don't connect to the internet.

    But for most situations I suppose it is not possible.

    If I misunderstood , please feel free to correct me.

    Thanks in advance.

    >>BIOS related would be my guess but since this server is hosted remotely, checking it is somewhat tricky.

    Yes, sometimes we could manually change the BIOS date and time settings to achieve this purpose.

    Best regards,


    Andy_Pan

    Wednesday, March 30, 2016 6:57 AM
    Moderator
  • Hi Andy,
    thanks for getting back to me. Not sure you quite understood my question (the key issue was that the OS couldn't update the hardware/CMOS clock) but appreciate you taking the time to reply! As it turns out the problem lay with the server itself, which was an HP Proliant Gen9 DL580:

    h20564.www2.hpe. com/hpsc/doc/public/display?docId=emr_na-c04557232&lang=en-us&cc=us

    The fix was to make the following registry change then reboot the server:

    "Create a new DWORD sized Microsoft Windows registry setting named RealTimeIsUniversal under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\ and set the value to '1'. This option will cause the Windows operating system to treat the Real Time Clock time as UTC rather than local time. "

    Cheers
    • Marked as answer by Robot Archive Thursday, March 31, 2016 9:38 AM
    Thursday, March 31, 2016 9:38 AM
  • Hi Robot,

    Sorry for the misunderstood.

    The fix was to make the following registry change then reboot the server: "Create a new DWORD sized Microsoft Windows registry setting named RealTimeIsUniversal under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\ and set the value to '1'. This option will cause the Windows operating system to treat the Real Time Clock time as UTC rather than local time. "

    Thanks for your sharing and I'm glad to hear that your issue was solved.

    Best regards,


    Andy_Pan

    Thursday, March 31, 2016 9:46 AM
    Moderator
  • Change Batery CMOS and setting clo'ck on bios
    Thursday, March 31, 2016 9:48 AM