Exception from HRESULT : 0x81070905


  • Hi, I can't figure out why I get this error when I try to create a site from a .wsp solution?

    Any help is appreciated


    Feature Activation: Threw an exception, attempting to roll back. Feature 'PDB_MultiPage_WikiModules' (ID: 'd10a5318-273f-4571-a8c9-dddc03dffea0'). Exception: Microsoft.SharePoint.SPException: Exception from HRESULT: 0x81070905 ---> System.Runtime.InteropServices.COMException (0x81070905): Exception from HRESULT: 0x81070905

    at Microsoft.SharePoint.Library.SPRequestInternalClass.EnableModuleFromXml(String bstrSetupDirectory, String bstrFeatureDirectory, String bstrUrl, String bstrXML, Boolean fForceUnghost, ISPEnableModuleCallback pModuleContext)

    at Microsoft.SharePoint.Library.SPRequest.EnableModuleFromXml(String bstrSetupDirectory, String bstrFeatureDirectory, String bstrUrl, String bstrXML, Boolean fForceUnghost, ISPEnableModuleCallback pModuleContext) -

    -- End of inner exception stack trace ---

    at Microsoft.SharePoint.Administration.SPElementDefinitionCollection.ProvisionModules(SPFeaturePropertyCollection props, SPSite site, SPWeb web, Boolean fForce)

    at Microsoft.SharePoint.Administration.SPElementDefinitionCollection.ProvisionElements(SPFeaturePropertyCollection props, SPWebApplication webapp, SPSite site, SPWeb web, Boolean fForce)

    Thursday, March 01, 2012 10:48 PM

All replies

  • Hi,

    if i understand you correctly, you are trying to create a site from an .wsp containing a site template.

    Can you try to deploy the site template using the .wsp file to make sure it works.

    (Seems to be problem with the .wsp file).


    Daniel Bugday
    Microsoft Community Contributor, Member of Microsoft Extended Expert Team, MCT, MCTS/MCPD SharePoint 2007/2010, SQL MCDBA, MCSE

    Blog: SharePoint By Bugday
    Twitter: Follow me on Twitter
    Technet: My Ask The Expert Area On Technet
    Founder of SharePoint Forum

    Thursday, March 01, 2012 11:01 PM
  • Hello,

    I've founded exactly the same problem 12 hours ago and I didn't found where the problem came from yet.

    I found that the problem only occurs with 2 sites tempates :

    In the category "Empty & personalised", I've 3 templates :

    • Empty
    • Personalised site (Site de personalisation)
    • The Template I made

    If I create an empty template, non problem.

    If I try one of the 2 others, I have an error

    • Edited by Dimitri_M Friday, March 02, 2012 9:05 AM update
    Friday, March 02, 2012 8:53 AM
  • Daniel, thanks for your reply.  Here is more background..

    1. I created a sharepoint site (site A.)  a while back on a different server farm.
    2. The template I used was multi-page meeting workplace
    3. I used sharepoint designer and saved the site as template
    4. I created a brand new site/server farm using the team site template
    5. I then loaded the site A. as a solution
    6. When I try to create a custom site (site A.) on the new server farm B., I get the error...

    Hope this clarifies..


    Friday, March 02, 2012 2:31 PM
  • Do you have any folders included in your template?

    I had the same problem and after a long time of searching i found some folders in the shared documents with a foldername:

    1. foldertitle

    2. foldertitle 

    I renamed the folders to:

    1 foldertitle

    2 foldertitle

    And made a new template. This turned out to be my solution.
    Let me know if this solution worked for you.

    The problem seems to be a "dot" in folder or file names...

    Yours sincerely, Bart van Osenbruggen

    Friday, May 11, 2012 1:39 PM
  • I was unable to create a new site from my saved template, but the issue turned out to be that my document sets name had a "." (dot) in them. When I removed the dot, it worked fine. Thank you! 
    Thursday, May 31, 2012 5:08 PM