none
MOSS 2007 Wiki page edit drama.

    Question

  •  

    Hi all,

    Someone else at my company installed and configured MOSS 2007 and then set up a "New Wiki Site". All was good in the world.

    The Wiki was working wonderfully, people were adding content left, right, and centre. Pages were being added and edited. Seemed to be a nice addition to the organisation and fits in with the bigger picture too.

    Then ....

    There is always a then.

    One day for no obvious reason that I can ascertain the function to edit a wiki page stopped behaving as expected.

    Normally what we were doing was going to one of several pages and clicking the edit button in the top right corner, then to add a new page we were typing double square brakets around the new page title, then saving that page. (Eg. click edit button, go to appropriate place on page, type [[DNS Servers]], click save button) This would then place a link on the edited page. If you clicked that link it would take you to a page with a WYSIWYG editor and you could add your content. Then when you are done click the create button and your new page is there.

    We are all good up to here.

    Now we come to the issue, after creating a page, if we now want to edit it we would click the edit button, but instead of bringing up the WYSIWYG editor it brings up a page that only allows you to modify the title or the name of the document and edit webparts and not actually modify the content of the page. (it appears to be the same .aspx page, but the functionality is not there)

    But wait the issue gets weirder, if you try to edit a page that was created before the issue started to appear you can edit away to your hearts desire, but if you create a new page and try to edit it .... no dice.

    I cannot find anywhere anyone having a similar issue. I would really appreciate anyones insight and help in sorting this out.

    The MOSS install was supposedly a vanilla NEXT NEXT NEXT OK FINISH type install. I have subsequently patched the server and the MOSS installation, but this was only after the issue presented itself and hasn't corrected it.

    Kind regards,

    Dave

    Smile

     

    Question is also posted in Newsgroup: microsoft.public.sharepoint.general Will post back answers from there if I get any.

     

    Smile

    Thursday, March 27, 2008 2:17 AM

Answers

  •  

    Success!

     

    The issue was related to a content type problem within the wiki library.  Somehow a person was able to upload an Excel spreadsheet document into the wiki library.   It appears that once that happened all future pages created with "new" were created under the "document" type instead of the "wiki page" content type.

     

    Warning:  The steps below used to fix the issue require directly modifying SharePoint properties using a 3rd party tool.   Make sure you have a full backup of your SharePoint environment before attempting these steps.   Accidentally changing the wrong property within SharePoint Manager 2007 can cause major damage to your SharePoint environment.   I am not responsible for any problems, damages or losses caused by following these instructions.   Proceed at your own risk.

     

    Here are the steps to fix the issue:
    1.  Download and install the SharePoint Manager 2007  (SPM) on the SharePoint server.   Run the program.

     

    2.  Navigate to the wiki library using the SPM tree view.   Expand the wiki node and then under it expand the content types node.   You will most likely see 3 content types:  Documents, Wiki Page, and Folder.   If you see this then the following steps can help you resolve the issue;  continue on with step #3.   If you do not see this then the following steps may not resolve your issue.

     

    3. Click on the wiki node and in the right property panel locate the property ContentTypesEnabled.  It will be set to false.  Change that to true and then click on the save button.

     

    4. Open up a web browser and navigate to your wiki page.   Change the default view to include the field ContentType.  After you complete this step you should see the problem pages listed as a content type of "document" instead of wikipage.   

     

    5.  Edit the properties of each page that has a content type of document.  Change the content type to wiki page.

     

    6.  Navigate to the site settings of the wiki library.   You should now see a section listing out the content types.   Choose the document content type and then delete it.   If you did not change the content types of the existing pages you may receive an error message.  In that case return to step #5.

     

    7.  Return to the SPM, right click on the wiki library and select refresh.   After a couple minutes SPM will reload all of the properties.

     

    8.  Make sure the wiki library node is selected in SPM and then change the ContentTypesEnabled property in the right panel back to false.   Click the save button.

     

    Once this has been completed all existing wiki pages and all newly created pages should work correctly.

     

    • Proposed as answer by Eric Sammann Friday, August 15, 2008 9:17 PM
    • Marked as answer by Mike Walsh FIN Sunday, February 8, 2009 9:15 AM
    Tuesday, June 3, 2008 5:54 PM

All replies

  • It sounds like some kind of silly permissions issue. If your not the admin or creator of the site, i would relay that issue to them. If your not getting errors i would have to point to a configuration item got changes for the site and someone isnt fessing up to it. I just started using MOSS 2007 myself so i cant say for certain but im almost sure its not messed up, just behaving the way it was told to...

     

    Saturday, April 12, 2008 11:33 PM
  • Dave,

     

    Did you ever figure out the issue?   We are seeing the exact same problem.   For existing wiki pages if you click edit everything is fine.  For new pages we see the exact same issue... it allows you to modify the title and such but it doesn't allow you to change content.  

     

    I checked and the exact same edit page is being used for both the working and non-working wiki pages.  In fact I can replace the ID in the edit page string back and forth between a working wiki page and one that is not working.

     

    It doesn't look like a permissions issue because people with full control are seeing this problem.

     

    Very strange and frustrating.

     

    -Mike

    Tuesday, June 3, 2008 4:34 PM
  • ...More research results...

     

    I am using a wonder program called SharePoint Manager 2007 from CodePlex and I think I may have found a clue to what is going on.   If I look at an existing wiki page that is editing properly it shows the ContentType as a Wiki Page.   On the ones that are not editing properly it looks like the ContentType is being set as a Document.

     

    Why?   Guess that is the next step in the investigation.   I will keep posting my results.

     

    Tuesday, June 3, 2008 5:21 PM
  •  

    Success!

     

    The issue was related to a content type problem within the wiki library.  Somehow a person was able to upload an Excel spreadsheet document into the wiki library.   It appears that once that happened all future pages created with "new" were created under the "document" type instead of the "wiki page" content type.

     

    Warning:  The steps below used to fix the issue require directly modifying SharePoint properties using a 3rd party tool.   Make sure you have a full backup of your SharePoint environment before attempting these steps.   Accidentally changing the wrong property within SharePoint Manager 2007 can cause major damage to your SharePoint environment.   I am not responsible for any problems, damages or losses caused by following these instructions.   Proceed at your own risk.

     

    Here are the steps to fix the issue:
    1.  Download and install the SharePoint Manager 2007  (SPM) on the SharePoint server.   Run the program.

     

    2.  Navigate to the wiki library using the SPM tree view.   Expand the wiki node and then under it expand the content types node.   You will most likely see 3 content types:  Documents, Wiki Page, and Folder.   If you see this then the following steps can help you resolve the issue;  continue on with step #3.   If you do not see this then the following steps may not resolve your issue.

     

    3. Click on the wiki node and in the right property panel locate the property ContentTypesEnabled.  It will be set to false.  Change that to true and then click on the save button.

     

    4. Open up a web browser and navigate to your wiki page.   Change the default view to include the field ContentType.  After you complete this step you should see the problem pages listed as a content type of "document" instead of wikipage.   

     

    5.  Edit the properties of each page that has a content type of document.  Change the content type to wiki page.

     

    6.  Navigate to the site settings of the wiki library.   You should now see a section listing out the content types.   Choose the document content type and then delete it.   If you did not change the content types of the existing pages you may receive an error message.  In that case return to step #5.

     

    7.  Return to the SPM, right click on the wiki library and select refresh.   After a couple minutes SPM will reload all of the properties.

     

    8.  Make sure the wiki library node is selected in SPM and then change the ContentTypesEnabled property in the right panel back to false.   Click the save button.

     

    Once this has been completed all existing wiki pages and all newly created pages should work correctly.

     

    • Proposed as answer by Eric Sammann Friday, August 15, 2008 9:17 PM
    • Marked as answer by Mike Walsh FIN Sunday, February 8, 2009 9:15 AM
    Tuesday, June 3, 2008 5:54 PM
  • Mike,

    Thank you for your contribution.  This was an excellent find and the solution worked perfectly.  I was a little confused by step 3 so I want to mention the problem I had in case anyone else gets confused.  In step two you mention to look for the 3 content types, Documents, Wiki Page and Folder.  Then in step three you indicate to click on the Wiki node.  Well, I clicked the Wiki Page node and could not find the ContentTypesEnabled property.  I eventually looked to the Wiki library itself and found the property there.

     

    Friday, August 15, 2008 9:17 PM
  • I've had the same experience with this.
    It looks like when you move an item or document from another list into the wikipages list, the wikipage list inherits automatically the contenttype of the added item as default contenttype.

    In this way I suddenly 'lost' my extra columns like 'owner' and 'Document type' (use for different wiki formats).

    Here are the steps for 'resetting' the contenttype if you don't have a third party tool (I'm not sure if the false contenttype is still hidden in the background after this):

    1. go to another wikipage list within the site collection (or create one)
    2. make sure a wikipage exists or create one new with a name that is not yet used in your target list
    3. Go to "Site Actions" and choose "Manage Content and Structure"
    4. Find the source wikilist
    5. Select the source wikipage
    6. Choose Move (to another location)
    7. Choose the target wikilist (the list with the wrong contenttype)

    Once you have finished these actions you should find the right fields available in your wikilist settings.


    If you have created your own columns, then you should create these columns in the source wikilist as temp columns. It doesn't matter which field type you choose as long as the name is exactly the same as in the target list and the field type is different from the original (for easy recognising later on). Go over the steps mentioned above.
    You will find your temp columns added to your list settings, hereby duplicating the columns. Then remove these added temp columns from your list (make sure you remove the temp ones...). You wikilist should behave normally after this and will show the customized fields in the wiki edit and new pages. You may need to rearrange the column order.

     

    • Edited by cezuart Wednesday, September 10, 2008 12:19 PM
    • Proposed as answer by cezuart Wednesday, September 10, 2008 12:19 PM
    • Unproposed as answer by Mike Walsh FIN Sunday, February 8, 2009 9:15 AM
    Wednesday, September 10, 2008 12:14 PM