none
Prompted for credentials on server after application pool account change RRS feed

  • Question

  • I recently changed the account that the application pool is running as for a MOSS 2007 site that serves as our Intranet (in order to get email-enabled lists to work).  So far it seems to be running fine, except for the fact that when I try to open the site on the actual MOSS server I am prompted for credentials and nothing I enter will allow me to view the site.  This is only happening on the server itself, all other machines will display the site.  I can't figure out what is causing this and it wouldn't be a major issue except that I need to be able to display the site so that I can debug VS workflows.  Any ideas on what I've missed here?

    Thanks,
    Chanda
    Wednesday, April 22, 2009 5:50 PM

Answers

  • From the above discussions, it looks like you cannot access the site on the server but can access the site remotely. This issue can be fixed by making the following registry change:

    • Click Start, click Run, type regedit, and then click OK.
    • In Registry Editor, locate and then click the following registry key:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    • Right-click Lsa, point to New, and then click DWORD Value.
    • Type DisableLoopbackCheck, and then press ENTER.
    • Right-click DisableLoopbackCheck, and then click Modify.
    • In the Value data box, type 1, and then click OK.
    Quit Registry Editor, and then restart your computer.

    Thanks,
    Prashanth
    • Marked as answer by Chanda Cole Tuesday, April 28, 2009 11:26 PM
    Tuesday, April 28, 2009 1:41 AM

All replies

  • Hello Chanda,

    you need to run stsadm -o updatefarmcredentials

    Check this link:

    How to change service accounts and service account passwords in SharePoint Server 2007 and in Windows SharePoint Services 3.0:
    http://support.microsoft.com/kb/934838

    Cheers,
    Daniel Bugday

    Web: SharePoint Forum Blog: Daniel Bugday's SharePoint Blog

    Wednesday, April 22, 2009 6:22 PM
  • Daniel,

    Thanks for the reply.  After looking into updatefarmcredentials I see that it is used after changing the application pool account for the Central Administration site (see here: http://technet.microsoft.com/en-us/library/cc262150.aspx) - I changed the application pool account that is used with our Intranet web application, not Central Admin.  Should I still use this or should I use updatedaccountpassword as described here: http://technet.microsoft.com/en-us/library/cc262549.aspx?  Thanks for your help!

    Chanda
    Wednesday, April 22, 2009 8:09 PM
  • Hi, you should run the command updateaccountpassword. /Daniel
    Daniel Bugday

    Web: SharePoint Forum Blog: Daniel Bugday's SharePoint Blog

    Wednesday, April 22, 2009 8:16 PM
  • Daniel,

    Thank you for the reply, however I have run the updateaccountpassword command and am still being prompted to enter credentials to view my web application on the MOSS server.  I am able to view the same web application on another server logged in as the same user, so it is impacting the MOSS server only. 

    I have successfully change the web application pool account for another web application (my dev site) and am able to view that one on the MOSS server just fine.

    Any ideas?

    Thanks,
    Chanda
    Tuesday, April 28, 2009 12:52 AM
  • From the above discussions, it looks like you cannot access the site on the server but can access the site remotely. This issue can be fixed by making the following registry change:

    • Click Start, click Run, type regedit, and then click OK.
    • In Registry Editor, locate and then click the following registry key:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    • Right-click Lsa, point to New, and then click DWORD Value.
    • Type DisableLoopbackCheck, and then press ENTER.
    • Right-click DisableLoopbackCheck, and then click Modify.
    • In the Value data box, type 1, and then click OK.
    Quit Registry Editor, and then restart your computer.

    Thanks,
    Prashanth
    • Marked as answer by Chanda Cole Tuesday, April 28, 2009 11:26 PM
    Tuesday, April 28, 2009 1:41 AM
  • Thank you Prashanth, that did the trick.  Not sure why it would have become a problem after changing the application pool account but it is working now.  Thanks again,

    Chanda
    Tuesday, April 28, 2009 11:27 PM