Exchange 2010 and 2016 coexistence issue RRS feed

  • Question

  • I've read through multiple guides on adding Exchange 2016 to an existing Exchange 2010 environment.

    On the Exchange 2016 server i ran the get-exchangeserver and the output is:

    EX01       mailbox,clientaccess,hubtransport     Standard      Version 14.3

    EX02       mailbox                                           Standard      Version 15.1

    Which is the output I'm supposed to see according to the guides.  At this point the guides pretty much end, so I'm left to assume that no other configuration needs to be done.  Well, that doesn't seem to be quite correct.

    I moved a test mailbox from the Exchange 2010 database to the Exchange 2016 database.  Move is successful, however Outlook 2010 will not connect to exchange.  I can access the email account in OWA, however, I can receive emails; i can send internally, however i cannot email to external email addresses.

    When i look at the Delivery Report, i get a strange message of:

    The message has been queued on server '' since 7/10/2019 2:46:11 PM.  The last attempt to send the message was at 7/10/2019 2:46:23 PM and generated the error '[{LED=};{MSG=};{FQDN=};{IP+};{LRT=}]'

    I'm looking at the Mail Flow\Send Connector and the settings are:


    Name: Internet

    Connector Status: Enable

    Protocol Logging level: none

    Maximum message size: 10MB


    MX record associated with recipient domain is selected

    Smart host authentication is None


    Address Space is Type: SMTP    Domain: *      Cost: 1

    Source Server: Server: EX01     Site:      Role: Mailbox,Client Access, HubTransport

    DNS records for MX only point to EX01.  There is no autodiscover record, however on the test computer i'm using, i added EX02's ip address to the local HOSTS file for

    Are there settings I'm missing? Exchange?  DNS?

    Thursday, July 11, 2019 7:02 PM

All replies

  • I solved the OWA issue with sending external.  I had to create a new connector and attach it to EX02.  

    I still can't get Outlook 2010 to connect to the EX02 server.  I go through the setup and it shows I'm connecting to, however after putting in my password, i get:

    Outlook cannot log on.  Verify you are connected to the network and are using the proper server and mailbox name.  The connection to Microsoft Exchange is unavailable.  Outlook must be online or connected to complete this action.

    Thursday, July 11, 2019 9:14 PM
  • In environments that are native Exchange 2010, when you introduce Exchange 2016, MAPI/HTTP will be enabled by default. As long as the client supports the protocol, once a mailbox is moved to Exchange 2016, the client will reconfigure itself to use MAPI/HTTP. Upon next boot of the client, MAPI/HTTP will be utilized. It is very important to ensure that you have the correct firewall and load balancer settings in place prior to moving mailboxes, otherwise client connectivity will fail. Ensure you have configured your load balancer and/or firewall rules to allow traffic on /mapi/* via TCP443.

    Besides, ensure that your Outlook 2010 is updated to support MAPI/HTTP. Outlook 2010 was updated to support MAPI/HTTP in the January 2015 Public Update, and additional fixes for it were released in the April 2015 Public Update. 

    Also ensure you have correctly set the MAPI/HTTP, run the command below to double confirm it:

    Get-OrganizationConfig |fl MapiHttpEnabled 
    Get-CasMailbox <user or mailbox ID> | fl MapiHttpEnabled
    Get-MapiVirtualDirectory -Server EX02 | fl 

    For more details, see Client Connectivity in an Exchange 2016 Coexistence Environment with Exchange 2010 and Outlook Connectivity with MAPI over HTTP.


    Manu Meng

    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, July 12, 2019 8:50 AM
  • Just checking in to see if above information was helpful. Please let us know if you would like further assistance.


    Manu Meng

    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact

    Wednesday, July 17, 2019 1:42 PM