none
How to stop Office SharePoint Server Search Service

Answers

  • hi All,

               i think once running the stsadm operation to stop the search action........if the status goes to stopping.then the process can be fastened by  executing in stsadm command prompt

          stsadm -o  execadmsvcjobs.


    Hopes this idea may help.
    Regards,
    Ajith George
    • Proposed as answer by Ajith George Thursday, September 11, 2008 11:38 AM
    • Unproposed as answer by Mike Walsh FIN Wednesday, December 31, 2008 4:49 PM
    • Marked as answer by Mike Walsh FIN Wednesday, December 31, 2008 4:49 PM
    Tuesday, September 9, 2008 12:40 PM

All replies

  • I am having the same issue.  Please advise of a solution.
    Tuesday, July 17, 2007 3:25 PM
  • it was quite an oddity for me. It magically stopped after a few days and repaired itself.
    Tuesday, July 17, 2007 9:29 PM
  •  

    Hello Henry

    I am having the same issue with our Office SharePoint Server Search (stopping)

    Do you recommend just leaving it alone? It was stuck on crawling a shared drive and was unresponsive, thats why i initiated the stop. I noticed you said it stopped and rebuilt itself after 3 days, hopefully it will do the same.

    Thanks

    Tuesday, April 8, 2008 2:05 PM
  • My search service was in "stopping" status last Thursday. Checking the logs today, it was able to kick off a new full crawl on Friday evening without any further intervention on my part.

    We are pre-SP1 still.
    Tuesday, April 8, 2008 5:00 PM
  • stsadm -o osearch -action stop

    then

    stsadm -o osearch -action start

    • Proposed as answer by Beat Nideröst Wednesday, March 24, 2010 5:53 AM
    Wednesday, April 23, 2008 9:53 AM
  • If only that worked...stopping and starting the search service is not the problem; stopping and starting the crawl is the problem.

    If anyone has updates as to how to stop a large crawl in a shorter timeframe than "a week", do let me know. Thanks, Peter
    Monday, April 28, 2008 3:58 PM
  • blargh, I didn't follow through apparently. The "net start/stop" solution posted above does work, so long as you run it on all servers in your farm.


    Edit: this is not the same thing as running the "stsadm -o osearch" commands above, which will kill your index in the process.
    Monday, April 28, 2008 10:19 PM
  • Unfortunately this isn't always the answer. I get the following message:

     

    C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\BIN>stsadm -o osearch -action start -role IndexQuery

     'start' action failed. Additional information: Time out has expired and the operation has not been completed.

     

    When I use the 'stsadm -o osearch -action list' command it shows:

     

    Status: Unprovisioning
    Role: IndexQuery

    Which corresponds with the stuck 'stopping' message. But so far no joy on un-sticking it...

     

    Using 'net stop osearch' I get:


    The service could not be controlled in its present state.

    More help is available by typing NET HELPMSG 2189.

     

    HELPMSG 2189 returns:


    The service could not be controlled in its present state.


    EXPLANATION

    The service is not currently accepting requests. If the service is starting, it cannot process requests until it is fully started.

    ACTION

    Try the operation again in a minute or two.

    If this problem persists, the service may be stuck in a partially running state. Contact technical support. Be prepared to give the name of the service and other information about the system, such as the services and applications that were running, and the type and amount of network activity on the computer at the time of the problem.

     

     

    A restart of the server appeared to make no difference. The service still showed as stopping. However I was then allowed to start the service again.

    Now I'm back to square one - trying to resolve 'This server is not the indexer of this search application.'

     

    Friday, May 16, 2008 8:40 AM
  •  

    I'm having the same issues with trying to stop the Office SharePoint Server Search remaining in a status of Stopping.

     

    Running "stsadm -o osearch -action stop -f" isn't doing anything either.  It just hangs there. 

    Thursday, May 29, 2008 9:02 PM
  • There is a SharePoint forum just for Search issues. Please use it.

    Moving this whole thread there.
    Saturday, May 31, 2008 3:42 PM
  • Hello LaloV,

    Did you ever find a solution to this problem? We're having the same problem now and I'd be very interested in knowing what you did to resolve this.

    Thanks
    Korosh


    Monday, June 30, 2008 7:04 PM
  • I dont remember exactly, but i did try the stadm command but that didnt work.

    I believe I recycled the IIS app pool (Shared Services) or i reset the crawled content under search settings in Shared Services and just recrawled everything.

    If you notice your crawling will continue to work even thought the status notification says stopped.

     

     

    Monday, June 30, 2008 8:06 PM
  •  

     

    Sorry, may be my English not so well.

     

    I was have the same problem in my production envirouments.

    You must following next steps:

                    1. Disable (stop) Windows SharePoint Services Search service from the Central Administration on your Application server.

                    2. Set start type “Maniual” for service Office SharePoint Server Search. (from Services on the local server)

                    3. Restart your Application server were you done first two steps.

                    4. After restarting go to the Services on the server and Start Office SharePoint Server Search.

                    5. Go to the Central Administration, Services on the Server, choose your Application server. You will see that Office SharePoint Server Search actually in “Stopping” state.

    6. Click on the Office SharePoint Server Search and on the next page activate two check box then type your password for the service account for search in the farm and click OK.

                    7. Run the cmd from service account (the same account for your SSP) and run next command: stsadm -o osearch -action start -role indexQuery

                    8. Go to the Central Administration, Services on the Server, choose your Application server. You will see that Office SharePoint Server Search actually in “Running” state.

                    9. Now you must start Windows SharePoint Services Search service, but first you must deleting old database and rebuilt it from the Central Administration when you click Run the service.

     

    May be this will be helpfull: http://www.cleverworkarounds.com/2008/07/09/office-server-search-memory-leak-and-stuck-on-crawling/

     

    Best regards,

    Dmitriy 

    Ukrtelecom JSC Company

    Administrator of Microsoft Office SharePoint Server 2007

    • Proposed as answer by Aniket SPoint Thursday, May 28, 2009 10:11 PM
    Tuesday, July 15, 2008 10:34 AM
  • Thank you for your posts. 


    In regards to the seemingly never-ending stop attempt of the search service, we resolved the issue by way of some commands I had not used before.

    1. A month ago, we used the central admin screen (services on server) to stop search services (since an earlier attempt at stopping an on-going crawl had apparently hung indefinitely). No luck. The system kept showing a status on the "services on server" screen kept showing "stopping" but it never stopped.

    2. We then attempted to stop the search services at the command prompt using this:

    stsadm -o osearch -action stop

    ...again no luck!



    Using this command we confirmed that one of the serers was not "online" (sorry I don't recall the exact status it displayed):


    stsadm -o osearch -action list



    2. We opened a new command prompt and typed the following which revealed a problem with out-dated/out-of-sync databases (?):

    stsadm -o sync -listolddatabases 5

    When executing this command, you should get no values back. If you get a listing of a database, you have a problem...we had a problem.

    3. To resolve the matter we executed the following (the last value in the command represents days back from current date):

    stsadm -o sync -deleteolddatabases 5

    Despite the word "delete" you don't need to fear losing any content (at least that’s what we were told and it held true for us). Perhaps someone with more expertise can comment intelligently on details of what this command does. I can simply tell you that after executing the above command, we were able to stop the search services, restart search services, reset indexes and perform a full crawl.



    Thank you
    Tuesday, July 15, 2008 2:52 PM
  • You can forcefully kill the process using taskkill.  Open up a command prompt, and run:

    tasklist /svc

    This will list your services, PIDs and associated processes.

    Find the PID next to the service 'Osearch'

    Enter this command where XXXX is your PID:

    taskkill /PID XXXX /F

    That will kill the process and allow you to start it again.  Hope this helps.
    • Proposed as answer by SeedTech Thursday, September 4, 2008 5:21 PM
    • Unproposed as answer by Mike Walsh FIN Wednesday, December 31, 2008 4:49 PM
    Thursday, September 4, 2008 5:05 PM
  • hi All,

               i think once running the stsadm operation to stop the search action........if the status goes to stopping.then the process can be fastened by  executing in stsadm command prompt

          stsadm -o  execadmsvcjobs.


    Hopes this idea may help.
    Regards,
    Ajith George
    • Proposed as answer by Ajith George Thursday, September 11, 2008 11:38 AM
    • Unproposed as answer by Mike Walsh FIN Wednesday, December 31, 2008 4:49 PM
    • Marked as answer by Mike Walsh FIN Wednesday, December 31, 2008 4:49 PM
    Tuesday, September 9, 2008 12:40 PM
  • Ajith George said:

    hi All,

               i think once running the stsadm operation to stop the search action........if the status goes to stopping.then the process can be fastened by  executing in stsadm command prompt

          stsadm -o  execadmsvcjobs.


    Hopes this idea may help.
    Regards,
    Ajith George



    I had the same issue as the original poster and this worked to clear the timer job.
    • Proposed as answer by Mike Ryba Thursday, March 8, 2012 3:56 PM
    Wednesday, December 31, 2008 4:26 PM
  • if you want to just stop the service, should use this command:  net stop oSearch
    if you want to just start the service, should use this command: net start osearch

     the stsadm mentioned in the other replies do more than just stop and start the service.  believe the stsadm -o osearch -action stop command actually uninstalls the role from the server.  these greater functions may be helping to cause your issue.

     the full command to add the role is stsadm -o osearch -action start -role query

     these commands have been much more consistent and succesfull for me than using the gui.  before adding the query role with the stsadm command.  one needs to mke sure it is configured properly first.  you can do this with the "serices on server" gui by clicking on the service name in the left column instead od clicking on "start" in the right column.
    • Proposed as answer by jimi mattingly Saturday, April 18, 2009 10:36 PM
    Saturday, April 18, 2009 10:35 PM
  • "if you want to just stop the service, should use this command:  net stop oSearch
    if you want to just start the service, should use this command: net start osearch"


    Had the same issue as stated in this thread and this solution worked for me.

    MCSE, Web Systems Administrator
    Friday, May 15, 2009 7:10 PM
  • In my case, all of the above failed with ".... timed out" and the search service was stuck in "stopping"

    Using pstools to kill the "mssearch" service from another computer (with an admin account that has privelages on the server running sharepoint) does a splendid job.

    ex:

    pskill \\sharepointservername mssearch
    • Proposed as answer by ITGirl Friday, August 7, 2009 2:15 PM
    Thursday, May 28, 2009 3:00 PM
  • PSkill is th ebest solution for killing office search MSsearch exe. Go to task manager and find the task ID .
    Download PSKill from
    http://technet.microsoft.com/en-us/sysinternals/bb896683.aspx

    use follwing command
    PSKill -t 11334

    where 11334 is task ID for the MSSearch.

    This really works.
    • Proposed as answer by Rahul Parimal Sunday, January 24, 2010 2:00 AM
    Sunday, January 24, 2010 1:59 AM
  • Thanks. stsadm -o osearch -action start -role query worked for me. stsadm -o  execadmsvcjobs did nothing.
    Monday, February 15, 2010 12:25 PM
  • Hi

    Using stsadm to stop the osearch service will blat the index:

    Try using running taskkill.exe /F /IM mssearch.exe /T in command prompt – this will terminate all mssearch.exe processes and their dependencies and then restart the mssearch.exe service again ( this might take a couple of minutes – you can check in Task manager when the service is up again).

     

    If the above does not resolve the issue, then reboot the index server

    Cheers

    Jon



    Friday, March 5, 2010 3:20 PM
  • Hi, Thanks for your posts guys..

    I had to do a combination of what was mentioned here:

    1. stsadm -o osearch -action stop

    2. Reboot (the service was stuck stopping anyway)

    3. stsadm -o osearch -action start -role index

    After this i could net stop / net start as much as i wished. I actually didnt need to - the december 2009 update was timing out because of it though.

    Tuesday, April 13, 2010 2:00 AM
  • 0

    Hi all, Thanks

    I have executed the following commands from command prompt;

    1. stsadm -o osearch -action stop

    2. stsadm -o osearch -action start

    Note; It will give u a Warning: The Office SharePoint Server Search service that was enabled on this se
    rver will be uninstalled and all index files for all SSPs will be deleted.
    Are you sure you want to permanently delete all data in the index for all SSPs?
    [y/n]n (Give this as No)
    Operation was canceled.
    Operation completed successfully

     

    This Works


    • Edited by Anil.bm Wednesday, April 14, 2010 5:41 AM changes
    Tuesday, April 13, 2010 9:46 PM
  • If you really want to stop long running crawls and not kill the existing index you can do the following:

    Locate any MSSDMN processes and kill them, once you kill them you should have a smoother time restarting the MSSearch service.

     

    This should get you back on track.

     

    -Robert

    Friday, July 30, 2010 5:10 PM
  • Hello people,

    I am having the same issue but I have WSS 3.0 environment. So there is no osearch command as it is only availble for MOSS.

    So can anyone please suggest what to do in WSS 3.0?

    Will stadm -o spsearch -action stop will do the same in WSS 3.0?

    Wednesday, October 13, 2010 10:07 AM
  • Hi All!

    I Bloged about it because i could find any solution, so read my aproach

    http://msmvps.com/blogs/officept/archive/2011/05/12/office-server-search-process-stopping-stuck-freeze-eternally.aspx

     

    Regards

    JL 


    MVP Office Development, MCP, MCTS SharePoint 2010 Development
    Thursday, May 12, 2011 12:41 PM
  • Hello,

    If at all crwal is the problem & showing stopping in Crawling. In central Administration in Search Service Application select->Index Reset & click Reset Now. This will make the crawling status to Idle if is taking longer time for stopping.

     

    Saturday, February 18, 2012 7:42 AM
  • My Crawl was in a stopping state for 16 hours, unfortunately none of these things worked. Has anyone seen any PowerShell to force the crawl to stop?

    Thanks,

    Tony

    Friday, February 22, 2013 9:49 AM
  • Hi, I just facing this issue yesterday. I had recently upgrade my Sharepoint Server to SP1, but I haven't run the Product Configuration Wizard to make necessary updates to current SP.

    I already tried all solutions provide in here but no luck. In the end, I just run the Product Configuration Wizard and bam, everything working normal again.

     
    Wednesday, March 27, 2013 2:04 AM
  • In my case, the service was Office Search which is Osearch but worked perfectly and the crawl began immediately.

    MooseMan

    Thursday, April 9, 2015 9:05 PM