none
Welcome email uses internal servername

    Question

  • Setup:  Windows Server 2003 SP1/WSSv3/SSL/published via ISA2004/basic authentication

    Problem:  When adding a new user to the site, and checking "Send welcome e-mail to the new users", it includes the site link to https://internalname.domain.com/sitename.  However, I have the site published via ISA as https://externalname.domain.com/sitename

    In the Central Administration site, I have set up the appropriate access mappings.  Any way to make the welcome email include the external link and not the internal one?  Most of our users are accessing this site as an extranet, so the internal link doesn't resolve for them.

    Suggestions?

    Christian

    Tuesday, February 13, 2007 7:35 PM

All replies

  • I have the same problem. The email sent includes a load of unwanted information. It's a bit spam-like. Can I change the body text to suit our needs?

     

    Is anyone listening? Thread started in Feb. '07 with no reply.

    Thursday, October 25, 2007 8:12 PM
  • I have the same setup, an internal name for integrated authentication and an external mapping for basic authentication. If you access the site using the external name when setting up new users etc, the external name will be used in links sent out in welcome e-mails.

    Friday, October 26, 2007 1:17 AM
  • >>>access the site using the external name

     

    Great tip. That will help. Thanks for the prompt reply.

    Friday, October 26, 2007 1:24 AM
  • Is there any setting to ensure that the "Send welcome e-mail to new users" checkbox is unchecked by default, in order to avoid sending emails by mistake?

     

    Thursday, December 06, 2007 6:08 AM
  • I'm looking for this answer too.  Anybody got it?

    Wednesday, February 13, 2008 10:10 PM
  • I also want to know how to make "send welcome email" unchecked by default.  I found a method here: http://fmuntean.wordpress.com/ but it involves changing a file in the 12 hive, which would affect all SharePoint web applications on the server - I need to be able to change this on a site collection basis.

     

    Any suggestions?

     

    Wednesday, July 02, 2008 1:40 PM
  • This is a BUG, or at best a VERY poorly desiged feature...

    The problem exists in Microsoft.SharePoint.ApplicationPages.AclInv.SendEmailInvitation()* 

    One of the lines read:
    string urlToEncode = base.Web.Url + "/_layouts/people.aspx?MembershipGroupId=" + SPHttpUtility.UrlKeyValueEncode(byID.ID.ToString());

    The problem, of course is that base.Web will be the web that the current user is in, not the web that the extranet user will have rights to.

    Other than replacing/editing the AclInv.aspx page in Layouts I don't see any way this can be fixed.  Given that this thread has been out here for more than two years I hold little hope that MS will fix the issue any time soon...

    (*locate the dll in C:\inetpub\wwwroot\wss\Virtual Directories\<your site>\_app_bin and reflect away...)
    Thursday, April 09, 2009 8:08 PM