none
Unable to crawl file share RRS feed

  • Question

  • SharePoint 2013 Enterprise On Premise....
    I have set-up a new content source which is a file share.
    I have made sure that the crawl account has read access to the location and I have also used gpedit.msc on the server where the file share resides to make sure that the account also has the rights shown below.

    However when I try to do a crawl of the content search I keep getting the error (in the crawl log)
    The crawl account did not have sufficient privileges to access the security attributes of this file or folder. Ensure the crawl account has the 'Manage auditing and security log' privilege

    What have I missed?

    Thursday, February 25, 2016 3:14 AM

Answers

  • Hi,

    To resolve this issue, assign the Manage Auditing And Security Log permission to the SharePoint 2013 crawler. To do this, follow these steps on the computer that hosts the file shares:

    1. Click Start, click Run, type gpedit.msc, and then click OK.
    2. Navigate to the following location in the Local Group Policy Editor:
      Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment
    3. In the right pane, locate and right-click Manage auditing and security log, and then click Properties.
    4. Click the Add User or Group button in the Manage auditing and security log properties dialog box, and then add the crawl account that the SharePoint 2013 crawler uses.
    5. Click OK in the Manage auditing and security log properties dialog box.

    Note If you assign the Manage Auditing And Security Log permission by using a Group Policy Object (GPO), add the crawl account to the GPO.


    Badri

    Monday, February 29, 2016 5:48 AM

All replies

  • The permissions settings are very tricky when it comes to the File Share.  Once you change the policy you must log off and login again. 

    Based on my experience file shares some time have broken permission inheritance so SharePoint Crawl account does not get permissions to all sub levels.  To make sure that Crawl account has permissions on every folder and sub folder you must Add the user to Security Tab on file share properties then Click Advanced to go to the inheritance settings and apply the permissions to folder as well as sub folder of all levels.  Do not forget to assign Share permissions.

    Once you assign the permissions all to all levels, crawl will complete successfully. 


    Jerry Yasir - Office Server & Services MVP/MCT Hewlett Packard Enterprise - If this reply helped you resolve your issue, please propose as answer. It may help other community members. Thanks!

    • Proposed as answer by Deepesh Yevle Thursday, February 25, 2016 4:46 AM
    • Unproposed as answer by QPR_JAY Wednesday, March 2, 2016 8:13 AM
    Thursday, February 25, 2016 4:38 AM
  • go to your SharePoint server, and open Start->Administrative Tools->Services, scroll to SharePoint Search Host Controller, check the service account.

    1 : Go to the computer that hosts file shares, then grant the service account Manage Auditing And Security Log permission as the Microsoft article you mentioned, compare the result

    2 : GPO permissions on network share. After providing permissions on network share


    Deepesh Yevle -MCP MCTS MCITP ITIL

    Thursday, February 25, 2016 4:48 AM
  • The problem seems to have resolved itself... must have needed a GP update.

    However for some reason the crawl log shows only 11 items crawled (with no errors).
    The root folder, the 9 subfolders and a text file that was in there.
    This file share is where we store video files.... any ideas why the video files themselves would not be crawled?

    Thursday, February 25, 2016 10:51 PM
  • ok... one step closer. I added MP4 and MOV to the list of file extensions to be crawled.

    I then did a full crawl for the content source and it took longer (a good sign).
    However, I now get 5 "warnings" in the crawl log. One for each of the video files in the file share.

    The file reached the maximum download limit. Check that the full text of the document can be meaningfully crawled
    Or
    Item format unsupported

    Is this an iFilter thing?

    Thursday, February 25, 2016 11:06 PM
  • Good to know that you are making progress.

    The default Download limit for crawler is 64MB.  You have to increase it to allow the crawling of videos.  Its a bit tricky decision.  I hope your videos are not Blueray DVDs converted to Mp4.  The max is 1024MB which you can set using PowerShell.  Review the video files and decide what size you must specify.

    $searchapp = Get-SPEnterpriseSearchServiceApplication $searchapp.GetProperty("MaxDownloadSize") #this command is just to check the current value; default is 64 $searchapp.SetProperty("MaxDownloadSize", <value>) #where you replace <value> with the download limit; for example, 256

    $searchapp.Update() #Run a Full Crawl.

    Best of Luck.


    Jerry Yasir - Office Server & Services MVP/MCT Hewlett Packard Enterprise - If this reply helped you resolve your issue, please propose as answer. It may help other community members. Thanks!


    Friday, February 26, 2016 12:31 AM
  • Yep thanks did that. Increased to 3GB (this is the test farm!) as the largest of the 8 files is 2.8GB and then I ran a full crawl again. This time it took 40 minutes! But ultimately no videos were successfully crawled.

    Errors/warnings are:

    The first attempt to crawl this object failed. Another attempt is being made.
    and
    Item format unsupported

    I'm beginning to think this is a bad move.

    Friday, February 26, 2016 12:38 AM
  • Hi,

    To resolve this issue, assign the Manage Auditing And Security Log permission to the SharePoint 2013 crawler. To do this, follow these steps on the computer that hosts the file shares:

    1. Click Start, click Run, type gpedit.msc, and then click OK.
    2. Navigate to the following location in the Local Group Policy Editor:
      Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment
    3. In the right pane, locate and right-click Manage auditing and security log, and then click Properties.
    4. Click the Add User or Group button in the Manage auditing and security log properties dialog box, and then add the crawl account that the SharePoint 2013 crawler uses.
    5. Click OK in the Manage auditing and security log properties dialog box.

    Note If you assign the Manage Auditing And Security Log permission by using a Group Policy Object (GPO), add the crawl account to the GPO.


    Badri

    Monday, February 29, 2016 5:48 AM
  • What if you have shares located on a non-microsoft filer (such as NetAPP)?  How can you change auditing permissions there?  This fix assumes that all file servers are Microsoft file servers.
    Wednesday, February 8, 2017 3:41 PM
  • You should then post the question to NetApp support forum.  I have never configure NetApp with SharePoint so can't confirm but Check below posts to see if they help.

    https://social.technet.microsoft.com/Forums/en-US/d3453d00-ce85-44fc-a6ef-cd9d9f7d71b7/file-share-crawl-netapp-servers-permission-issues?forum=sharepointsearch


    Jerry Yasir - Office Server & Services MVP/MCT Hewlett Packard Enterprise - If this reply helped you resolve your issue, please propose as answer. It may help other community members. Thanks!

    Wednesday, February 8, 2017 3:47 PM