locked
Error: The search request was unable to connect to the Search Service.

    Question

  • When attempting a search, I get the the error message "The search request was unable to connect to the Search Service. "  The search sevice has been started in Central Administration.  Does anyone have suggesting as to how to troubleshoot this issue?

     

    Thank you in advance for your help.

    Wednesday, June 06, 2007 4:40 PM

Answers

  • At last it is working....

    Goto Computer management...
    Select Services and applications
    Start indexing service.

    Thanks,
    Aji
    • Proposed as answer by Ben Mouser Monday, December 01, 2008 9:36 PM
    • Unproposed as answer by Mike Walsh FIN Tuesday, March 10, 2009 1:47 PM
    • Marked as answer by Mike Walsh FIN Tuesday, March 10, 2009 1:48 PM
    Thursday, July 12, 2007 9:10 PM
  • This issue plagued me for most of last week.  I deleted the search service application and installed a new one.  Then I had the same error message.  A Grrrr... response was short lived because it was the weekend: - Relax :)

    Monday morning I found the configurations for "Service Application Associations" under Application Management (Central Admin).  I clicked the default proxy group for my main web application and had to check the check box next to my new search application.  Problem solved.

     

    • Proposed as answer by fdelfosse Wednesday, November 24, 2010 1:35 PM
    • Marked as answer by Mike Walsh FIN Thursday, December 30, 2010 1:48 PM
    Monday, August 30, 2010 12:34 PM

All replies

  • I get the same error.

     

    Some additional information:

    The following errors occur in the event log at the WFE:

     

    Event Type: Error

    Event Source: Office Server Search

    Event Category: Search service

    Event ID: 10040

    Date:  6/11/2007

    Time:  1:45:59 PM

    User:  N/A

    Computer: XXX

    Description:

    The last query machine has been taken out of rotation.  Check previous event logs to determine cause.  Propagation may be necessary. Component: 230a3c7d-b2d5-4bc8-8225-94db7ec58cbd


    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

     

    Event Type: Error

    Event Source: Office Server Search

    Event Category: Search service

    Event ID: 10038

    Date:  6/11/2007

    Time:  1:45:59 PM

    User:  N/A

    Computer: T45MOSS

    Description:

    Query machine XXX' has been taken out of rotation due to this error:  0x80040e04.  It will be retried in 15 seconds. Component: 230a3c7d-b2d5-4bc8-8225-94db7ec58cbd

     

    And then, 15 seconds later:


    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Event Type: Information

    Event Source: Office Server Search

    Event Category: Search service

    Event ID: 10041

    Date:  6/11/2007

    Time:  1:46:14 PM

    User:  N/A

    Computer: XXX

    Description:
    Query machine 'XXX' has been restored to the query rotation. Component: 230a3c7d-b2d5-4bc8-8225-94db7ec58cbd


    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


     

    The event logs at the DB server and the search server do not throw any error messages. The problem seems to occur when the index grows over a certain size.

     

    Has anyone managed to solve this?

    Monday, June 11, 2007 11:57 AM
  • I also had the same message when tried to search anything. Solution for me was to start two Windows Services on the server machine such as ‘Office SharePoint Server Search’ and ‘Windows SharePoint Services Search’ - they were stopped because of login troubles.

    Wednesday, July 11, 2007 2:14 PM
  • I also have the same error , when I am trying to search some thing , I am getting the below error
    "The search request was unable to connect to the Search Service"

    My environment is ,
    WSS 3 with SQL server2005 Embedded Edition .
    Search service is started in windows services as well as in Central Administration .

    Any one can help me , I am struggling with this from last week.

    Thanks
    Aji
    Wednesday, July 11, 2007 6:41 PM
  • At last it is working....

    Goto Computer management...
    Select Services and applications
    Start indexing service.

    Thanks,
    Aji
    • Proposed as answer by Ben Mouser Monday, December 01, 2008 9:36 PM
    • Unproposed as answer by Mike Walsh FIN Tuesday, March 10, 2009 1:47 PM
    • Marked as answer by Mike Walsh FIN Tuesday, March 10, 2009 1:48 PM
    Thursday, July 12, 2007 9:10 PM
  • Hi Aji K Jose,

     

    Thank you very much for the great information.

     

    We have recovered from the index service stoppage.

     

    But now we observe that the index server is alternatively restored and taken out of the rotation.

     

    Do you have any idea?

     

     

     

    Thursday, November 29, 2007 11:16 AM
  •  

    thanks. it works. I restarted them.
    Thursday, January 31, 2008 3:01 AM
  •  

    Hi,

     

    I am working on search control of sharepoint services 2007,which is available on all the pages.

    when i am trying to search any word or document exist on my siet then i am getting  error page mention that

     "The search request was unable to connect to the Search Service."

    & i want to know how to work with search settings available in side the site settings page of the application

    & how to do use of these options. (1)Use custom scopes. Display richer results using the following Search Center:

    & also how to work with search scopes & search keywords.

     

    Finally my aim is to make that search control working.please help me on this.

     

     

    Thanks,

    sarmi

     

     

    Friday, May 02, 2008 6:50 AM
  • Sarmi,

    this book by Patrick Tisseghem and Lars Fastrup might be a good starting point - or you could attend a Microsoft search course.

     

     

    - Tarjei

    Friday, May 02, 2008 9:21 AM
  • Hi Aji,

    I tried your suggestion but its not working.

    I am using Sharepoint2003 and wish to search the list of documents which are contained a particular word.

    Please help me to find a solution for this.

    dhana.
    Saturday, March 07, 2009 5:12 AM

  • I have the same error message when searching with event log ID 10038, 10039 and 10040.

    My environment is MOSS 2007 Standard version and Window Server 2003 SP2.


    Has anyone managed to solve this?

    Thanks in advance
    Wednesday, July 22, 2009 4:09 AM
  • It worked for me

    1.  Try to restart Office Sharepoint Server Search (if it is not started start it.) 
    open Cmd prompt.....
    and stop and start Office Sharepoint Search
    net stop osearch

    net start osearch


    2. Might be ur SSP in not set up properly. You can try setting up the SSP with the correct administrative accounts


    3. Then do a full crawl of your site.


    4. And then do what AJi K Jose has suggested.

    i.e.

    Goto Control Panel>>Administrative Tools>>Computer management
    Select Services and applications
    Start indexing service.
    Friday, September 04, 2009 4:38 AM
  • I have restarted the indexing service from computer management. However, problem still persists.  Is there any way to over come this problem without restarting the office search service? 'cause don't want to run the share point indexing again after restarting the share point search service...
    Thursday, October 22, 2009 8:23 AM
  • I have followed all of the above, and other suggestions and find myself in the same situation.  Further thoughts or suggestions would be appreciated.
    Saturday, October 31, 2009 6:39 AM
  • Make sure you have configured and started the crawling. Go to the crawl settings in your Shared Services Administration site. Go in Search Settings and look at the Content sources. Click on the content source, and in there you can define the URLs to crawl, the schedule, etc. Click on the "Start full crawl of this content source" at the bottom. Make sure you define the schedules properly, otherwise your search results will be irrelevant and stale.
    Tuesday, November 10, 2009 8:22 PM
  • We had  a probelm with the same symptoms.  Checking the Crawl Log showed a load of Access Denied errors.  After a lot of research it turned out to be the loopback check performed by Windows Server.

    http://support.microsoft.com/kb/896861
    Wednesday, December 09, 2009 2:19 PM
  • We are having the same problem.  I have tried all of the suggestions above and still no joy.

    I beginning to think this may be a permissions issue with the account as I too am seeing a lot of Access Denied errors.  I am going to create a new account for search services and see if that fixes the problem.

    Will let you know how I make out.


    Jim Restucci
    Thursday, May 06, 2010 9:12 AM
  • I managed to solved the problem. The issue is caused by web server and index server, "Server" services is not started (running). Therefore the web server cannot talk to index server.

    Resolution:-

    1. go to Web Server and go to Control Panel > Administrative Tools > Services.

    2. Look for "Server" service. If is not started, right click it and click Start.

    3. Go to Index Server and go to Control Panel > Administrative Tools > Services.

    4. Look for "Server" service. If is not started, right click it and click Start.

    Make sure the 2 server "Server" services is started. Hope it helps. Thanks.

    Tuesday, May 25, 2010 3:30 AM
  • Hi Yan,

     

    Can you do the below setting :

     

    GO To Start-> Administrative Tools->Services

    Select Office SharePoint Server Search and do the ReStart

     

    might be this will very use full to you.....

    Wednesday, July 07, 2010 5:07 AM
  • This issue plagued me for most of last week.  I deleted the search service application and installed a new one.  Then I had the same error message.  A Grrrr... response was short lived because it was the weekend: - Relax :)

    Monday morning I found the configurations for "Service Application Associations" under Application Management (Central Admin).  I clicked the default proxy group for my main web application and had to check the check box next to my new search application.  Problem solved.

     

    • Proposed as answer by fdelfosse Wednesday, November 24, 2010 1:35 PM
    • Marked as answer by Mike Walsh FIN Thursday, December 30, 2010 1:48 PM
    Monday, August 30, 2010 12:34 PM
  • Thanks a lot!

    3 days checking the entire farm setup while the answer was fairly simple.

    you made my day.

    Fred.

    Wednesday, November 24, 2010 12:22 PM
  • Thanks for the answer! This was the fix I was looking for.
    • Proposed as answer by Buckeyes Forever Thursday, December 09, 2010 4:03 AM
    • Unproposed as answer by Mike Walsh FIN Thursday, December 30, 2010 1:48 PM
    Thursday, December 09, 2010 3:52 AM
  • Thanks Willhadden Your Suggestion Solve my Problem
    Tuesday, December 21, 2010 9:24 AM
  • Thanks for this
    Thursday, December 30, 2010 12:43 PM