locked
Event 10038, 10039, 10040 on Windows SharePoint Services 3 Search

    Question

  • My front end server is throwing up dozens of these event ID's from the "Windows Sharepoint Services 3 Search" source. The 10038 is:

     

    Query machine 'blah' has been taken out of rotation due to this error: The system cannot find the file specified.   0x80070002.  It will be retried in 15 seconds. Component: blah

     

    10040 is:

     

    The last query machine has been taken out of rotation.  Check previous event logs to determine cause.  Propagation may be necessary. Component: 'blah'

     

    and 10039 is:

     

    Retry of query machine 'blah' has failed with error: The system cannot find the file specified.   0x80070002.  It will be retried again in 30 seconds

     

    It may\may not be related but searching of the online sharepoint help is also not working, it never returns any results no matter what you search for. Can anybody help?

    Friday, June 8, 2007 3:35 PM

Answers

  • In my case, I tried to run Products and Technologies Sharepoint Assistant, this process failed but then I follow those instructions:
    http://support.microsoft.com/kb/923896/en-us

    I reloaded again Products and Technologies that became succeded.
    Then service search works again :)
    • Marked as answer by Mike Walsh FIN Wednesday, September 7, 2011 8:50 AM
    Monday, October 5, 2009 10:53 AM

All replies

  • I am getting this too, but only when I click on the week view of calender.

     

    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=1722643&SiteID=1&mode=1

     

    check here.

    Tuesday, June 12, 2007 4:36 PM
  • Hi,

     

    I am get this same error and wondering if you happen to have resolve the problem. If so, is there any information you could share to help me resolve it.

     

    Thank you.

    Friday, July 6, 2007 1:07 AM
  • I re-created all of the Search indexes, deleted databases and so on, this seemed to fix the problem for a while. But now search has stopped working again...
    Friday, July 6, 2007 8:22 AM
  • Well my problem was that Groupwise Template or whatever the first new WSS v3 template was, it failed to install on my server, I left it alone assuming not had uninstalled it's self. I uninstalled the program, then recreated my website and everything works great.
    Friday, July 6, 2007 11:12 PM
  • I had same problem. After granting "local activation" permission to network service (in your case to account on which SPS site actually runs) for SPSearch and IIS WAMREG admin service all works ok.

    Friday, August 3, 2007 5:40 AM
  • Where do you make this change?

     

    I've been looking and trying everything, but can't get the darned search to work in our WSS3.

     

    Thanks,

    Friday, August 24, 2007 7:52 PM
  •  

    >>Where do you make this change?

     

    In Component Services mmc snap-in of course. Right click SPSearch and ISS WAMREG Admin components in DCOM Config folder and select "properties". Then adjust permissions at "security" tab.

    Wednesday, September 26, 2007 4:25 PM
  • Make sure your Windows SharePoint Services 3 Search is started on Index server (assuming farm)
    Its set for Manual by default, No need to change DCOM settings on Index server assuming proper install.
    • Proposed as answer by tedka Friday, August 8, 2008 6:35 PM
    • Unproposed as answer by Mike Walsh FIN Tuesday, May 19, 2009 7:38 AM
    Friday, August 8, 2008 6:34 PM
  • In my case, I tried to run Products and Technologies Sharepoint Assistant, this process failed but then I follow those instructions:
    http://support.microsoft.com/kb/923896/en-us

    I reloaded again Products and Technologies that became succeded.
    Then service search works again :)
    • Marked as answer by Mike Walsh FIN Wednesday, September 7, 2011 8:50 AM
    Monday, October 5, 2009 10:53 AM
  • Run the following stsadm command to restore the query machine back to the query rotation, even if your SharePoint search service is started.

    stsadm -o osearch -action start

    Monday, March 22, 2010 12:09 AM
  •  

    To resolve this issue,

    1. Check the permissions for the Search Folder. Ensure WSS_Admin_WPG, IIS_WPG group has permission.

     

    2. Execute below command on affected query server

    stsadm -o osearch -action stop

    stsadm -o osearch -action start -role query


    Rajini Hasant'

     

    Moderator Note: NEVER propose your own posts. Propose the good answers of other people - that is why the function is there.

    • Proposed as answer by Rajini Hasan Monday, July 18, 2011 12:05 PM
    • Unproposed as answer by Mike Walsh FIN Monday, July 18, 2011 3:13 PM
    • Edited by Mike Walsh FIN Monday, July 18, 2011 3:15 PM Moderator Note added about not proposing own posts. (I will delete posts if repeated too often)
    Monday, July 18, 2011 11:44 AM
  • Hi Rajini

    When you say "check the permissions for the search folder...." where do you do this.

    Thanks

    Adam

     

    Monday, July 25, 2011 3:16 PM
  • HI Adam,

    Edit the SSP, you can find the index path configured. This path will be configured in Index server. Also note down the propagation location in query servers as well from CA --> Operations --> Services on Server --> Choose the query server and click on Office SharePoint Server Search. This will show you the propagation locations in query servers.

    Check the permissions in those search folders..


    Rajini Hasan
    Tuesday, July 26, 2011 5:23 AM
  • Hi Rajini,

    We are facing same issues.

    On the indexes and on the propagation path WSS_ADMIN_WPG user has access permissions with full control.

    However in place of IIS_WPG user, WSS_WPG user has Read, Execute and list folder contents permissions for the search folders.

    Can you please guide as to what permission needs to be set for WSS_Admin_WPG, IIS_WPG group ?

    Thanks in advance !!

    Avaneesh

    Wednesday, September 7, 2011 6:03 AM
  • Hi avaneesh,

    There's no harm in giving full control for those groups..


    Rajini Hasan
    Wednesday, September 7, 2011 7:24 AM