none
Office 2007 Open File dialog immediately closes. RRS feed

  • Question

  • Greetings!

     

    Our environment is currently running Office 2007 Enterprise. We have implemented roaming user profiles and folder redirection for a subset of our users. Since that change, our users are unable to open documents using the appropriate application's Open File dialog. When the user clicks Open File the dialog appears for less than one second and then immediately closes. Another problem which I believe to be related is that when a user clicks on Save As, the application hangs and finally crashes. Any guidance on how to resolve this would be greatly appreciated!

    Very best regards.

    Friday, July 1, 2011 5:01 PM

Answers

  • Max,

     

    Sorry about the delay. Work has inhibited my promptness. However, I appreciate yours. I was able to solve the problem.

     

    This issue is related to folder redirection and a few registry settings inside HKCU. It appears to me (since what I did solved the problem) that MS Office 2007 does not like a UNC path value inside the Shell Folders "Personal" key. This is not an issue for us as we are currently mapping the user's My Documents to a drive letter as well as using folder redirection.

     

    The solution was relatively simple. Modify the following registry setting as follows (for each user, of course):

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders]

    "Personal"="z:\\" #This is if z is the letter used for your user's My Documents mapping.

     

    Again, I'm not sure why Office 2007 doesn't like a UNC path in this registry value. The fact is that it doesn't. So mapping the network location of My Documents to a letter and modifying the registry is a solution that works.

     

    Very best regards.

    • Marked as answer by thornburg Tuesday, July 12, 2011 4:08 PM
    Tuesday, July 12, 2011 4:07 PM

All replies

  • Hi there,

    Is this issue only related with Office application?

    For example, when you open the Notepad, and use the Open File function, will it be OK?


    Sincerely,

    Max Meng
    Forum Support
    Please remember to mark the replies as answers if they help andunmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    Monday, July 4, 2011 4:35 PM
    Moderator
  • Any update?

    Sincerely,

    Max Meng
    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    Tuesday, July 5, 2011 6:34 AM
    Moderator
  • Sorry for the delay. Off for Independence Day. It seems to be isolated to MS Office 2007. Notepad open file dialog works with no problem. Any ideas?
    Tuesday, July 5, 2011 3:09 PM
  • I haven't heard a similar problem before, what happened before you got this problem? Any change on your system? Add any add-ins?

    Let's troubleshoot this issue follow the instructions below:

    Please try to start the Office program in safe mode

    1. Click Start, point to All Programs, and then point to Microsoft Office.
    2. Press and hold the CTRL key, and then click the Office program you want to start.

    If the problem does not occur in the safe mode, this issue might be related to some third-party add-ins in the Office program, we can try to disable them. Normally, you could do the following to disable the conflict add-ins in your Office program:

    Disable add-ins
    1. Click File menu, click Options > Add-in, click Go button in the Manage: Com-in Add.
    2. Check if there are any add-ins, clear the checkbox to disable them.
    3. Close the Office program and restart it.
    4. Add one check back each time to the list of Add-In, restart the Office program, and repeat the above procedure. Once the issue reappears again, we can determine which add-in causes this problem and then disable it.

     

    However, if the problem persists after this, we might need to repair the Office program from

    either: Start -> Microsoft Office -> Microsoft Office Diagnose
    or: Start -> Control Panel > Programs and Features, right click the Office program and choose Change, then Repair.

    Any questions, feel free to post back.


    Sincerely,

    Max Meng
    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    • Marked as answer by Max MengModerator Tuesday, July 12, 2011 6:50 AM
    • Unmarked as answer by thornburg Tuesday, July 12, 2011 3:56 PM
    Wednesday, July 6, 2011 2:02 PM
    Moderator
  • Hi there,

    I am writing to see how everything is going with this issue. Is the problem resolved? If there is anything I can do for you, please feel free to let me know.

    Sincerely,

    Max Meng
    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    Sunday, July 10, 2011 3:56 AM
    Moderator
  • Hi,

    As there has  been no update for a couple of days, I will temporary mark the reply as answer to closed this thread.
    And if you come back to find it doesn't work for you, please reply to us and unmark the answer, this thread will be re-opened.


    Sincerely,

    Max Meng
    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    Tuesday, July 12, 2011 6:50 AM
    Moderator
  • Max,

     

    Sorry about the delay. Work has inhibited my promptness. However, I appreciate yours. I was able to solve the problem.

     

    This issue is related to folder redirection and a few registry settings inside HKCU. It appears to me (since what I did solved the problem) that MS Office 2007 does not like a UNC path value inside the Shell Folders "Personal" key. This is not an issue for us as we are currently mapping the user's My Documents to a drive letter as well as using folder redirection.

     

    The solution was relatively simple. Modify the following registry setting as follows (for each user, of course):

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders]

    "Personal"="z:\\" #This is if z is the letter used for your user's My Documents mapping.

     

    Again, I'm not sure why Office 2007 doesn't like a UNC path in this registry value. The fact is that it doesn't. So mapping the network location of My Documents to a letter and modifying the registry is a solution that works.

     

    Very best regards.

    • Marked as answer by thornburg Tuesday, July 12, 2011 4:08 PM
    Tuesday, July 12, 2011 4:07 PM
  • I’m glad to hear that you resolve this issue.

    Thank you for sharing your solutions and experience here. It will be very beneficial for other community members who have similar questions.


    Sincerely,

    Max Meng
    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    Friday, July 15, 2011 7:49 AM
    Moderator