none
Central Administration not Available, STSADM password reset errors "job-admin-apppool-change" already exists RRS feed

  • Question

  • Hi Everyone,

    I think I've shot myself in the foot by not properly following set up instructions.

    I have a two-fold problem.  Firstly, my Sharepoint Central Administration V4 site is showing Service Not Available.  This seems to be related to the credentials the Central Administration V4 Application Pool - hitting Test Settings within IIS Manager for the site shows an Authentication and Authorization error for the credentials due to a bad password.

    My reading indicates that I should run something to the effect of:

    %STSADM -o updatefarmcredentials -userlogin DOMAIN\username -password <new password as set via AD>

    This runs into the following Error message

    Error deploying administration application pool credentials. Another deployment may be active. An object of the type Microsoft.SharePoint.Administration.SPAdminAppPoolCredentialDeploymentJobDefinition named "job-admin-apppool-change" already exists under the parent Microsoft.SharePoint.Administration.SPTimerService named "SPTimerV4".  Rename your object or delete the existing object.

     

    I've tried searching out a solution but as yet have been unable to find a mechanism to resolve this error.  I have had a look through http://social.technet.microsoft.com/forums/en-US/sharepointadmin/thread/b7c17dac-1cd1-4f75-a031-e28e4fbfd2f7 but it doesn't seem to relate to the same problems - as far as I know the account from which the command is being run is a farm administrator and the problem seems to be the existing job rather than permissions errors.

    Your help will be much appreciated.

     

    Stuart

    Wednesday, September 22, 2010 7:53 AM

Answers

  • Try adding -local to yoour command.

    %STSADM -o updatefarmcredentials -userlogin DOMAIN\username -password <new password as set via AD> -local

     

    Tuesday, November 29, 2011 7:27 AM

All replies

  • Hi Stuart Weaver,

     

    Firstly, please check if the SharePoint 2010 timer service is running. If not, please start it manually, then check the effect. In addition to this, you can try to run SharePoint configuration wizard, then check the effect.

     

    Note: when you start the SharePoint 2010 timer service, make sure you input the latest password. The steps are as follows:

     

    Open services.msc, locate the SharePoint 2010 timer service, double click it, then click log on tab, input the updated password, then click apply.

     

    Hope this helps.

     

    Rock Wang


    Regards, Rock Wang Microsoft Online Community Support
    Thursday, September 23, 2010 7:13 AM
  • Hi Rock,

     

    Thanks very much for your help.

     

    The SPTimerV4 service is running (I have tried it both ways, but the same issue occurs either way).

     

    I have just run through the configuration wizard and the external program wizard part has gone through OK.  I have entered all the of the details into the browser based part of the wizard and it has been on the Processing page for the past hour.

     

    EDIT:  It just refreshed to a connection failed, but, on the plus side, I can connect to central administration again.

     

    EDIT2: When I tried resetting a the farm administrator's password I got "Error - Requested registry access is not allowed". When I tried resetting a different user's password I got the following: "This operation uses the SharePoint Administration service (spadminV4), which could not be contacted. If the service is stopped or disabled, start it and try the operation again. "

    EDIT 3: When I run the command I mentioned above, I receive an "Access is denied" error.

     

    Cheers,

    Stuart

    Friday, September 24, 2010 6:55 AM
  • Stuart,

     

    Did you ever get an answer for this? I am having the same issue.

    Thursday, September 29, 2011 7:40 PM
  • Try adding -local to yoour command.

    %STSADM -o updatefarmcredentials -userlogin DOMAIN\username -password <new password as set via AD> -local

     

    Tuesday, November 29, 2011 7:27 AM
  • Hooray!  This worked for me.  Cheers, Rune.
    Wednesday, April 25, 2012 12:46 AM
  • This worked for me too!
    Thursday, October 10, 2013 2:38 PM
  • Thank you Rune, you saved my day! 
    Friday, April 24, 2015 12:46 PM