none
File Explorer not opening RRS feed

  • Question

  • Receive this error when opening explorer in SharePoint 2013 library:

    We're having a problem opening this location in File Explorer. Add this web site to your Trusted Sites list and try again.

    This error happens on the Windows 8.1 client and Windows Server 2012 R2.

    Using Windows 8.1 with all updates

    Tried IE 11 64bit and 32 bit same result

    Server is 2012 R2 datacenter with all updates

    SharePoint 2013 foundation with SQL express (out of the box setup)

    Web client installed and running on both Windows 8.1 and Server 2012 R2

    Added the site to both server and client in the trusted site area of IE

    I did installed the desktop experience on the server 2012 R2 and rebooted. I then checked to see if the webclient service was started and it was. However, I still get the same error from any Windows 8.1 box I use.

    Loaded up a fresh copy of Windows 8.1 and still received the same error. Tried again from the SharePoint 2013 Foundation server and still received the same error: We're having a problem opening this location in File Explorer. Add this web site to your Trusted Sites list and try again

    Please help with any other ideas.

    Tuesday, September 16, 2014 7:15 PM

Answers

  • OK Everyone,

    Here is the answer I came up with and it worked on the client and server both. Procedures for Office 2013 are also in there.

    I don’t think “Explorer View” will work until you edit your registry to support non-ssl websites.  Not only did MS lock down Office Products, I believe it locked down the WEBDAV protocol, which is used for “Explorer View”.   

    There are two configurations you must make.

    The first step will fix the Explorer View

    The Second step (install SharePoint Designer first) will Fix Designer.

    Step 1: Configure WebDAV Redirector on the client

    To enable Basic authentication on the client computer, follow these steps:

    In Windows Vista or Windows 7, click Start, type regedit in the Start Search box, and then press Enter.

    In Windows 8, hold the Windows key (WINKEY) + F, highlight Apps in the Menu bar, type regedit in the Search box, and then press Enter.

    Locate and then click the following registry subkey: 

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters

    On the Edit menu, point to New, and then click DWORD Value.

    Type BasicAuthLevel, and then press Enter.

    Right-click BasicAuthLevel, and then click Modify.

    In the Value data box, type 2, and then click OK.

    Note The mapping is as follows: 

    0 - Basic authentication disabled 

    1 - Basic authentication enabled for SSL connections only 

    2 - Basic authentication enabled for SSL and non-SSL connections

    Exit Registry Editor, and then restart the computer.

    Step 2: Update the Registry on the client

    Note This step is required for Office 2013 and Office 2010 applications.

    On the client computer, add the BasicAuthLevel registry key and an appropriate value. To do this, follow these steps.

    Important Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.

    Start Registry Editor. 

    In Windows 8, hold the Windows key (WINKEY) + F, highlight Apps in the Menu bar, type regedit in the Search box, and then press Enter. If you are prompted for an administrator password or for confirmation, type the password, or provide confirmation.

    In Windows 7 or in Windows Vista, click Start, type regedit in the Start Search box, then press Enter. If you are prompted for an administrator password or for confirmation, type the password, or provide confirmation.

    In Windows XP, click Start, click Run, type regedit, and then click OK.

    Locate and then click one of the following registry subkeys:

    For Office 2010

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet

    For Office 2013

    HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Common\Internet

    On the Edit menu, point to New, and then click DWORD Value.

    Type BasicAuthLevel, and then press Enter.

    Right-click BasicAuthLevel, and then click Modify.

    In the Value data box, type 2, and then click OK.

    Note The mapping is as follows: 

    0 - Basic authentication disabled 

    1 - Basic authentication enabled for SSL connections only 

    2 - Basic authentication enabled for SSL and for non-SSL connections

    Exit Registry Editor, and then restart the computer.

    • Proposed as answer by sgtjd Thursday, September 18, 2014 2:40 PM
    • Edited by sgtjd Thursday, September 18, 2014 2:44 PM
    • Marked as answer by Rebecca Tu Friday, September 19, 2014 5:21 AM
    Wednesday, September 17, 2014 5:35 PM
  • TL;DR - make sure you have a root (/) site collection for the web application.

    After trying many suggestions including hotfixes, registry edits, etc. we discovered the solution here:

    https://blogs.msdn.microsoft.com/george_bethanis/2013/11/04/sps13-open-with-explorer-random-error-were-having-a-problem-opening-this-location-in-file-explorer-add-this-web-site-to-your-trusted-sites-list-and-try-again/

    Cause: There is a missing Root site collection...

    Resolution:  Check and ensure, that the "Managed Paths" are not changed in the web Application's page, that there is a (root) explicit for this web application and there is a working root site collection.

    The key phrase being "and there is a working root site collection".


    Wednesday, June 1, 2016 4:49 PM

All replies

  • Hi Jackie,

    As I understand, you are using SharePoint foundation 2013 server on-premise. The issue occurs when you click Open with Explorer in a library. May I know if you could reproduce the issue on other client machine or other account? Please use 32-bit IE to test the issue for better experience. http://technet.microsoft.com/en-us/library/cc263526(v=office.15).aspx

    Please make sure your server is up to date since there is KB for similar issue.

    Then try to delete browser cache including cookies and clear automatically detect settings under Connections > Lan settings > Automatic configuration.

    And disable Antivirus to test the issue again.

    Check if you could map to drive and open SharePoint sites.

    If there is still issue, please collect ULS log for further troubleshooting.

    http://blogs.msdn.com/b/george_bethanis/archive/2013/11/04/sps13-quot-open-with-explorer-quot-random-error-quot-we-re-having-a-problem-opening-this-location-in-file-explorer-add-this-web-site-to-your-trusted-sites-list-and-try-again-quot.aspx

    Regards,

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com .


    Rebecca Tu
    TechNet Community Support


    • Edited by Rebecca Tu Wednesday, September 17, 2014 8:20 AM
    Wednesday, September 17, 2014 8:20 AM
  • As you said,you have already added the sites in Trusted but still see the error.I would recommend to follow the below.

    1.    Since SharePoint 2013 fully support IE 32-bit version above 7, there might be compatibility issue with other browsers. I’d recommend you use IE 8,9,10 32-bit for optimal Performance.
    2.    Open the same document library in Internet Explorer as this functions does not work with Firefox or Chrome by default
    3.    Make sure the IE (Internet Explorer) Version should be 32-bit and not a 64-bit

    http://expertsharepoint.blogspot.de/2014/08/open-with-explorer-is-disabled-in-for.html

    IE11 is having some issues:please find the link below.

    http://expertsharepoint.blogspot.de/2014/08/issues-with-sharepoint-2013-and.html


    Anil Avula[MCP,MCSE,MCSA,MCTS,MCITP,MCSM] See Me At: http://expertsharepoint.blogspot.de/

    Wednesday, September 17, 2014 8:47 AM
  • using SharePoint foundation 2013 server on-premise.

    The issue occurs when you click Open with Explorer in a library. May I know if you could reproduce the issue on other client machine or other account?
    I used two different accounts on three different machines.

    Please use 32-bit IE to test the issue for better experience. 
    Used IE 11 version: 11.0.9600.17278, 32bit version from this path: C:\Program Files (x86)\Internet Explorer

    Please make sure your server is up to date since there is KB for similar issue.
    Server is up to date. Has build: 15.0.4649.1001

    Then try to delete browser cache including cookies and clear automatically detect settings under Connections > Lan settings > Automatic configuration.
    Completed same error.

    And disable Antivirus to test the issue again.
    Removed virus protection same error.

    Check if you could map to drive and open SharePoint sites.
    Could not map to drive. Received this error:
    Mapped network drive did not work either:
    Error: The folder you entered does not apprear to be valid. Please choose another.

    path used:  http://site.domain.com/library  (library is the name of the document library)
    I also tried:
    http://site.domain.com/_layouts/15/start.aspx#/library/Forms/AllItems.aspx
    http://site.domain.com/_layouts/15/start.aspx#/library/Forms/
    http://site.domain.com/_layouts/15/start.aspx#/library/
    http://site.domain.com/library/

    However, when I pasted them in a browser they all worked.
    Is WebDAV an issue here. I don't see it in IIS. It must be embedded in SharePoint.

    If there is still issue, please collect ULS log for further troubleshooting.
    I found this:
    09/17/2014 13:25:20.20  w3wp.exe (0x2078)                        0x3310 SharePoint Foundation          Monitoring                     nasq Medium   Entering monitored scope (Request (OPTIONS:http://site.domain.com:80/library)). Parent No 
    09/17/2014 13:25:20.20  w3wp.exe (0x2078)                        0x3310 SharePoint Foundation          Logging Correlation Data       xmnv Medium   Name=Request (OPTIONS:http://site.domain.com:80/library) 276db99c-f08c-9045-0221-1c1fc29e286b
    09/17/2014 13:25:20.20  w3wp.exe (0x2078)                        0x3310 SharePoint Foundation          Authentication Authorization   agb9s Medium   Non-OAuth request. IsAuthenticated=False, UserIdentityName=, ClaimsCount=0 276db99c-f08c-9045-0221-1c1fc29e286b
    09/17/2014 13:25:20.20  w3wp.exe (0x2078)                        0x0C1C SharePoint Foundation          General                        af71 Medium   HTTP Request method: OPTIONS 276db99c-f08c-9045-0221-1c1fc29e286b
    09/17/2014 13:25:20.20  w3wp.exe (0x2078)                        0x0C1C SharePoint Foundation          General                        af75 Medium   Overridden HTTP request method: OPTIONS 276db99c-f08c-9045-0221-1c1fc29e286b
    09/17/2014 13:25:20.20  w3wp.exe (0x2078)                        0x0C1C SharePoint Foundation          General                        af74 Medium   HTTP request URL: /library 276db99c-f08c-9045-0221-1c1fc29e286b
    09/17/2014 13:25:20.20  w3wp.exe (0x2078)                        0x0C1C SharePoint Foundation          General                        af76 Medium   HTTP request translate header: f 276db99c-f08c-9045-0221-1c1fc29e286b

    Wednesday, September 17, 2014 5:29 PM
  • OK Everyone,

    Here is the answer I came up with and it worked on the client and server both. Procedures for Office 2013 are also in there.

    I don’t think “Explorer View” will work until you edit your registry to support non-ssl websites.  Not only did MS lock down Office Products, I believe it locked down the WEBDAV protocol, which is used for “Explorer View”.   

    There are two configurations you must make.

    The first step will fix the Explorer View

    The Second step (install SharePoint Designer first) will Fix Designer.

    Step 1: Configure WebDAV Redirector on the client

    To enable Basic authentication on the client computer, follow these steps:

    In Windows Vista or Windows 7, click Start, type regedit in the Start Search box, and then press Enter.

    In Windows 8, hold the Windows key (WINKEY) + F, highlight Apps in the Menu bar, type regedit in the Search box, and then press Enter.

    Locate and then click the following registry subkey: 

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters

    On the Edit menu, point to New, and then click DWORD Value.

    Type BasicAuthLevel, and then press Enter.

    Right-click BasicAuthLevel, and then click Modify.

    In the Value data box, type 2, and then click OK.

    Note The mapping is as follows: 

    0 - Basic authentication disabled 

    1 - Basic authentication enabled for SSL connections only 

    2 - Basic authentication enabled for SSL and non-SSL connections

    Exit Registry Editor, and then restart the computer.

    Step 2: Update the Registry on the client

    Note This step is required for Office 2013 and Office 2010 applications.

    On the client computer, add the BasicAuthLevel registry key and an appropriate value. To do this, follow these steps.

    Important Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.

    Start Registry Editor. 

    In Windows 8, hold the Windows key (WINKEY) + F, highlight Apps in the Menu bar, type regedit in the Search box, and then press Enter. If you are prompted for an administrator password or for confirmation, type the password, or provide confirmation.

    In Windows 7 or in Windows Vista, click Start, type regedit in the Start Search box, then press Enter. If you are prompted for an administrator password or for confirmation, type the password, or provide confirmation.

    In Windows XP, click Start, click Run, type regedit, and then click OK.

    Locate and then click one of the following registry subkeys:

    For Office 2010

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet

    For Office 2013

    HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Common\Internet

    On the Edit menu, point to New, and then click DWORD Value.

    Type BasicAuthLevel, and then press Enter.

    Right-click BasicAuthLevel, and then click Modify.

    In the Value data box, type 2, and then click OK.

    Note The mapping is as follows: 

    0 - Basic authentication disabled 

    1 - Basic authentication enabled for SSL connections only 

    2 - Basic authentication enabled for SSL and for non-SSL connections

    Exit Registry Editor, and then restart the computer.

    • Proposed as answer by sgtjd Thursday, September 18, 2014 2:40 PM
    • Edited by sgtjd Thursday, September 18, 2014 2:44 PM
    • Marked as answer by Rebecca Tu Friday, September 19, 2014 5:21 AM
    Wednesday, September 17, 2014 5:35 PM
  • Hello ,

    I have done the registry update, still i am not able to open the folder in explorer view, Please suggest the anything we need to perform.

    Thanks in advance.

    Wednesday, June 10, 2015 9:05 PM
  • TL;DR - make sure you have a root (/) site collection for the web application.

    After trying many suggestions including hotfixes, registry edits, etc. we discovered the solution here:

    https://blogs.msdn.microsoft.com/george_bethanis/2013/11/04/sps13-open-with-explorer-random-error-were-having-a-problem-opening-this-location-in-file-explorer-add-this-web-site-to-your-trusted-sites-list-and-try-again/

    Cause: There is a missing Root site collection...

    Resolution:  Check and ensure, that the "Managed Paths" are not changed in the web Application's page, that there is a (root) explicit for this web application and there is a working root site collection.

    The key phrase being "and there is a working root site collection".


    Wednesday, June 1, 2016 4:49 PM